It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Have a peculiar problem with the game. Played it earlier with my laptop hooked up to an HDTV, and it worked like a charm, the game took up all the space and it looked real spiffy.

But now, when I'm away, trying to play the game directly on the laptop's screen, the estate the game takes up is really tiny, with huge amount of black space filling up the rest of the screen!

I looked at the settings, and tried every mode there, tried to start it in window mode and force it to full-screen it via the alt+enter command, but nothing works! Even tried to right-click the icon, went to compability section and checked the "run in 640x480 resolution" option...

Any idea on how I may solve this problem?

Here are the specs: Core i5 2.53GHz, 4GB DDR RAM, Radeon 5650m, Windows 7 64-bit.
This question / problem has been solved by drennanimage
Open Catalyst Control Center (or whatever it's called nowadays) and try following the instructions here until you see the GPU scaling options, then pick "Maintain aspect ratio" (or "Scale image to full panel size" if you don't mind a squished image).
There are no GPU scaling options while not being connected through another screen :/
While on the laptop, that option disappears since (presumably) Catalyst finds no use of scaling...
Try switching the resolution of your built-in display to something that's not its native resolution and see if scaling options appear.
That worked! Weird how computers work sometimes... Such a roundabout way to make it work XD
Thank you very much!