It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Whenever I quit out of the game and reload it all the config, from controls to graphics, is forgotten.
Is there any way I can fix this issue? Or is it something that the GOG team have to sort out?
I didn't have this problem with XP. Just Windows 7. So it's probably down to where the config files are being stored. But I don't know what to do about it.
This question / problem has been solved by Namurimage
avatar
Navagon: Whenever I quit out of the game and reload it all the config, from controls to graphics, is forgotten.
Is there any way I can fix this issue? Or is it something that the GOG team have to sort out?
I didn't have this problem with XP. Just Windows 7. So it's probably down to where the config files are being stored. But I don't know what to do about it.

Have you tried to install it somewhere other than the default 'Program Files' directory ?
avatar
Namur: Have you tried to install it somewhere other than the default 'Program Files' directory ?

It's installed to F:\Games\Painkiller
Which is pretty much where all my games were installed to under XP (same physical drive, different letter). All without any problems.
avatar
Navagon: It's installed to F:\Games\Painkiller
Which is pretty much where all my games were installed to under XP (same physical drive, different letter). All without any problems.

I do have PK from gog, but i still haven't installed it on 7, just on XP.
Are you running it as admin ?
avatar
Namur: Are you running it as admin ?

As an account with admin privileges, yes (read: only account).
avatar
Namur: Are you running it as admin ?
avatar
Navagon: As an account with admin privileges, yes (read: only account).

You can always go to the shortcut and tick the 'run as admin' just to make sure...
avatar
Namur: You can always go to the shortcut and tick the 'run as admin' just to make sure...

Well, what d'ya know? It only went and bloody worked, didn't it? Solution is you!
Does that mean I'm going to have to do that for most games or is there a universal 'run as admin' option somewhere? I'd have thought that being the admin would have been enough. But I'm not up on all these newfangled OS.
avatar
Navagon: Well, what d'ya know? It only went and bloody worked, didn't it? Solution is you!
Does that mean I'm going to have to do that for most games or is there a universal 'run as admin' option somewhere? I'd have thought that being the admin would have been enough. But I'm not up on all these newfangled OS.

Well, i'm glad that worked ;)
I'm fairly new to win7 myself and i never had vista, but i think that even when running an admin account, there are different previleges assigned to apps...or something :)
As a rule, i always tick that box for games, but i can't say if it's really necessary to do so for every game/app...
avatar
Namur: Well, i'm glad that worked ;)
I'm fairly new to win7 myself and i never had vista, but i think that even when running an admin account, there are different previleges assigned to apps...or something :)
As a rule, i always tick that box for games, but i can't say if it's really necessary to do so for every game/app...

Most apps don't seem to have that problem from what I can tell. But I think I'll have to remember to do that with games.
If Windows 7 has the same setup as Vista for administrators then yes there is a way to always run as admin, but it requires a little tinkering.
Your standard setup is one user account which is an 'administrator' account. However, this isn't quite accurate. In Vista there is then a hidden 'true administrator' account. To get this carry out the following instructions:
Click on the Start button.
Click on Start Search.
Type cmd into the search field.
Right-click cmd, select 'Run as administrator' from the shortcut menu.
In the black 'DOS box', type the following at the command line:
Net user administrator /active:yes
Check the message : The command completed successfully.
Switch User, or logoff
From now on, the Administrator account will appear as an option on the Welcome screen, along with any user accounts you may have set up. Use it like any other account.
If you want to disable the account and hide it, enter this command at an elevated command prompt (but not whilst logged in using the administrator account itself) and press Enter:
Net user administrator /active:no
Bear in mind that these instructions are for Vista, but as Vista and Windows 7 are similar you may find that this works in Windows 7 too.
Post edited October 25, 2009 by korell