It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hellow everyone, so I'm new to GOG but i see they have some great games on here. SO i just bought painkiller black edition, and installed it on my vista machine. It lags. The lag is kinda weird, as it makes the game run in slow motion instead of just being choppy. I have all the settings turned down but it still does the same thing. Here are my specs, I know they are not great but I can run games like serious sam the second encounter, unreal tournament 2004, quake 3, and others witrhout problems but painkiller does the above. Specs:
intel core 2 duo 1.66 GHz
Intel Integrated Graphics (yes i know they suck)
220GB HDD
2GB DDR2 553 MHz RAM
Windows Vista 32 bit
So can someone please help me solve this problem? I really want to play this game. Thanks in advance.


EDIT:
also, I checked FPS and normally I'm getting 60 but when enemies appear i go down to about 20. So whats up with that? task manager says its using only around 70% cpu when fighting and I dont think its my video card.
Post edited July 29, 2011 by maximdymok
This question / problem has been solved by grviperimage
You've got too much power :) Switch the game to a single core either bu picking affinity in the task manager every time you run it or do the imagecfg voodoo.
Ah yes, I've tried that aswell - with task manager - but it doesn't seem to help much. Maybe makes it a little more choppy instead of the slow down effect, but still lags. Any other ideas?
What type on Intel graphics have you got there?
I'm not on the PC we are talking about currently, but, I do believe the GPU is Intel Express 965 family chipset. I'm not sure about the number though.
When you get back, try these tricks:
A. Back up the exe and give it imagecfg treatment. It might work better than task manager switch if the bug kicks it somewhere in the early loading sequences of the game.
B. Get 3D-Analyze and tell it to run the game exe with HW T&L Emulation on.
avatar
grviper: When you get back, try these tricks:
A. Back up the exe and give it imagecfg treatment. It might work better than task manager switch if the bug kicks it somewhere in the early loading sequences of the game.
B. Get 3D-Analyze and tell it to run the game exe with HW T&L Emulation on.
I already tried 3danalyze with HW thing and it didn't do anything at all, the Cfg thing I just tried and it makes it a little more choppy instead of slo-mo, which is exactly what task manager did. Also, strangely enough, if you use the -a 0x1 command when you start the game it crashes, however if you use the -a command it works, running on one core. Strange.
avatar
maximdymok: Strange.
Anything similar to this case?
http://www.gog.com/en/forum/painkiller_black_edition/running_in_slow_motion
avatar
maximdymok: Strange.
avatar
grviper: Anything similar to this case?
http://www.gog.com/en/forum/painkiller_black_edition/running_in_slow_motion
Yes, the exact thing... Except that the people there say when they experience slow-mo effect, their FPS is still fine, while in my case, especially when running the game on one core only, my FPS drops to about 30 AND does slow motion. Only happens when monsters appear.
Also, I don't know if that's the way to do it, but I tried creating a shortcut for the Painkiller.exe and adding -CPUSPEED=1600 to the end of location - that will make it run at that exact CPU speed, right? It didn't do anything.
Anyone? I'm still experiencing the problem.
avatar
maximdymok: Anyone? I'm still experiencing the problem.
I'm out of ideas. Time to hit GoG support!
avatar
maximdymok: Anyone? I'm still experiencing the problem.
avatar
grviper: I'm out of ideas. Time to hit GoG support!
Actually, they said they'd fix it but never did yet. I might have to return the game after all. Thanks for your help though, its always appreciated.