It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Well, one of the fine things about playing old games on modern hardware is, that loading times should not be that long. I am playing on some serious hardware, yet I have to find the loading times a tad annoying.
The machine seems to be just sitting there doing nothing for most of the time during the loading screens. CPU is barely reaching a load of 3%, disk activity stops after about 2 or 3 seconds and then I'm watching a loading screen which becomes a bit dull after a while.
Is there any way to speed up the loading times by decreasing a timeout value or something in the config file? I mean seriously, I have way faster loading times at other games that are much more demanding when it comes to hardware.
This question / problem has been solved by CameO73image
Nope, MAXMEM didn't sort it out either.
Edit: Meh, wrong clicky thing. Accidentaly marked Vorxions post as the solution, which it's obviously not.
Post edited March 12, 2009 by mhe
When the game was released, the developers themselves said that the load times in this game were "horrible". Unfortunately I don't think there's much you can do settings-wise to improve them.
As a benchmark, loading takes 20-25 seconds for me, E8500 / 4GB / HD4850 etc. 50 seconds sounds like a lot, but I bet it's some specific part of your hardware that Painkiller has a problem with, or is poorly optimized for. On older hardware (my old laptop for example), I get load times of 50 seconds and more too.
I've made my peace with this problem and just have to accept it. It just sucks compared to the instant saving and loading I have been spoiled by with the Unreal games here...
Those loading times are definitely caused by some system incompatibility. In comparison, my PC loads levels in about 5 seconds (!) Only the game startup takes a while ... maybe 10-15 seconds (and since there is no progress bar it almost seems to hang).
My specs are:
Windows 7 beta (64-bit)
Core2Duo E8400 @ 3.60GHz
Asus Geforce GTX260
4GB DDR2 RAM
Bose Companion 5 USB Audio
Running at 1680x1050, max details.
Figured it out! It turned out that forcing VSync to On (using for instance the NVidia Control Panel) is the cause of this. Just leave it at the default ("Let the application decide" which is effectively Off) and your loading times will decrease enormously!
Thanks for the solution! I really love vsync, but if it really makes such a difference, I'll keep it off for Painkiller.
avatar
mhe: Thanks for the solution! I really love vsync, but if it really makes such a difference, I'll keep it off for Painkiller.

Don't forget to mark CameO73's post as a solution to Your problem. He deserves a free cookie too! ;)
You're right, he deserves it!
Post edited March 30, 2009 by mhe
I don't get it. what is the solution? it goes from the first post saying " this is my problem" to "thanks for the solution." where's the solution?
avatar
Advoc: I don't get it. what is the solution? it goes from the first post saying " this is my problem" to "thanks for the solution." where's the solution?

Turn off Vsync in the Nvidia control panel. The solution is on the bottom of page 1.
Gog is weird and takes you to the last page by default. The Question post on this page is just carried over from the first page. Like I said, Gog is weird.
avatar
Advoc: I don't get it. what is the solution? it goes from the first post saying " this is my problem" to "thanks for the solution." where's the solution?

You need to go back to page one of the thread to read it (this is page two). The layout may be a bit confusing because the first post of the thread is shown at the top of both pages.
avatar
mhe: I've made my peace with this problem and just have to accept it. It just sucks compared to the instant saving and loading I have been spoiled by with the Unreal games here...

It's interesting you've said this. For the most part I agree with you because Unreal Gold, Unreal Tournament Gold and Unreal Tournament 2004 ECE all have very fast loading times on modern hardware. However, Unreal 2 is a very slow loading game even on modern tech and it is a common complaint about the game.
I have been playing this game in 3d with Nvidia 3d vision which forces vsync. I was wondering why load times were so long for me. Sadly there isn't much that I can do about it since this game looks so good in 3d.