It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Well, one of the fine things about playing old games on modern hardware is, that loading times should not be that long. I am playing on some serious hardware, yet I have to find the loading times a tad annoying.
The machine seems to be just sitting there doing nothing for most of the time during the loading screens. CPU is barely reaching a load of 3%, disk activity stops after about 2 or 3 seconds and then I'm watching a loading screen which becomes a bit dull after a while.
Is there any way to speed up the loading times by decreasing a timeout value or something in the config file? I mean seriously, I have way faster loading times at other games that are much more demanding when it comes to hardware.
This question / problem has been solved by CameO73image
I don't have a problem with the loading times at all, but I don't have a monster machine. It's possible that your "serious hardware" is actually causing the delay.
I'm assuming that you have a multi-core processor. Many older games have performance issues with them that can usually be easily resolved by setting the game executable's affinity to a single core. I'd start with that for now.
I think the load times have more to do with how it was coded and optimized then how powerful your rig is.
Just out of curiousity what are you using to play painkiller?
I'll give the core affinity idea a try, thanks in advance.
As for the hardware, I'm using a watercooled Q6600 quadcore at 3,2Ghz, 4GB of RAM, a slightly overclocked GTX 260 and a RAID 0 drive setup. It's usually enough to keep at least long loading times at bay, but I Painkiller doesn't seem to like my rig. Once loaded the game runs perfectly though.
The loading times for Painkiller are slow, even on fast machines. We are talking 10-20 seconds here, not that bad, but more than it could be. IF it's more than this, there is some other issue, the mentioned Core-Affinity, compatibility-mode settings and graphics drivers are the ones to check.
This is more to do with the way the game was coded/designed-to-load-data than PC power.
The affinity setting doesn't affect my problem at all. Maybe it's due to running Vista 64 (i know it sucks, but running it is unfortunately a necessity for me).
How long is it actually taking to load? Like Ois mentioned, the game does take 10-20 seconds to load by default, are you experiencing load times that are much beyond that?
I've made several attempts at loading levels, the average time it takes is about 50 seconds.
Whoa! That ain't right at all...
Do you have more than 4GB of RAM? If so, I've got a bizarre one to suggest... limit your RAM to 3GB or less. I have seen instances of older 32-bit games counter-intuitively choking on too much RAM. Rather than physically remove RAM, you can temporarily set the RAM lower in your boot.ini through msconfig. Just run msconfig, go to the BOOT.INI tab, click on the Advanced button and set the "/MAXMEM" flag to 3GB or less.
I'll give that a try shortly, but I am not very confident about it.
I use a 64bit OS, which means that all the limitations that affect 32bit Windows memory management in general do not apply here.
Some general technical background about the memory things here - it might be useful because it has been discussed to death on many forums:
A 32bit application in a 64bit Windows only gets 2GB of memory allocated, since this is the limit for userspace in 32bit Windows. 32bit architectures can use 4GB, but Windows splits this memory up into 2GB kernel space and 2GB userspace.
The often cited /3GB switch in boot.ini only shifts this split border more towards userspace, meaning userspace gets 3GB and kernelspace keeps 1GB. This might work for some apps, but generally can cause system instability because several device drivers, especially those for graphics cards, may assume that kernelspace is always 2GB for them, thus leading to bluescreens etc. To make matters worse, the additional gig of memory one gets by using the /3GB switch are only allocated to a running application if it's exe-file header has the LARGEADRESSAWARE flag set.
Anandtech did some very interesting arctiles about that stuff if you want to dig in deeper.
Long story short - /MAXMEM should do nothing for me because Painkiller can only get 2GB of memory as dedicated userpace, I seriously hope it can cope with that, because if it doesn't, it might be a bit far fetched to call it a 32bit app...
But I'm going to try it anyways in the interest of science. Thanks! :)
What speed does your harddrives run at? If its on the lower end this could account for longer load times regardless of them being in a raid 0 setup.
Actually, the problems I have seen with this are often directly related to drivers "misreading" the greater than 4GB RAM and reducing performance considerably, despite the use of a 64-bit OS. A prime example of this occurs with Vampire: Bloodlines where on systems with newer Nvidia hardware/drivers and more than 4GB of RAM, the drivers automatically reduce texture quality and performance to extremely poor levels. Setting the MAXMEM flag corrects that situation, so if you are getting something similar, it could resolve your issue.
Like I said, its a bizarre suggestion, but at this point, the only other thing I think we have left to "blame" is Vista 64, which doesn't really solve your problem.
avatar
Ralackk: What speed does your harddrives run at? If its on the lower end this could account for longer load times regardless of them being in a raid 0 setup.

Benchmarked the drive volume with a read performance of over 150MB/sec, so I find it hard to blame the drives themselves.
avatar
cogadh: Actually, the problems I have seen with this are often directly related to drivers "misreading" the greater than 4GB RAM and reducing performance considerably, despite the use of a 64-bit OS. A prime example of this occurs with Vampire: Bloodlines where on systems with newer Nvidia hardware/drivers and more than 4GB of RAM, the drivers automatically reduce texture quality and performance to extremely poor levels. Setting the MAXMEM flag corrects that situation, so if you are getting something similar, it could resolve your issue.
Like I said, its a bizarre suggestion, but at this point, the only other thing I think we have left to "blame" is Vista 64, which doesn't really solve your problem.

One never ceases to learn. Quite interesting facts you got there. Makes me a bit more optimistic about the MAXMEM thing. I'll give it a try and report back as soon as i have the time to do so.
Same load slowness on E8400 3GHz, 3GB, SATA 7200rpm, 8800GT. About 50sec. And it doesn't bother to cache like doom3. Seriously, doom3 loads faster. Oh, WinXP Home 32bit here.
Post edited March 12, 2009 by Resil
The only things in common so far are more than 2GB of memory, a Intel CPU and a nVidia graphics card. But at least I don't seem to be alone.