It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Here is my problem:

I've configured the game to my monitor resolution/refresh rate, but after the initial corporate logos and various titles drift by after launching the game, I get a black screen.

The sound/music is playing, and I have a visible mouse cursor (an armored hand), but no title/menu options.

If I randomly click around I can sometimes make the game start, but that is only through blind luck. After starting the game, everything works and looks perfect.

I've completely installed everything, including the 1.69 Hot Update suggested in other threads.
This question / problem has been solved by Tenkiimage
Have you tried to start the game using the nwmain.exe directly and setting compatibility options for the exe to WinXP SP 2?
Post edited October 28, 2010 by Grombart
avatar
Grombart: Have you tried to start the game using the nwmain.exe directly and setting compatibility options for the exe to WinXP SP 2?
I have tried starting it with the nwmain.exe, but I can't set it to that compatibility because I'm actually running XPSP2.

It is really, random -- I've "mapped" a spot on my monitor that should be the Load Game button, but it only works 20% of the time. I can always click it and move through options, but the video only displays that small percentage.
when you can get into the game, if you quit back to the menu does the menu display or go back to the black screen?
avatar
Aliasalpha: when you can get into the game, if you quit back to the menu does the menu display or go back to the black screen?
Everything displays perfectly afterward. That is what is really tripping me up.
well that rather buggers the corrupted file idea. Does it display if you ALT+TAB out to the desktop and go back? SOMETIMES stuff like that helps, in the compatibility options for XP, does it have an option something like 'disable desktop composition'? I'd look but my XP machine is like 2 metres away and I'm comfy sitting here
avatar
Aliasalpha: well that rather buggers the corrupted file idea. Does it display if you ALT+TAB out to the desktop and go back? SOMETIMES stuff like that helps, in the compatibility options for XP, does it have an option something like 'disable desktop composition'? I'd look but my XP machine is like 2 metres away and I'm comfy sitting here
It does not have that option. Please see attached photo of my compatibility screen.

ETA: If I have the black screen, I can't ALT+TAB out. Only CTRL+ALT+DELETE will get me out of the program. After bailing and then going back to it, no changes -- still black. The only thing that fixes it is random, chaotic, and lucky clicking.
Attachments:
Post edited October 28, 2010 by DAEvo
I am having this problem as well. I'm curious, are you using a laptop like I am?

It's probably not XP specific, since I'm running on Win7 Pro.
avatar
Tenki: I am having this problem as well. I'm curious, are you using a laptop like I am?

It's probably not XP specific, since I'm running on Win7 Pro.
No, Tenki -- I'm not using a laptop. Desktop system, flatscreen monitor. 1024x1280, but problem occurs at every workable resolution.

Do you find that you also lose AL+TAB and other functionality when in "black screen" mode?
avatar
DAEvo: No, Tenki -- I'm not using a laptop. Desktop system, flatscreen monitor. 1024x1280, but problem occurs at every workable resolution.

Do you find that you also lose AL+TAB and other functionality when in "black screen" mode?
Yea, I was. I just did some research and at least PART of it is related to an old NVIDIA driver bug. problem is, if you're using older cards, like my laptop (geforce go 6150) they haven't updated those at all for years I found a modded recent driver files my latop could use here: http://forums.laptopvideo2go.com/topic/27279-v25947-windows-7vista-32bit-hpcompaq-oem-inf/ that solved the problem for me at least. You grab the driver file, extraxt it, and then replace the .inf file that was in the driver with the one they have linked at the top. Naturally it's a bit your mileage may vary, and use at your own risk, but the game is working for me at least.
avatar
DAEvo: No, Tenki -- I'm not using a laptop. Desktop system, flatscreen monitor. 1024x1280, but problem occurs at every workable resolution.

Do you find that you also lose AL+TAB and other functionality when in "black screen" mode?
avatar
Tenki: Yea, I was. I just did some research and at least PART of it is related to an old NVIDIA driver bug. problem is, if you're using older cards, like my laptop (geforce go 6150) they haven't updated those at all for years I found a modded recent driver files my latop could use here: http://forums.laptopvideo2go.com/topic/27279-v25947-windows-7vista-32bit-hpcompaq-oem-inf/ that solved the problem for me at least. You grab the driver file, extraxt it, and then replace the .inf file that was in the driver with the one they have linked at the top. Naturally it's a bit your mileage may vary, and use at your own risk, but the game is working for me at least.
Great find, Tenki. Thank you. I'm going to dig into that route and see what I find out. This is certainly an older video card and I suspect this is just the problem, even though I have applied all available updates.

I'll post more about my desktop solution as I figure it out.


Tenki has is correct -- this is a problem specific to my card, my driver, and my stupidity.

The NVIDIA site has an update from this week that sorted all of my problems. Updating through Windows XP when this problem started actually enabled a worse and older driver, so, even though I thought I was getting everything up-to-date, I was actually compounding the problem.

All in all, problem solved. Driver problem -- who would have thought it? Oh, everyone. [hangs head in shame]
Post edited October 28, 2010 by DAEvo
avatar
Tenki: Yea, I was. I just did some research and at least PART of it is related to an old NVIDIA driver bug. problem is, if you're using older cards, like my laptop (geforce go 6150) they haven't updated those at all for years I found a modded recent driver files my latop could use here: http://forums.laptopvideo2go.com/topic/27279-v25947-windows-7vista-32bit-hpcompaq-oem-inf/ that solved the problem for me at least. You grab the driver file, extraxt it, and then replace the .inf file that was in the driver with the one they have linked at the top. Naturally it's a bit your mileage may vary, and use at your own risk, but the game is working for me at least.
avatar
DAEvo: Great find, Tenki. Thank you. I'm going to dig into that route and see what I find out. This is certainly an older video card and I suspect this is just the problem, even though I have applied all available updates.

I'll post more about my desktop solution as I figure it out.


Tenki has is correct -- this is a problem specific to my card, my driver, and my stupidity.

The NVIDIA site has an update from this week that sorted all of my problems. Updating through Windows XP when this problem started actually enabled a worse and older driver, so, even though I thought I was getting everything up-to-date, I was actually compounding the problem.

All in all, problem solved. Driver problem -- who would have thought it? Oh, everyone. [hangs head in shame]
Not sure this is solved..... I have exactly this issue running on an asus 1001p netbook with integrated intel 3150 graphics, so not just related to NVIDIA?

I have updated to latest graphics drivers with no joy :/
I have tried over and over to fix this problem. Screen hangs/black/crash after titles. I have tried all of the suggested fixes via the site suggestions, with no luck. I have tried sening e-mails requesting tech support via propper methods, along wit my dxdiag file. and after 1 1/2 months I still have gotten no responses, other than the one sent asking for a refund (told no). I really want to play this game, and I am really sprised at the horendous customer service I have recieved. I am at a loss
Did you try setting SafeMovie=1 in the ini file? Also, run it from nwmain.exe rather than the launcher. In compatibility settings, try checking "Disable visual themes" and "Disable desktop composition".
I also suffered the black screen freeze after the opening cut scene problem. After trying all the suggested remedies, I gave up in frustration. Just last week I upgraded my graphics cards from 2 Nvidia GeForce 7800 GT's running in SLI mode to 2 GeForce 9800 GT's with SLI. This solved the problem and NeverWinterNights Diamond now runs smoothly with no problems or crashes. This verifies for me that the cause of the problem was the GPU's or the GPU's drivers. I hope this narrows down the solution for users experiencing a similar problem.
Post edited May 14, 2011 by DocRemo