It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hello guys.

I'm currently suffering from a problem with camera controls in NWN2 with really oversensitive panning when i move the mouse to the edge of the screen. It's making non-paused combat and navigation a bit troublesome as a slight nudge can cause the camera to circle the character multiple times.

Adjusting the sensitivity within the program seems to make no difference, strangely enough. Is there anything I can change in the config files that could help deaden the responsiveness please?
Post edited June 15, 2014 by Gl1tch
avatar
Gl1tch: Hello guys.

I'm currently suffering from a problem with camera controls in NWN2 with really oversensitive panning when i move the mouse to the edge of the screen. It's making non-paused combat and navigation a bit troublesome as a slight nudge can cause the camera to circle the character multiple times.

Adjusting the sensitivity within the program seems to make no difference, strangely enough. Is there anything I can change in the config files that could help deaden the responsiveness please?
These are my camera settings. Go into your \Documents\Neverwinter Nights 2\ folder and BACK UP nwn2player.ini, then open the original in notepad and replace your current 'character mode', 'exploration mode' and 'strategy mode' settings with these:

[Character Mode Options]
Mousewheel_Speed_Min=1.000000
Mousewheel_Speed_Max=10.000000
Mousewheel_Speed_Default=5.050000
Mousewheel_Speed_Current=2.170000
Mouse_Turn_Min=0.050000
Mouse_Turn_Max=3.000000
Mouse_Turn_Default=1.000000
Mouse_Turn_Current=0.286000
Edge_Turn_Min=3.000000
Edge_Turn_Max=10.000000
Edge_Turn_Default=5.000000
Edge_Turn_Current=3.000000
Camera_Lag_Min=0.000000
Camera_Lag_Max=0.000000
Camera_Lag_Default=0.000000
Camera_Lag_Current=0.000000
Fade Objects=0
Show Move Cursor=1
Mouseover Highlight Flags=32767
CameraMode=0
LeftClickAction=1
Ceiling Draw Mode=1
PossessAsDefault=1
CameraFollowAlways=1
MouseMovement=1
Enable ScreenEdgeCameraTurn=0

[Exploration Mode Options]
Mousewheel_Speed_Min=8.000000
Mousewheel_Speed_Max=50.000000
Mousewheel_Speed_Default=25.000000
Mousewheel_Speed_Current=9.260000
Mouse_Turn_Min=0.050000
Mouse_Turn_Max=5.000000
Mouse_Turn_Default=3.500000
Mouse_Turn_Current=0.495500
Edge_Turn_Min=0.800000
Edge_Turn_Max=5.000000
Edge_Turn_Default=3.000000
Edge_Turn_Current=1.200000
Edge_Move_Min=0.200000
Edge_Move_Max=3.000000
Edge_Move_Default=1.000000
Edge_Move_Current=1.040000
Keyboard_Move_Min=1.000000
Keyboard_Move_Max=10.000000
Keyboard_Move_Default=5.000000
Keyboard_Move_Current=2.440000
Fade Objects=1
Show Move Cursor=1
Mouseover Highlight Flags=32767
CameraMode=1
LeftClickAction=1
Ceiling Draw Mode=0
PossessAsDefault=1
CameraFollowAlways=0
MouseMovement=1
Enable ScreenEdgeCameraTurn=0
Enable ScreenEdgeCameraMove=1

[Strategy Mode Options]
Mousewheel_Speed_Min=8.000000
Mousewheel_Speed_Max=75.000000
Mousewheel_Speed_Default=25.000000
Mousewheel_Speed_Current=17.380001
Mouse_Turn_Min=0.050000
Mouse_Turn_Max=5.000000
Mouse_Turn_Default=3.500000
Mouse_Turn_Current=0.941000
Edge_Turn_Min=3.000000
Edge_Turn_Max=8.000000
Edge_Turn_Default=5.000000
Edge_Turn_Current=3.900000
Edge_Move_Min=0.250000
Edge_Move_Max=6.000000
Edge_Move_Default=3.000000
Edge_Move_Current=1.285000
Keyboard_Move_Min=0.500000
Keyboard_Move_Max=10.000000
Keyboard_Move_Default=5.000000
Keyboard_Move_Current=0.880000
Fade Objects=1
Show Move Cursor=1
Mouseover Highlight Flags=32767
CameraMode=4
LeftClickAction=3
Ceiling Draw Mode=2
PossessAsDefault=1
CameraFollowAlways=0
MouseMovement=1
Enable ScreenEdgeCameraTurn=0
AutoCenterFreeCam=0
SelectedCharacterCursor=0
Enable ScreenEdgeCameraMove=1

If that doesn't help, check your mouse control panel. It may have oversensitive settings for games like NWN2. Your mouse control panel may have the option to create profiles.
Post edited June 15, 2014 by Hickory
Perfect, Thanks Hickory!

I will give it a try and see what i can do :) Might do a little bit of side by side comparison to get an idea of what's throwing it out as well.
You can also turn off the screen-edge panning in the regular options screen if you don't like it at all, like me.