It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I downloaded all applicable "Critical Rebuild" patches for this version of the game. This includes the "NWN Original v1.69", "NWN Hordes of the Underdark v1.69", and "NWN Shadows of Undrentide v1.69".

Only the "NWN HotU v1.69" Critical Rebuild patch works properly. All others give me a "You can't use this patch with your version of Neverwinter Nights" error message.
This question / problem has been solved by frankd3image
avatar
predcon: Only the "NWN HotU v1.69" Critical Rebuild patch works properly. All others give me a "You can't use this patch with your version of Neverwinter Nights" error message.
The Bioware download page lists the HOTU patch is also for the Platinum and Diamond (the one GOG sells) editions.
avatar
predcon: Only the "NWN HotU v1.69" Critical Rebuild patch works properly. All others give me a "You can't use this patch with your version of Neverwinter Nights" error message.
avatar
Kezardin: The Bioware download page lists the HOTU patch is also for the Platinum and Diamond (the one GOG sells) editions.
Ah, ok. Still, as incomplete as the GoG version is, I wish the other two patch packages would at least go over the files they're meant to patch, for posterity or something. You know, just in case there are actually files that are found in them that aren't found in the HOTU patch.

On the other hand, if all files that are going to be patched can be found in the HOTU patch, then I guess I don't need to worry about the other two.
According to this post the GOG version should now be fixed.

http://www.gog.com/en/forum/neverwinter_nights_diamond/patch_is_needed/post12

But nobody has confirmed it yet.
avatar
frankd3: According to this post the GOG version should now be fixed.

http://www.gog.com/en/forum/neverwinter_nights_diamond/patch_is_needed/post12

But nobody has confirmed it yet.
I guess that since that's the only one that'll work, then that's the only one I'll need. I'm still going to install the CEP though.