It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hi guys,

Im getting a wierd and annyoing glitch where the light effects / glow from torches, lamps and the like pass through the walls and pillars anyone knows how to fix this?

I ve searched the web and messed with all in-game settings and could not fix this.
Post edited June 28, 2014 by Takezow
This question / problem has been solved by AGhost_7image
That would have to be one of the engine's "features"... There isn't anything you can do about that, other than working around the problem by designing accordingly.
wow.. feature then.. well that sucks

Im not even modding or anything like that, just playing through the campaing

thanks a lot for the info man
Post edited June 28, 2014 by Takezow
It shouldn't be that way.

You can try to edit the nwn.ini file (it is in the main NWN folder). It's a simple text file that you can edit with Notepad or a similar program (I recommend Notepad++). There are a couple of lines regarding the lighting and shadows in the game. For example:

EnableEnvironmentShadows=1 (if the value is 0, change to 1)
CreatureShadowDetail=2
NumDynamicLights=8
NumShadowCastingLights=3

Play with values of these lines (these are taken from my nwn.ini) and see if it's gonna help.
thanks for your reply Kerebron, but none of these settings fixed it.

Im talking specifically about the glow effect that braziers, torches and lamps emit.

I can see this effect through pillars, statues and certain wall parts..
You should be able to fix this using the auroa toolset and manually adjusting the tile lighting, but that may be a bit more work than warranted. Alternatively, you could try a graphics override to make the game look prettier. Some of them may fix lighting issues, but given I personally don't use them, I can't really recommend any one in particular.
Checking www.neverwintervault.org is your best bet currently.
There used to be (in fact, there still is) a similar problem with Nvidia graphics drivers when using SLI (multiple graphics cards) in the Witcher and Nexus games, where lights shine through solid surfaces. Are you using Nvidia cards in SLI? If so, disabling it may help (NWN is hardly likely to need SLI with any fairly recent Nvidia cards).
There is even a mention of this issue in Bob Hall's NWN2 Toolset Notes. Its quite exhaustive, and the only fix for this issue which is mentioned is what Nidhoegger has already suggested (see Volume I, page 86).
@AstralWanderer

I dont run a SLI setup, and ironicly enough i have had this issue with W1 as well hehe. Anyways, thanks for the suggestion.

@AGhost_7

Yeah, I messed up with every possible setting and even ended up diggin some old NWN CDs I had.

Even v1.1 comes with this annoyance and there s no setting that will fix this.

I guess the possible solutions are to mess up with light effects within the tool set , which I have absolute no idea how to use, so its actually not an option; or

try to find a mod which overrides the effect with a smoother or invisible one.

anyways, guess I ll just suck it up and try to ignore this, been having some serious fps with NWN anyways...

thanks a lot for the help guys!
Post edited July 03, 2014 by Takezow
avatar
Takezow: or try to find a mod which overrides the effect with a smoother or invisible one.
Well, you could try installing NWshader? - an OpenGL graphics wrapper. It might help with your issue because it uses a different rendering system. Besides it improves the look of NWN1 even when not adding any shaders (better draw distance and no fog, etc).

Here is the summary page with some screens - NWshader.

I had trouble getting the newest release to work (the settings GUI for "Chronepsis 0.2.2.3" was messed up), so I would recommend the "Bahamut_0214" release. I've been using it since I started NWN a few years ago, no problems.

You simply unzip it into your NWN1 install folder, then run "NWShader GUI.exe" (inside the nwshader folder) to set options if you want.
Post edited July 08, 2014 by anamorphic
avatar
Takezow: or try to find a mod which overrides the effect with a smoother or invisible one.
avatar
anamorphic: Well, you could try installing NWshader? - an OpenGL graphics wrapper. It might help with your issue because it uses a different rendering system. Besides it improves the look of NWN1 even when not adding any shaders (better draw distance and no fog, etc).

Here is the summary page with some screens - NWshader.

I had trouble getting the newest release to work (the settings GUI for "Chronepsis 0.2.2.3" was messed up), so I would recommend the "Bahamut_0214" release. I've been using it since I started NWN a few years ago, no problems.

You simply unzip it into your NWN1 install folder, then run "NWShader GUI.exe" (inside the nwshader folder) to set options if you want.
Thanks man, I ll have a look at that later.

For some bizarre reason my framerate keeps oscillating between 40 and 120 fps in game, no matter what Im doing, so Im trying to fix this 1st.
avatar
Takezow: For some bizarre reason my framerate keeps oscillating between 40 and 120 fps in game, no matter what Im doing, so Im trying to fix this 1st.
Can you force Vertical Sync in your graphics card control panel?

It sounds like you might be having graphics driver issues. Newer drivers sometimes break older games, so you could try rolling back to a driver version from a few years ago or something.

For example, according to this person VSync might not work at 1920x1080.