It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I found that the biggest part of fixing the stuttering issues was turning the CPU affinity to "All Cores". Rather than set it manually every time through Task Manager, is there a line I can put into an ini file somewhere that will achieve this setting?
This question / problem has been solved by Mattocoimage
avatar
predcon: I found that the biggest part of fixing the stuttering issues was turning the CPU affinity to "All Cores". Rather than set it manually every time through Task Manager, is there a line I can put into an ini file somewhere that will achieve this setting?
In the ini file... no, though a quick google search led me to this: http://www.robpol86.com/index.php/ImageCFG
No, NWN is finicky enough without using a third-party utility. There's a line in "nwnplayer.ini" that says "Client CPU Affinity=0". How do I modify it to use all cores? Do I set it to "0123" or do I use semicolons, as "0;1;2;3"?

[EDIT]
The answer is "No". Using semicolons or commas to separate the digits doesn't work, and using all four in a row doesn't either.
Post edited January 06, 2011 by predcon
Have you tried setting the Affinity value to -1 or -2? I believe one or the other disables CPU Affinity to make the game use all available cores.

v1.69 Patch notes:

- Added new option to the nwtoolset.ini file to set the toolset CPU affinity
on multi-core computers. If you have more than one CPU on your PC, then
you can use this setting to make the toolset run on only one of the CPUs
by specifying the number of the CPU (0-31). Setting "CPU Affinity=-1"
will turn off CPU affinity
(default 0).
[Start Up]
"CPU Affinity".
- The nwnplayer.ini setting for "Client CPU Affinity" now defaults to 0 (a
setting of -1 will be converted to 0). If you need to disable this
feature set the value to -2.

So -2 is the value to use, not -1.
Post edited January 06, 2011 by Mattoco
IN other words, the default tries to use all cores anyway.

All the advice is dedicated to the idea that it is usually a bad idea and NWN runs better using one core. YMMV.

Good Luck :)
avatar
Mattoco: Have you tried setting the Affinity value to -1 or -2? I believe one or the other disables CPU Affinity to make the game use all available cores.

v1.69 Patch notes:

- Added new option to the nwtoolset.ini file to set the toolset CPU affinity
on multi-core computers. If you have more than one CPU on your PC, then
you can use this setting to make the toolset run on only one of the CPUs
by specifying the number of the CPU (0-31). Setting "CPU Affinity=-1"
will turn off CPU affinity
(default 0).
[Start Up]
"CPU Affinity".
- The nwnplayer.ini setting for "Client CPU Affinity" now defaults to 0 (a
setting of -1 will be converted to 0). If you need to disable this
feature set the value to -2.

So -2 is the value to use, not -1.
-2 works. Again, when used in conjunction with "Miles 2D Audio", all stuttering is cleared up on my PC. Especially the Bink movies, which was the worst culprit. I still can't get the movies to play from the "Movies" menu (that is, the visuals. The audio track will play, but no video) , though. They'll only play in the normal course of gameplay.