It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hey everyone.
NWN plays great on the computer, except my character and all of the NPCs are invisible. All I see is my shadow. Really weird. I have an ATI HD 4800. I'v done all of the updates and even changed to ADMIN for Win 7. I've been playing with the in-game video controls and nothing seems to help my character appear. Everything else is great. Textures, frame rates, etc.
Has anyone had this problem?
If you have any suggestions let me know.
Post edited December 09, 2010 by CptRoboto
This question / problem has been solved by Kezardinimage
avatar
CptRoboto: If you have any suggestions let me know.
Enabling Catalyst AI seems to fix this problem sometimes - or you try the solutions offered in the third thread : :

http://gregattack.com/2008/07/26/neverwinter-nights-radeon-invisible-characters-missing-textures-just-shadows-bug/

http://nwn.bioware.com/forums/viewtopic.html?topic=681985&forum=49

http://nwn.bioware.com/forums/viewtopic.html?topic=568235&forum=42
Post edited May 31, 2011 by Funke
Worked perfect!
Thanks a million.
avatar
CptRoboto: If you have any suggestions let me know.
avatar
Kezardin: Enabling Catalyst AI seems to fix this problem sometimes - or you try the solutions offered in the third thread : :

http://gregattack.com/2008/07/26/neverwinter-nights-radeon-invisible-characters-missing-textures-just-shadows-bug/

http://nwn.bioware.com/forums/viewtopic.html?topic=681985&forum=49

http://nwn.bioware.com/forums/viewtopic.html?topic=568235&forum=42
avatar
CptRoboto: Worked perfect!
Ahhh glad it is solved. For other users who might have the same problem and an ati card, it can sometimes be fixed by unchecking the 'enable environment shadows on characters' option under the ingame video settings. Getting different drivers can also be a solution.

:)
Just bought the game and I have the same problem... all characters are invisible for me. Win 7 64bit, ATI HD 5850. The previous solution links don't work for me nor does anything else. Any hints? What do I actually have to do?

I'm starting the game directly (nwmain.exe) because going through the standard menu it just crashes for me. Also the configuration utility tells me that I don't have OpenGL installed (which is ridiculous as all other games work just fine).

Any guidance? Thank you!
avatar
frostschutz: Just bought the game and I have the same problem... all characters are invisible for me. Win 7 64bit, ATI HD 5850. The previous solution links don't work for me nor does anything else. Any hints? What do I actually have to do?

I'm starting the game directly (nwmain.exe) because going through the standard menu it just crashes for me. Also the configuration utility tells me that I don't have OpenGL installed (which is ridiculous as all other games work just fine).

Any guidance? Thank you!
I wouldn't trust the config utlity, but might be worth checking the open GL thing. DOn't many games now use something else??

Anyway, nasty fix is to turn off "show environmental effectsa on characters" from video options inside the game. Better fix is check video drivers. I have v8.881.0.0 which work wonderfully. Hope those ideas help.

Good Luck :)
avatar
shia_luck: I wouldn't trust the config utlity, but might be worth checking the open GL thing. DOn't many games now use something else??
I use Windows for gaming only and I have like >100 3D games (Steam, GOG, and some oldies that I already had or ordered cheaply from Amazon). I'm fairly sure that some of them are using OpenGL rather than Direct3D...

I'm not sure which ATI driver version I'm using - Windows Update and Steam provide me with driver updates every so often, so it should usually be the latest one.

I'll experiment a bit more with this later. I noticed that GOG has a support article that suggests I have to download some directx thing - but it links to a microsoft server and the download goes at <10kb/s for me (on a 16mbit line) which is extremely frustrating.

Thanks for your reply. I hope I can resolve the issue :)
Okay, disabling the "Environment Mapping on Creatures" setting makes the characters visible.

I didn't try this option yesterday unfortunately.

In the meantime I've installed that DirectX runtime and updates ATI drivers to the latest version.

However apparently doing this broke something else: The movies don't show anymore. I hear the audio but the video just doesn't show. Not when starting a new game (it keeps showing the loading screen while the movie audio plays). Not through the movies selection menu (it keeps showing the menu while it plays the movie audio only). So I lost movie video playback capability somewhere along the road.

Not sure what I did to break this now; I think I'll just remove the entire game and attempt a reinstall.
programs>>accessories>>system tools>>system information will tell you your driver version.

Movies not working is a common and sometimes unfixable solution.

Things you can try:
1. in nwn.ini (in your nwn folder, opens with notepad) change the safemovie line to = 1
2. I remmbr reading somewhere about downloading the bink video package (the movies are bink files). Can't find the link for this tho soooooo, but it might give you an avenue to explore.

Anyway, unless you really really want the movies.... I'd just worry about getting the right drivers.

Good Luck :)
avatar
shia_luck: Movies not working is a common and sometimes unfixable solution.
Thanks, they're back in working order after a reinstall.

1. in nwn.ini (in your nwn folder, opens with notepad) change the safemovie line to = 1
I think this was the hint I needed. When trying to edit the ini file with notepad, I noticed it was write protected. Removing the write protection and setting resolution and safemovie directly in the ini file seems to have resolved all issues I had so far. I still get a slight skipping of sound in the movies but I decided to not care about it as long as it doesn't happen inside the game itself.

Thanks again!