It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I've gone through the various topics about graphical glitches, and I haven't found any solution to this problem.

Whenever I'm in an area with water in it, the game starts lagging and the surface of the water is flashing and looks like in the screenshot.
I've already been through and sorted out the silverskin problem, crashes during movies, etc. Got the DirectX june redist, drivers are up-to-date, and the critical rebuild does nothing to fix this problem.

I have a Radeon 3200 HD and run 64-bit Windows 7.
Attachments:
This question / problem has been solved by Mattocoimage
Go into your video settings and disable Shiny Water. ATI cards are generally unable to effectively use this feature.
Post edited May 31, 2011 by Funke
Yeah, the Shiny Water option is broken.
avatar
Mattoco: Go into your video settings and disable Shiny Water. ATI cards are generally unable to effectively use this feature.
Fixed the water glitch, thanks!
I still get lag in some areas, though.