It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hey guys!

First of all, I was very happy to see this gem put up for sale. It runs surprisingly well overall but there's one little problem I'm facing:

I can't view any of the campaign intro and cutscene videos! They do play, since I can hear the sounds and press "esc" to skip it (i.e. the game doesn't crash), but I'm not getting any visuals at all. :/

Anyone have any ideas of how I can fix this? I don't have any video codecs or anything like that installed (at least not to my knowledge) and I can see the initial Atari / Bioware videos when I start the game.

I'd be greatful for any help...

/Garenth
Post edited October 28, 2010 by Garenth
This question / problem has been solved by Nacimotaimage
Were you trying to watch them from the main menu?

Mine only show when i start a campaign, if i want to view them via the main menu i have the same issue, but well, it doesn't really matter as long as they work when playing the game...
They're bugged while playing the game as well. When I start a new campaign the game loads and then the video starts playing - only I'm stuck looking at the loading screen while I hear the video being played. If I press "esc" and skip the video, it jumps straight to the game.
Just to be sure: Did you already try to start the game directly through nwmain.exe and setting compatibility to WinXP SP2, as well as check the Run as Admin, Disable Visual Designs and Disable Desktop Composition boxes?

That's how it works for me at least... Win7 32bit here.
Post edited October 28, 2010 by Grombart
high rated
This is a known issue with Neverwinter Nights; it was supposed to be fixed with the last patch but that doesn't seem to be the case for many people. Hopefully the developers will fix it properly in the future.

In the meantime, I would suggest playing with your compatability settings as Grombart says above. If you're still having problems and want to watch them, you can download Bink from RAD Game Tools and watch them outside of the game, or possibly find them on YouTube.

RAD Game Tools - Bink Video

Further reading:
http://nwn.bioware.com/forums/viewtopic.html?topic=581474&forum=49
http://nwn.bioware.com/forums/viewtopic.html?topic=620007&forum=49
http://nwn.bioware.com/forums/viewtopic.html?topic=598005&forum=49

Edit:

ACDude800 appears to have found a solution on the AMD forums for people using Radeon graphics cards and chipsets:

- Disable desktop composition on nwmain.exe
- Download a fixed binkw32.dll from the following site:

http://www.mediafire.com/file/0mfgzd40nk0/binkw32_ati.zip

In your NWN installation directory, Rename the existing binkw32.dll to binkw32_ati.dll and extract the downloaded binkw32.dll into the folder

If shiny water does not work for you, disable it.

I have confirmed that this fix does work, having said that you should be cautious of updating DLLs because it is hard to know how the program utilizes the library and what things have changed betweens versions of said library
Post edited October 30, 2010 by Nacimota
Have the same issue in Vista (I blame Vista for everything! :)), but with the RAD Game Tools that Nacimota mentions I am able to watch cutscenes outside the game. Not ideal, but an acceptable solution, for me at least.
I'm also having this problem and submitted a ticket to support with Dxdiag. I tried replacing the binkw32.dll with newer versions and it either crashes or has the same behavior (of not playing the videos inside the game). Installing the newest rad tools had zero effect, but I can at least watch the videos as needed. Your staff must have noticed this problem while testing this game....right? heh

Please look into this gog :)
avatar
Nacimota: If you're still having problems and want to watch them, you can download Bink from RAD Game Tools and watch them outside of the game, or possibly find them on YouTube.
I think I can live with that. Thanks for the information! I'll mark your post as "solution" since there doesn't seem to be a permanent fix for this... at least not yet.
I have the same problem. I work around it by playing the game windowed. Windowed the movies will play.
avatar
TaliaKirana: I have the same problem. I work around it by playing the game windowed. Windowed the movies will play.
I wondered if that would actually fix it, and by the way, the tagged solution isn't a real solution...it's a workaround. This is not fixed in any acceptable way atm.
high rated
For those of you that are experiencing problems with the in games movies the following may help.

Edit nwn.ini located in your Neverwinter Nights installation folder.
Under [Display Options] change SafeMovie=0 to SafeMovie=1
This worked here.... Win7Pro 64bit

thanks

avatar
rmuchall: For those of you that are experiencing problems with the in games movies the following may help.

Edit nwn.ini located in your Neverwinter Nights installation folder.
Under [Display Options] change SafeMovie=0 to SafeMovie=1
Just to throw something else out you can try. I have Win 7 x64.
I was having an issue with choppy audio during movie playback.
I went into Advanced Sound Options and changed the Sound Provider to:
RAD Game Tools RSX 3D Audio.
Haven't had any issues since.
Post edited October 29, 2010 by spectralpulse
avatar
rmuchall: For those of you that are experiencing problems with the in games movies the following may help.
This made no difference for me unfotunately. But thanks for the suggestion - it's something worth trying!
I have seen another solution given for this same issue you are having, It was on this forum page:

http://www.gog.com/en/forum/neverwinter_nights_diamond/win_7_vista_users_click_me

Edit your nwn.ini file (located in your Neverwinter Nights installation folder).
Under [Display Options] change SafeMovie=0 to SafeMovie=1