It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
NoIntro, Strafe, Mouse Look, etc, it's here:
https://sites.google.com/site/sergroj/mm#TOC-GrayFace-MM7-Patch-v1.6.2

It works with GOG version.
After installing, run the game to (re)generate the MM7.ini file.

Thread here:
http://www.celestialheavens.com/forums/viewtopic.php?t=10078
Post edited September 05, 2012 by ERISS
I can confirm this is fully working no hitches or, hickups till now, just remeber to trun on mouse look, and mp3 music on the configuration file. Thanks!

- edit The file is in the game folder by the name of mm7, put "=1" on PlayMP3 and AlwaysStrafe=1(if you want to strafe with left and right arrows) & finally MouseLook=1. voilla, again thanks!
Post edited March 11, 2011 by zeroheros
Found a problem, music wont loop, even if you set it to loop on the config file, I am stumped. Any suggestions?
thanks, I will try it!
Ok, I tested the patch, it works very well, except that there is no music at all anymore... It's not so problematic, but does anybody know a way to fix that?
high rated
The patch may use the directory structure of the CD game version. Maybe it uses too its music numbers.
If the GOG music files are mp3, add one to all your game music file names ("8.mp3" becomes "9.mp3", not "09.mp3"; "1" was for CD game datas).
Create a "Music" folder in the game directory and place there the new files "2.mp3" to "20.mp3".
In mm7.cfg/ini file, set PlayMP3=1 and NoCD=1
MP3 music volume should be affected by Sound Volume you set in Settings ingame menu.

================================
Mouse Look and Strafe 1.5.1 patch options:

If you prefer the original Normal mode as default one, using Mouse Look only while holding the middle mouse button:
Edit or verify the new mm7.ini file:
CapsLockToggleRun=0
MouseSensitivity, X and Y, change them to 220 ( from 50)
or to -220 if you want to invert some axis (Thank to Perekk at post #18)
MouseLook=1
CapsLockToggleMouseLook=1
MouseLookChangeKey=4
AlwaysStrife=1

Ingame, as soon you load a game, go to normal mode by pressing [Caps Lock].
You then can switch to mouse look, for FPS game style, by holding [middle mouse] button.

Why MouseSensitivity was increased to 220 (after testing):
When you hold the middle mouse button, you can not turn as fast as with using the mouse look in default mode (and the cursor is uselessly moving).
Some turning speed is lost in the cursor, as,
when in mouse look mode, the cursor stands in the middle of the screen in the mouse look default mode,
and as the cursor is moving while in the normal DEFAULT mode.
Change it to your liking, the greater the faster you will turn while mouse looking.
Post edited August 01, 2011 by ERISS
thank you for your very detailed answer!!
avatar
ERISS: ...
Mucho thank you!!!
Hm, can't download the patch. Are there any other links to be had?
Thanks a lot =o)
I want to vouch for this patch, even if the only thing I know it did is fixing my launching problems. Thanks a lot for putting up this link!
Rubrum:
Do songs loop in the original game? One song per area? Not sure how to set the music right.
That's a new feature of the fanpatch. Go in mm7.ini file:
MusicLoopsCount option controls loops count of music. Set it to 0 for infinite loop.
Default is MusicLoopsCount=1 once the patch is installed (as it was in original game?).
Or, if you let it to 1 (or more) but finally you want to ear the stopped music again, then save the game, and reload it: when you load a game the music is played again.
Post edited August 01, 2011 by ERISS
So... the inability to download this is something only affecting me?
avatar
Domochevsky: So... the inability to download this is something only affecting me?
Here's a mirror I made.
Post edited March 29, 2011 by Vagabond
avatar
Domochevsky: So... the inability to download this is something only affecting me?
avatar
Vagabond: Here's a mirror I made.
Thanks man, appreciate it. :)

(first thing to notice: why is Rest now sitting on the "r" key and why does it wander along when i remap Cast Quickspell, which is currently assigned there? In combat this doesn't make much difference since you can't rest there anyway, but out of that when you want to cast healing spells that's rather... well, just another button press, really. Odd, though.)