It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello again.
On my laptop with Windows 7, I installed Lords of the Realm 2, but whenever I try to run the game, it looks fine for a moment, then after a few seconds will change to a rainbow bright drug trip looking thing. If you have ever tried to run starcraft, worms world party, or Age of empires 2 on vista you will probably know what im talking about.
It works fine on my windows vista computer (save the multiplayer problem i posted earlier)
I have tried alt-tabbing out, and that doesnt work. i also tried the "Graphic Mode Setup" program they talked about in the game support page, but i think thats for LOTR 1, and thus didnt work either.
i have contacted support about this problem a few days ago (MA0090000048), and i know they are in the UK and this is probably not a common problem, so i figured while i wait for them to contact me, id ask here too.
Thanks to anyone to can help :)
PS: it wouldnt let me take a screen shot for some reason, so thats why the horrible camera pic.
Attachments:
This question / problem has been solved by Qbiximage
avatar
darthcircuit: Hello again.
On my laptop with Windows 7, I installed Lords of the Realm 2, but whenever I try to run the game, it looks fine for a moment, then after a few seconds will change to a rainbow bright drug trip looking thing. If you have ever tried to run starcraft, worms world party, or Age of empires 2 on vista you will probably know what im talking about.
It works fine on my windows vista computer (save the multiplayer problem i posted earlier)
I have tried alt-tabbing out, and that doesnt work. i also tried the "Graphic Mode Setup" program they talked about in the game support page, but i think thats for LOTR 1, and thus didnt work either.
i have contacted support about this problem a few days ago (MA0090000048), and i know they are in the UK and this is probably not a common problem, so i figured while i wait for them to contact me, id ask here too.
Thanks to anyone to can help :)
PS: it wouldnt let me take a screen shot for some reason, so thats why the horrible camera pic.

You could try setting the color scheme to 256 colors and disabling visual themes.
In Windows 7, one can do this by right-clicking on the executable and using the "compatibility" tab.
P.S.
The GOG HQ is not in the UK, but in Poland ;-).
Post edited September 24, 2009 by DrIstvaan
kill explorer.exe before starting the game.
Games that use 8 bit graphics (like diablo 1) need this.
Think LotR 2 will be the same
avatar
Qbix: kill explorer.exe before starting the game.
Games that use 8 bit graphics (like diablo 1) need this.
Think LotR 2 will be the same

I don't kill explorer.exe, and don't have problems with LoTR2's colors.
well it is partly influenced by your graphics card as well actually :)
anyway I would suggest for the OP to try it.

You could try setting the color scheme to 256 colors and disabling visual themes.
In Windows 7, one can do this by right-clicking on the executable and using the "compatibility" tab.

I checked that before i ran the game the first time. If i remember correctly, those options are enabled by default. thanks though :D

P.S.
The GOG HQ is not in the UK, but in Poland ;-).

Ah! thanks for correcting me :D
EDIT:

kill explorer.exe before starting the game.
Games that use 8 bit graphics (like diablo 1) need this.
Think LotR 2 will be the same

That works!! Thanks a bunch :D
EDIT 2:
for anyone else having a similar problem, I have created a simple batch file that will kill explorer, run lords of the realm, and restore explorer when you are done playing.

echo off
taskkill /f /im "explorer.exe"
start /wait lords2.exe
explorer.exe

copy the above into notepad and "save as" a .bat file. make sure you run this in the same folder that has "Lords2.exe" in it.
Post edited September 24, 2009 by darthcircuit
I have the same graphical problem on Vista but even with killing explorer.exe, and running as administrator, 256 colors etc, it persists.
How did you get it to run on vista, mine wont load, i have tried running as admin and everything. Thanks
When I run LOTR1 and 2, the screen is not centered, but is tucked up into the left hand corner so parts of the scene and some dialog is not visible. This sometimes happens with other programs of mine and I haven't been able to find a solution. I'm running on vista.
My other GOG game, Divine divinity, does not have this problem.
Never mind. Just had to adjust monitor settings. Duh. :)
Post edited June 06, 2010 by scampywiak
Instead of killing explorer .exe before starting the game (which is a pain in the butt to start up again this way after you're done with the game) you could instead download the tool in this link that will solve all of the display issues you're having. It will suspend explorer .exe while you're playing then start it up again once you're done, easy and simple that way.
http://blog.macuyiko.com/2009/07/solving-color-problem-red-grass-purple.html
This will help with many other older games as well that have similar problems.
Enough with the n00b solutions

The informed solution is :P

net stop uxsms
pause
net start uxsms

in a batch.

This way you get to keep explorer running.
I know this is an old post, but thought I could add something in case others can benefit from what it took for LOTR2 to work for me.

I ran into 2 problems with running LOTR2 (on a somewhat older WinXP laptop):
1) Launch LOTR, got a flash of a blackscreen, then it aborted.
This was fixed with a combination of updating my NVidia video driver and adjusting the compatibility mode.

2) After this LOTR lauched ok, but every couple minutes the screen would switch to a playable but almost unviewable state. I discovered this forum post and tried the .bat file, but it just hanged. I fixed this by changing the .bat file to include compatibility mode settings. Here's the .bat file which worked for me:
----
echo off
taskkill /f /im "explorer.exe"
set __COMPAT_LAYER=Win95 256Color DisableThemes
start /wait lords2.exe
explorer.exe
----

(My first post!)
Good luck milords, and may your reign be a happy one!
avatar
darthcircuit:
You rock holmes.
So does QBix... which I assume is THE QBix?

(now I know to just retype the .bat parameters for any of these games with psychedelics)
I was wondering if anybody could tell me if there is a way to make the window bigger on a mac. It is way too small and the maximize button is disabled.