It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
JudasIscariot:
avatar
mrkgnao: Judas, please note that the Mac/Linux system requirements section in mangled up for Surgeon Simulator 2013.
Should be fixed now. Thanks :)
http://www.gog.com/forum/z/z_has_been_updated_to_version_12
http://www.gog.com/forum/xenonauts/xenonauts_has_been_updated_to_version_109
http://www.gog.com/forum/postal_series/postal_2_has_been_updated_to_version_1415_pc
avatar
fronzelneekburm: Just one little suggestion: Since the new version is so radically different from the originally released version, it would be really, really cool if GOG could include the previous build (2.0.0.6) with the bonus content. All those additions tend to get in the way of nostalgia. ;)
Done :)
avatar
JudasIscariot:
avatar
mrkgnao: Judas, please note that Unrest is marked as Linux, but Unrest Special Edition and Unrest DLC are not.
Fixed. Thanks :)
Post edited 4 days ago by JudasIscariot
avatar
DyNaer: Just a warning, Trine Enhanced Edition installer has been swapped by a new one (same gog build though) , no warning as asual -_- .

Checked the timestamp of the installer (july 28) , since it was released 4 days ago this timestamp doesn't match ...
There was a redistributable file added that was missing. If you had no problems installing and running the game then you don't need to redownload the installer :)
http://www.gog.com/forum/divine_divinity_series/divinity_original_sin_has_been_updated_on_mac
http://www.gog.com/forum/windforge/windforge_has_been_updated_to_version_118742
http://www.gog.com/forum/flatout_series/flatout_1_and_flatout_2_linux_have_been_updated
avatar
BranjoHello: So Windows users don't need to download again as nothing changed for them, right?
That's right :)
http://www.gog.com/forum/duke_nukem_series/duke_nukem_3d_linux_has_been_updated
http://www.gog.com/forum/rise_of_the_triad_series/rise_of_the_triad_dar_war_linux_has_been_updated
Post edited 3 days ago by JudasIscariot
Four games have just received their native Linux versions and one DOSBox game is now Linux-compatible.

The games:

Seven Cities of Gold: Commemorative Edition
Fist Puncher
Gateways
Escape Goat
Escape Goat 2

Prepare for the update flags as they are heading your way :D

Enjoy the new Linux additions, everyone :)
avatar
JudasIscariot: Four games have just received their native Linux versions and one DOSBox game is now Linux-compatible.

The games:

Seven Cities of Gold: Commemorative Edition
Fist Puncher
Gateways
Escape Goat
Escape Goat 2

Prepare for the update flags as they are heading your way :D

Enjoy the new Linux additions, everyone :)
avatar
ggf162: I think you messed up on the Gateways flags, the Windows and Mac show up as new as well as Linux. Doesn't happen with Escape Goat (I don't have the other ones).
I only flagged the Linux version but apparently there is a bug somewhere that flags the other installers.