It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
When I play games on my netbook in fullscreen mode, the resolution is always a bit off, no matter if I choose e.g. 800 x 600 or 1024 x 768, vertically the screen always gets a tiny bit squeezed, so that characters look somewhat smaller and fatter than they're supposed to look. It's not that much of a deal, but I wonder do I have to live with it because the netbook is built with different screen proportions than what games are used to or is there some kind of trick to display them correctly?

(The default resolution of my netbook is 1024 x 600; in Windows I can also choose 800 x 600, 1024 x 768 and 1152 x 864 but Windows only looks good in 1024 x 600.)
This question / problem has been solved by FooAtariimage
Check the BIOS on your netbook and see if you can force the screen to respect original aspect ratios. Then you will probably want to play at 800x600.

Also, some games have the ability to display in resolutions that are not in their menus. To do that, try opening their .ini files and finding where resolution is set, then update to 1024x600 and save.
Post edited August 29, 2011 by kodeen
Hmm, this surprises me a bit. My Laptop's resolutin is 1366x768, and I'm not having that problem. I do get black areas on the right and left hand sides of the screen, but other than that the games look just as they should.

For some games there are widescreen patches which would likely help your situation.

Out of curiosity, what GPU are you using? I'm using an AMD HD 6130M on Windows 7.
Thats what is great about GOG, its easy to work on Netbooks! Can make it a full fledged gaming pc with one stop to this site.
avatar
Leroux: ...
Sort of seconding kodeen's suggestion, look for an option to keep aspect ratio. What GPU does it have, and do you have the latest drivers? If you're lucky, the little graphics control program that usually comes with the drivers will have an option along those lines.

My laptop only has crappy built in Intel graphics, but in the control centre I have three options for display scaling:

Scale full screen (stretch if necessary),
Maintain aspect ratio (fill as much of the screen as possible while keeping the shape correct, fill the remaining space with black) and
No scaling (show the picture in the middle of the screen at the actual resolution and then fill the rest with black).

So yeah, look out for options like that. The second one will probably be what you're after. That means if the game doesn't support 1024x600 you can pick 800x600 instead.
Post edited August 29, 2011 by SirPrimalform
If experimenting with the video card settings doesn't get the results you want an alternative for GOG releases using DOSBox is to edit the DOSBox configuration file for the game in question to specify your exact resolution, so GOG's default of this:

fullresolution=original

is changed to this:

fullresolution=1024x600

This way the game will run at that specified resolution, ignoring any issues with how your netbook handles resolution matching.

You can manually edit the settings of many Windows-based games to specify a preferred resolution, but this varies widely so you'll need to refer to that game's forum for the specifics; many already have a sticky about widescreen compatibility--look for it there.
The graphic card is called "Intel Graphics Media Accelerator 3250" and the drivers are from April 19th of 2010, so most probably not the most recent version, but the problem is the netbook is currently not connected to the internet and when I tried to manually download a new driver for this model to my desktop and transfer it to the netbook afterwards, the netbook didn't accept it and said this version was not authorized for me and I should get the driver directly from the manufacturer of my graphic card or something (although I thought that was exactly what I did) ... :(

Thanks for the tip about preserving aspect ratio, everyone. The netbook uses Win7 Starter which doesn't offer as much options as normal Windows versions (at least not visibly for all) and I haven't found out yet where they put the graphic card's control panel, but I'll look into it and also check the BIOS.

I'm also going to try if I can fix at least the DOSBox games by changing their configuration.
Post edited August 30, 2011 by Leroux
Well, 1024x600 has ratio 128:75 And 800x600 or 1024x768 has ratio 4:3 and they are not compatible.

On bigger screens, 1024x768 is stretched and looks blurry, and on your screen is squeezed.

In your case it's either that, or black squares around the screen, but I don't know how to set that on Intel GMA.
avatar
Leroux: The graphic card is called "Intel Graphics Media Accelerator 3250" and the drivers are from April 19th of 2010, so most probably not the most recent version, but the problem is the netbook is currently not connected to the internet and when I tried to manually download a new driver for this model to my desktop and transfer it to the netbook afterwards, the netbook didn't accept it and said this version was not authorized for me and I should get the driver directly from the manufacturer of my graphic card or something (although I thought that was exactly what I did) ... :(

Thanks for the tip about preserving aspect ratio, everyone. The netbook uses Win7 Starter which doesn't offer as much options as normal Windows versions (at least not visibly for all) and I haven't found out yet where they put the graphic card's control panel, but I'll look into it and also check the BIOS.

I'm also going to try if I can fix at least the DOSBox games by changing their configuration.
I have a netbook with the same resolution and IGMA graphics. Try this;

Right click on desktop, select 'Graphics Properties'
Select 'Display Settings' then 'Aspect ratio options'
You want Maintain Aspect Ratio enabled.

That should give you games running in the correct aspect ratio. i.e. if you run a game at 800x600 should have borders left and right.
avatar
FooAtari: I have a netbook with the same resolution and IGMA graphics. Try this;

Right click on desktop, select 'Graphics Properties'
Select 'Display Settings' then 'Aspect ratio options'
You want Maintain Aspect Ratio enabled.

That should give you games running in the correct aspect ratio. i.e. if you run a game at 800x600 should have borders left and right.
Yes, that did the trick, thank you! :)

I assume you're all just helpful people who, like me, don't really give a damn about rep, but, regardless, here's +1 to everyone replying in the thread. ;)

Thanks!
No problem, glad it's fixed :)
I'm bumping this because I'm now having the issue on my netbook, which runs Linux w/ Gnome. There was no option in the BIOS, and I'm not seeing one in the Gnome interfaces. Any ideas?
avatar
kodeen: I'm bumping this because I'm now having the issue on my netbook, which runs Linux w/ Gnome. There was no option in the BIOS, and I'm not seeing one in the Gnome interfaces. Any ideas?
Try running one of these commands and then start the game:

xrandr --output LVDS1 --set PANEL_FITTING full_aspect
xrandr --output LVDS1 --set "scaling mode" full_aspect
avatar
xyem: Try running one of these commands and then start the game:

xrandr --output LVDS1 --set PANEL_FITTING full_aspect
xrandr --output LVDS1 --set "scaling mode" full_aspect
Here's the output from the first command. The output from the second is similar.


X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 149 (RANDR)
Minor opcode of failed request: 11 (RRQueryOutputProperty)
Serial number of failed request: 27
Current serial number in output stream: 27
avatar
kodeen: snip
Hmm.. the output names might be different. What is the output of 'xrandr' on its own?
Post edited September 22, 2011 by xyem