It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
high rated
IMPORTANT: Please read before posting This topic has been provided to discuss the latest releases of our Downloader (for both Mac and Windows systems) and to submit bug reports. The stable releases (recommended for most users) can be found at this address:http://www.gog.com/downloader.

Latest version:

Mac OS X - 1.2 (build 512)
Windows - 3.6.0

Both Downloaders now have the option of sending Error Reports directly to us (this can be found in app under Settings).
Post edited October 29, 2013 by Fallen_Zen
Trying to DL wizardry 8, its been downloading at about 300-400kbs for the past 10 minutes but its at 1.13GB of 1.13GB. Im not sure what its doing, tried to pause and restart it but that did nothing. any advice before I cancel and redownload (version 3.5.2.0 stable)
avatar
reaver894: Trying to DL wizardry 8, its been downloading at about 300-400kbs for the past 10 minutes but its at 1.13GB of 1.13GB. Im not sure what its doing, tried to pause and restart it but that did nothing. any advice before I cancel and redownload (version 3.5.2.0 stable)
Close and restart the downloader. It should say "Completed" after a bit.
avatar
reaver894: Trying to DL wizardry 8, its been downloading at about 300-400kbs for the past 10 minutes but its at 1.13GB of 1.13GB. Im not sure what its doing, tried to pause and restart it but that did nothing. any advice before I cancel and redownload (version 3.5.2.0 stable)
avatar
JMich: Close and restart the downloader. It should say "Completed" after a bit.
Ill try that when im back home, thanks mate.
avatar
reaver894: Trying to DL wizardry 8, its been downloading at about 300-400kbs for the past 10 minutes but its at 1.13GB of 1.13GB. Im not sure what its doing, tried to pause and restart it but that did nothing. any advice before I cancel and redownload (version 3.5.2.0 stable)
avatar
JMich: Close and restart the downloader. It should say "Completed" after a bit.
Im told that that did it, really i should have tried that before i left
avatar
reaver894: Im told that that did it, really i should have tried that before i left
No worries. Known bug, should be fixed in one of the next versions.
Hi,

I downloaded the latest version (3.5.2) , but can`t connect. The downloader is "Offline" - and is trying to connect for a long time now and nothing happens.
I also switched the button "on" (downloader mode) tried to reinstall , but still the same problem. My Antivirus is also off.
Have anyone the same problems to connect?

Thank you.

PS:
.NET 3.5 SP1. verification passed, also have run the .reg file for the downloader as told in a troubleshooting post here (cannot post links yet)

still the same problem.
The Downloader not even asked once for my login and password.
and I cannot download any game at all.
Hope anyone could help me out.
Post edited May 27, 2013 by Onion
avatar
Onion: Hi,

I downloaded the latest version (3.5.2) , but can`t connect. The downloader is "Offline" - and is trying to connect for a long time now and nothing happens.
I also switched the button "on" (downloader mode) tried to reinstall , but still the same problem. My Antivirus is also off.
Have anyone the same problems to connect?

Thank you.

PS:
.NET 3.5 SP1. verification passed, also have run the .reg file for the downloader as told in a troubleshooting post here (cannot post links yet)

still the same problem.
The Downloader not even asked once for my login and password.
and I cannot download any game at all.
Hope anyone could help me out.
Seems the Downloader is unable to connect to our API, therefore an offline mode and no prompt to login. Please make sure no firewall is blocking the app or the api.gog.com address.
Whenever I try to launch the downloader I get this error: https://dl.dropboxusercontent.com/u/39164/gog.PNG
Already tried both installing and launching as admin and in compatibility mode to no avail.
I'm on Win8 64bit.
avatar
Smertnik: Whenever I try to launch the downloader I get this error: https://dl.dropboxusercontent.com/u/39164/gog.PNG
Already tried both installing and launching as admin and in compatibility mode to no avail.
I'm on Win8 64bit.
Have you got installed .net framework 3.5 ? If so, could you please run the .net verification tool (http://support.microsoft.com/kb/2698555) ?
avatar
Smertnik: Whenever I try to launch the downloader I get this error: https://dl.dropboxusercontent.com/u/39164/gog.PNG
Already tried both installing and launching as admin and in compatibility mode to no avail.
I'm on Win8 64bit.
avatar
Szulak: Have you got installed .net framework 3.5 ? If so, could you please run the .net verification tool (http://support.microsoft.com/kb/2698555) ?
Reinstalling net framework 3.5 fixed the issue, thanks.
@ Fallen Zen;

thank you for your answer. I deactivated the firewall to try out if it works then, but the problem still there, no prompt to login. I also deactivated the security center, didn`t work either.
What else could I do?
Post edited May 27, 2013 by Onion
avatar
Szulak: Have you got installed .net framework 3.5 ? If so, could you please run the .net verification tool (http://support.microsoft.com/kb/2698555) ?
sorry to bother , but this is not the verification tool , it's the repair tool , it's not the same tool :

the verification tool can be found here :

http://cid-27e6a35d1a492af7.skydrive.live.com/self.aspx/Blog%7C_Tools/netfx%7C_setupverifier%7C_new.zip
or
http://blogs.msdn.com/cfs-file.ashx/__key/CommunityServer-Components-PostAttachments/00-08-99-90-04/netfx_5F00_setupverifier_5F00_new.zip

and the whole page : http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

(the link you mentionned is included)

Futhermore the microsoft page doesn't mention windows 8 as supported product , i don't know if it's an error....or Windows 8 is too recent for those pages (those pages seems to have been posted before win 8 release).

It seems logical to use the verification tool first and ONLY use the reparation tool if the first one find a problem.

Just my opinion, hope it will help some users
Post edited May 28, 2013 by DyNaer
avatar
Onion: @ Fallen Zen;

thank you for your answer. I deactivated the firewall to try out if it works then, but the problem still there, no prompt to login. I also deactivated the security center, didn`t work either.
What else could I do?
Could you send me a contents of your log file (a report option from Settings window), or if you can not open the Settings window, send log file manually? It's located as follow: C:\Users\username\AppData\Local\GOG.com.
Ok, how can I send it to you? I cannot attach the log file, it says wrong file format.

edit: I just send it through the settings option (time 16:52 ) , hope you got it. (in the comment field I wrote my nickname as well)
Post edited May 31, 2013 by Onion
The only problem I've had is that it only half-recognizes the setting for "Save downloads to:" It does download and save the titles to the folder I specified (C:\gog.com\) so that's a good thing. However, when I right-click the title's icon in the downloader and select "Open enclosing folder", it instead takes me to My Documents.

That's it, minor gripe.