It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
high rated
IMPORTANT: Please read before posting This topic has been provided to discuss the latest releases of our Downloader (for both Mac and Windows systems) and to submit bug reports. The stable releases (recommended for most users) can be found at this address:http://www.gog.com/downloader.

Latest version:

Mac OS X - 1.2 (build 512)
Windows - 3.6.0

Both Downloaders now have the option of sending Error Reports directly to us (this can be found in app under Settings).
Post edited October 29, 2013 by Fallen_Zen
avatar
minissa2003: I found GOG only recently. Thrilled but can't get the GOG downloader to do much of anything. Since I can't actually get it to run, I can't give you a version, but it's the one currently up (2/21/13). It seems to download OK, but when I try to run it, nothing happens. Running on Vista, using Firefox. Games are downloading OK with the Windows downloader, but all are over 1 GB, so a quicker way of downloading would be nice. I am loading things onto my D drive because that's where I've got the most space (and I've played Back to the Future, so the games are working OK coming from that drive). When just double-clicking on the icon didn't do anything (I get the final load screen with "launch" checked, and then nothing happens) I do get an option to extract a few files and I've even tried that, and still no luck. The screen did come up when I first logged in, but I was unclear what you were supposed to do other than go to the game download screen and turn the GOG loader "on." And that didn't do anything either. I would point out that your FAQ about this ap has a clickable link for problems that just takes you back to the download screen, which doesn't do much but tell you how great the GOG downloader is. Help?
Could you post your log file, please?
avatar
minissa2003: I found GOG only recently. Thrilled but can't get the GOG downloader to do much of anything. Since I can't actually get it to run, I can't give you a version, but it's the one currently up (2/21/13). It seems to download OK, but when I try to run it, nothing happens. Running on Vista, using Firefox. Games are downloading OK with the Windows downloader, but all are over 1 GB, so a quicker way of downloading would be nice. I am loading things onto my D drive because that's where I've got the most space (and I've played Back to the Future, so the games are working OK coming from that drive). When just double-clicking on the icon didn't do anything (I get the final load screen with "launch" checked, and then nothing happens) I do get an option to extract a few files and I've even tried that, and still no luck. The screen did come up when I first logged in, but I was unclear what you were supposed to do other than go to the game download screen and turn the GOG loader "on." And that didn't do anything either. I would point out that your FAQ about this ap has a clickable link for problems that just takes you back to the download screen, which doesn't do much but tell you how great the GOG downloader is. Help?
avatar
Szulak: Could you post your log file, please?
Can you please tell me where to find this or how to do this? I've spent most of the afternoon trying to get rid of all old downloads so I could start fresh, started fresh and ran into the same problems. Two things occur:
1) Is the downloader picky about which drive you load it on, and do the games then have to go onto that drive?
2) Someone mentioned an "add games" tab on the downloader screen, and I have not yet seen that. Does this mean it's likely to be a firewall issue?

I'll start over and post the log if you can direct me to it.
Thx.
I wrote earlier and Szulak was kind enough to answer with a request for log files. While waiting, I managed once again to clear out all old GOG file and get the downloader installed. And I've again hit a brick wall. I have my game chosen and the toggle switched to "GOGdownloader mode," but nothing is happening, I can't find a "go" switch nor can I find anything like and "add game" on the downloader screen itself. Are there directions for this ap somewhere on the site. I'm afraid to touch anything for fear I'll have to undergo this cumbersome delete/restart process again. Help?
And again. Everything's loaded and looks like it should be runnable, but I just can't find a way to tell the downloader to download my game. The one thing we noticed was that the default folder in settings was one that didn't exist. We tried creating it; still no luck. Isn't there some kind of set of instructions for this ap on this website? Basically, I'm trying to download Under a Killing Moon, we've tried pre-installing the downloader and then deleting it when clicking the "windows downloader" button with the toggle on GOG downloader tried to overwrite but got stuck on a file it couldn't overwrite, installed again from the game screen, logged in successfully---and now just don't know where to go from here. I tried to drag and drop, but the site interpreted that as an attempt to rearrange the games on my shelf. About...to...pull...hair...out...
avatar
minissa2003: snip
Ok, deep breath, let's see if we can get it working. You probably already done most of what I'm saying, but I find it best to not assume anything.
First of all, you mentioned you are using Firefox, so the first question is whether you are using any script blocking addons, like no-script or adblock. In case you do, whitelist www.gog.com and secure.gog.com so the scripts can work as they are intended to.
Second, when you click on Under a Killing Moon in your shelf, you should get the image attached (UAKM.jpg). Downloader mode on, and then you click on "Windows Game Installer", which links to
gogdownloader://tex_murphy_under_a_killing_moon/win_installer
Now one of two things should happen. Either the downloader will launch and add the installer, or firefox will return a "File not found". If you get the "File not found", go to Firefox Options->Applications, find gogdownloader and set it back to default. This should tell firefox to open all gogdownloader:// links with the gog downloader.

As for the log file Szulak asked for, it can be found in %localappdata%\GOG.com which translates to "C:\Users\{username}\AppData\Local\GOG.com", where {username} is your Windows username and the AppData folder is a hidden one.

Hope this helps with your problem, if not post results here and we can continue troubleshooting.

P.S. if it fails, try pasting the gogdownloader://tex_murphy_under_a_killing_moon/win_installer to IE to see if the downloader picks it up as it should.
Attachments:
uakm.jpg (38 Kb)
avatar
Jacques7Chef: Hi,

I've just recently downloaded the new version of Downloader for Mac OSX (Version 1.2, 133) and every time when I try to log out, it gives me an "Unhandled Error" message, which prevents me from clicking the "OK" button when it asks me "Are you sure you want to log out?," thus preventing me from logging out from the Downloader. Basically, I can log into the Downloader just fine, but the error prevents me from logging out.

Is this an error caused when a game is currently downloading or is this a new bug?

I've also recently sent 2 messages to the Support team with 1 of them being my Error Log File on a Word Doc, and the other with the error in more detail.

Can you guys help fix this, please?

Thanks
I've just received your log, as I stated here in a post above, try turning off all accessibility options when using the Downloader. This is a known issue and will be fixed in an upcoming update.
avatar
Jacques7Chef: Hi,

I've just recently downloaded the new version of Downloader for Mac OSX (Version 1.2, 133) and every time when I try to log out, it gives me an "Unhandled Error" message, which prevents me from clicking the "OK" button when it asks me "Are you sure you want to log out?," thus preventing me from logging out from the Downloader. Basically, I can log into the Downloader just fine, but the error prevents me from logging out.

Is this an error caused when a game is currently downloading or is this a new bug?

I've also recently sent 2 messages to the Support team with 1 of them being my Error Log File on a Word Doc, and the other with the error in more detail.

Can you guys help fix this, please?

Thanks
avatar
Fallen_Zen: I've just received your log, as I stated here in a post above, try turning off all accessibility options when using the Downloader. This is a known issue and will be fixed in an upcoming update.
Ah, ok. Problem solved, thanks! :D Hope you guys can fix this in the next update! :)
avatar
minissa2003: snip
avatar
JMich: Ok, deep breath, let's see if we can get it working. You probably already done most of what I'm saying, but I find it best to not assume anything.
First of all, you mentioned you are using Firefox, so the first question is whether you are using any script blocking addons, like no-script or adblock. In case you do, whitelist and so the scripts can work as they are intended to.
Second, when you click on Under a Killing Moon in your shelf, you should get the image attached (). Downloader mode on, and then you click on "Windows Game Installer", which links to

Now one of two things should happen. Either the downloader will launch and add the installer, or firefox will return a "File not found". If you get the "File not found", go to Firefox Options->Applications, find gogdownloader and set it back to default. This should tell firefox to open all gogdownloader:// links with the gog downloader.

As for the log file Szulak asked for, it can be found in %localappdata%\ which translates to "C:\Users\{username}\AppData\Local\", where {username} is your Windows username and the AppData folder is a hidden one.

Hope this helps with your problem, if not post results here and we can continue troubleshooting.

. if it fails, try pasting the to IE to see if the downloader picks it up as it should.
In order:
1) can't find any add-ons or extensions in FF, but I notice I haven't set up "sync." Is there something there that could be a problem?
2) Yes, that's the image I get. However, when I click on the downloader, the file it's asking me if I want to run looks like the file for the generic downloader (so it ends with desktop\setup_downloader_3.) so it looks like it's popping up a downloader not related specifically to my game. I tried this with several games just to be sure. So this means when I get the downloader screen, it has no game associated with it to download. It will launch, but since I have the downloader downloaded already, it asks if it should overwrite and then tends to get stuck about halfway through.
3) I tried sending the log a number of times last night and kept getting the errors "you can't send an attachment/image at this moment" or just "wrong file format." When I deleted the paragraph that mentioned the log (actually, I had to copy/paste into a new reply window), my notes sent but without the log. I shall try again. (OK, tried again, same problem. If there's a second AppData that's hidden, I may have to try to fiddle with my IE settings and send after I've reopened the site in IE. The fiends.
4) I know I will be condemned to computer Hell for admitting this, but the workaround using your file name in IE worked. If just using IE is likely to be the solution to my problems, I'll suck it up and use the tool of the Evil Empire. (Note, pasting the downloader name into FF did not result in any useful activity.) Or if that's the basic format for the name of the downloader for all games, I guess I can continue to use as a workaround?
Thanks! At least it's an option to waiting 6 hours for the downloader for the game.
avatar
minissa2003: snip
The inability to post links is due to low reputation. We had quite a bit of spammers on the forums a couple of months ago, thus you need a bit of rep before being able to post proper links. Using the old pastebin(dot)com/link should do the trick though. And since you do get a rep per day you post, a few days in the forums and you'll be able to post links.
Now, on to convincing Firefox to accept the gogdownloader:// links.

Go to Firefox options (alt->Tools->Options or Firefox->Options->Options), then click on "Applications" (see attached image). Find the entry "gogdownloader", then click on it, and choose program. Navigate to the gogdownloader.exe (should be at "C:\Program Files (x86)\GOG.com\GOG.com Downloader.exe") and select it. This will tell Firefox to send all gogdownloader:// links to the downloader.

Kind of late, so I hope my answer is coherent enough. If it doesn't work, reply and I'll try to see where my explanation failed, or see if it's something else.
Attachments:
options.jpg (68 Kb)
avatar
minissa2003: snip
avatar
JMich: Ok, deep breath, let's see if we can get it working. You probably already done most of what I'm saying, but I find it best to not assume anything.
First of all, you mentioned you are using Firefox, so the first question is whether you are using any script blocking addons, like no-script or adblock. In case you do, whitelist and so the scripts can work as they are intended to.
Second, when you click on Under a Killing Moon in your shelf, you should get the image attached (). Downloader mode on, and then you click on "Windows Game Installer", which links to

Now one of two things should happen. Either the downloader will launch and add the installer, or firefox will return a "File not found". If you get the "File not found", go to Firefox Options->Applications, find gogdownloader and set it back to default. This should tell firefox to open all gogdownloader:// links with the gog downloader.

As for the log file Szulak asked for, it can be found in %localappdata%\ which translates to "C:\Users\{username}\AppData\Local\", where {username} is your Windows username and the AppData folder is a hidden one.

Hope this helps with your problem, if not post results here and we can continue troubleshooting.

. if it fails, try pasting the to IE to see if the downloader picks it up as it should.
(This is reply 2. Unless you want a laugh, skip reply 1) Just for fun, I decided to behave as though I'd received the "file not found" message. And, yup, there in options>apps was the gogdownloader set to some other setting (I could see where another game had downloaded, as that was also an option). Set it back to default, tried Pandora Directive just so I didn't have two of the same game trying to run at once, and voila! Like I said, if the siterunners could post a document describing how this *&^)$%# is supposed to work, I would have had this working weeks ago. Heck, I'll even volunteer to write it now that I've done everything possible to get it not to work!
avatar
minissa2003: (This is reply 2. Unless you want a laugh, skip reply 1)
As you can see, to late to skip reply 1 ;)
No worries though, the "file not found" was me not sure of what the message is. And it seems that it's Firefox specifically not accepting the correct setting when the GOG Downloader is installed :/
As for writing a document on the downloader, feel free to do so, and post it on the forums. Doubt that many people will read it though, since most of the helpful threads get to be ignored :(
So, enjoy your games, and enjoy your stay in the forums. We are (usually) a helpful bunch.
avatar
JMich: The inability to post links is due to low reputation. We had quite a bit of spammers on the forums a couple of months ago, thus you need a bit of rep before being able to post proper links. <snip>
well....iinks would be ok but the filter seems to choke on other things too...when I tried to post the log here the forum software would tell me off despite not having any links in the msg. I managed to get around it but it was a bit annoying :)
avatar
Jacques7Chef: Ah, ok. Problem solved, thanks! :D Hope you guys can fix this in the next update! :)
It's already fixed in an internal build ;)
1. 3.3.14.0
2. Windows 7
3. Polski
6. Mam taki problem, ściągam grę przez downloader, ściągnąłem dajmy na to 2gb, pauzuję, wyłączam komputer, gdy włączę ściąganie ponownie zaczyna mi pobieranie od 1.42gb mimo że w folderze do którego ściągam jest plik ważący 1.60gb... W jaki sposób można to rozwiązać? Jest to bardzo uciążliwe jeśli nie mogę zostawiać kompa włączonego na kilka godzin.
login not working, Stating "Wrong Email and/or password". Re-entered it several times, working on the webpage ;)

1. 1.2 (331)
2. MacOS X 10.8.2
3. German
5. log is empty
6. Trying to login, but not working, always getting a "Wrong e-mail and / or password", bot is definitly right ;)


--> worked after redownloading the app. not sure why...
Post edited March 01, 2013 by wallenium