It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
high rated
IMPORTANT: Please read before posting This topic has been provided to discuss the latest releases of our Downloader (for both Mac and Windows systems) and to submit bug reports. The stable releases (recommended for most users) can be found at this address:http://www.gog.com/downloader.

Latest version:

Mac OS X - 1.2 (build 512)
Windows - 3.6.0

Both Downloaders now have the option of sending Error Reports directly to us (this can be found in app under Settings).
Post edited October 29, 2013 by Fallen_Zen
No it didn't download correctly as you said it looks like a issue on the last chunk
Post edited November 20, 2012 by GaminggUy45
With the new downloader, I've noticed something odd (at least for me). The bonuses I add are in the list, but the installers I add go to the list only to immediately disappear when they start downloading. I checked, and they are in the download folder just fine, but it's weird that they don't remain in the Downloader list with the rest of the game's bonuses and stuff.

*Edit - Nevermind, the Downloader wasn't reading my clicks and adding them properly apparently. I checked Unmechanical (which did add the installer), but neglected to check the other folders until now. The installers apparently just weren't added when I clicked them the first time and I'm grabbing them now.

*Edit to the Edit - Symphony's installer still won't show up in the Downloader, but I checked the download folder and it is mysteriously being downloaded as I type this. Seems everything's getting wonky on me and either not being grabbed by the download link, or isn't showing up in the downloader while being downloaded.
Post edited November 20, 2012 by Garugo
avatar
Garugo: With the new downloader, I've noticed something odd (at least for me). The bonuses I add are in the list, but the installers I add go to the list only to immediately disappear when they start downloading. I checked, and they are in the download folder just fine, but it's weird that they don't remain in the Downloader list with the rest of the game's bonuses and stuff.

*Edit - Nevermind, the Downloader wasn't reading my clicks and adding them properly apparently. I checked Unmechanical (which did add the installer), but neglected to check the other folders until now. The installers apparently just weren't added when I clicked them the first time and I'm grabbing them now.

*Edit to the Edit - Symphony's installer still won't show up in the Downloader, but I checked the download folder and it is mysteriously being downloaded as I type this. Seems everything's getting wonky on me and either not being grabbed by the download link, or isn't showing up in the downloader while being downloaded.
Thanks for reporting this issue, I will take a look on it. Could you post your log file please?
Post edited November 20, 2012 by Szulak
avatar
Szulak: Thanks for reporting this issue, I will take a look on it. Could you post your log file please?
Just sent a support request on the issue. I think I sent it to the right place. Not sure if the log attached properly, though. I didn't get a positive notification of it, just that when I tried to attach it again it said I already attached 1 item.
avatar
Szulak: Thanks for reporting this issue, I will take a look on it. Could you post your log file please?
avatar
Garugo: Just sent a support request on the issue. I think I sent it to the right place. Not sure if the log attached properly, though. I didn't get a positive notification of it, just that when I tried to attach it again it said I already attached 1 item.
As soon as guys from support will forward your report to me, I will can take a look on it. Thanks.
avatar
JacobD88: No worries, thanks Szulak, here's a partial log file (I can't paste all 600+ lines of stack errors, or the log start, it won't let me) with S2 Steel Storm
avatar
Szulak: It looks like any process attempted to gain an access to game files, what caused such errors. What antivirus or any spyware protection are you using? Does this problem occurs on every game, or just on that one?
I use PC Tools Internet Security, never had any problems prior to the last couple of releases.

Downloader EXE is "allowed all" for all connections in firewall, and added as a global exception in the antivirus

Hope that helps; i just cannot understand why it works >10MB of a download then stalls/crashes

Jacob
avatar
Szulak: As soon as guys from support will forward your report to me, I will can take a look on it. Thanks.
Unfortunately, the log seems to have no helpful information (response from Support) and I forgot to take a screenshot while grabbing the items not showing up or before clearing the download list. If it happens again, I'll try to remember to get the important info captured in time. For now, just going to assume it was because of my mass download habits with regard to GOG or maybe one of the extensions I added to Opera recently that had affected it.

Much appreciated, though.
How do I change the default game installation path (not the default GoG download path) in the GoG installer? If it's already answered somewhere in this thread someone point me to it. I'm looking through posts now. thx!
avatar
tensix: How do I change the default game installation path (not the default GoG download path) in the GoG installer? If it's already answered somewhere in this thread someone point me to it. I'm looking through posts now. thx!
The easiest way is to start any new installer manually from the downloaded exe, change the installation path in options and install the game. New installers should set that path as default every next time.
thanks, Gowor! will try it on the next purchase
I've just noticed that I can't rearrange the list of pending downloads outside a game's content. By this I mean if I have a group of downloads for Blood (the installer and all bonus content), and a group of downloads for Duke Nukem 3D, I can only rearrange the downloads with in their own groups. I can't put the DN3D installer first, and then the Blood OST, and then the DN3D OST, etc.
pic related,i have this problem with:

bioforge
hotline miami
pid
space colony hd
stronghold
Attachments:
Post edited November 24, 2012 by oigroig
Post edited November 24, 2012 by oigroig
avatar
oigroig: pic related,i have this problem with:

bioforge
hotline miami
pid
space colony hd
stronghold
Asked about this a couple of weeks ago.
It has to do with compatibility. They are changing the installer as some older DOS based games can't handle characters like . in the installpath.
Post edited November 24, 2012 by ELFswe