It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
high rated
IMPORTANT: Please read before posting This topic has been provided to discuss the latest releases of our Downloader (for both Mac and Windows systems) and to submit bug reports. The stable releases (recommended for most users) can be found at this address:http://www.gog.com/downloader.

Latest version:

Mac OS X - 1.2 (build 512)
Windows - 3.6.0

Both Downloaders now have the option of sending Error Reports directly to us (this can be found in app under Settings).
Post edited October 29, 2013 by Fallen_Zen
avatar
Toast_burner: I can't seem to get the downloader to work on my laptop. I have it installed but when I click add to downloader nothing happens.
It works on my desktop, just not my laptop.
If you're using Firefox, please go to Firefox -> Options -> Options -> Applications and find the item "gogdownloader", set it to default. Restart the Downloader.
avatar
biki23: I installed the new downloader, version 3.0.40. But when I try to start, i get a error popup. I have tried running as administrator, disabling anti virus. The error says to look in the log c:\Users\jc\AppData\Local\GOG.com\logger.log.

But i cannot find the file. Even the folder c:\Users\jc\AppData\Local\GOG.com\ is not there.
Please help.
avatar
Fallen_Zen: The AppData folder may be hidden. Best thing would be to Copy & Paste the path c:\Users\jc\AppData\Local\GOG.com\ into a folder window. Or make them visible in the Control Panel.
Hi
I tried to copy paste the path and it showed target does not exist. Also show hidden folders is enabled.
P.S. I am using windows 7.
avatar
biki23: Hi
I tried to copy paste the path and it showed target does not exist. Also show hidden folders is enabled.
P.S. I am using windows 7.
try pasting the path %localappdata%\GOG.com
The %localappdata% variable corresponds to your user\appdata\local directory, so the %localappdata%\GOG.com should do the trick.
avatar
biki23: Hi
I tried to copy paste the path and it showed target does not exist. Also show hidden folders is enabled.
P.S. I am using windows 7.
avatar
JMich: try pasting the path %localappdata%\GOG.com
The %localappdata% variable corresponds to your user\appdata\local directory, so the %localappdata%\GOG.com should do the trick.
Same problem, target does not exist.
avatar
biki23: Same problem, target does not exist.
Try creating the GOG.com and then running the downloader, to see if that creates the logger.log file. If this fails as well, I'd suggest uninstalling and re-installing the downloader.
P.S. What exactly was the error message, other than looking at logger.log?
avatar
biki23: Same problem, target does not exist.
avatar
JMich: Try creating the GOG.com and then running the downloader, to see if that creates the logger.log file. If this fails as well, I'd suggest uninstalling and re-installing the downloader.
P.S. What exactly was the error message, other than looking at logger.log?
Tried creating the folder, but the log file was not generated.
Attaching a snapshot of the error popup

P.S. I re downloaded and re installed 3 times till now. Used Revo Uninstaller for uninstalling.
Attachments:
Post edited April 29, 2012 by biki23
avatar
biki23: Tried creating the folder, but the log file was not generated.
Attaching a snapshot of the error popup

P.S. I re downloaded and re installed 3 times till now. Used Revo Uninstaller for uninstalling.
Can you please verify that your .NET installation is properly installed? Here's the tool for this. Choose .NET 3.5 SP1. http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

What is your computer specs and OS (and OS's language)?
Ever since I joined gog.com, I have been watching with admiration your every move and always waited for the next brilliant idea that you might come with. Unfortunately, this is the first time when I must say that I am deeply disappointed about your choice. I was forced to update from the old Downloader version (suddenly stopped downloading), only to be horrified by what you have done with this new one: it requires installation (the old one was self-contained), the Setup silently installs that dreaded NET Framework that I never want to see on my Windows XP computer (I almost had a commotion when I opened Task Manager and saw it running), the installer fails somehow (my computer starts rebooting before I get to click on "Reboot later") and I am also annoyed by the balloon notifications (that can't be turned off). I know I am simply one of the 3 fossils :) that might complain about the .NET and everything, but it would be nice if you would just fix the old Downloader.
avatar
biki23: Tried creating the folder, but the log file was not generated.
Attaching a snapshot of the error popup

P.S. I re downloaded and re installed 3 times till now. Used Revo Uninstaller for uninstalling.
avatar
Fallen_Zen: Can you please verify that your .NET installation is properly installed? Here's the tool for this. Choose .NET 3.5 SP1. http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

What is your computer specs and OS (and OS's language)?
Installed but verification failed, will install and see.
The specs as Win7 64 bit, 4 GB DDR3, Amd 95 BE, MSI Geforce 460 gtx.

Edit: It did the job. Working now
Post edited April 30, 2012 by biki23
The new stable works just swell. I was able to download three games and all their bonus content after having left them in a "Paused" state all day (roughly 16 hours) without a single WER crash. This may also be due in part to the fact that I disabled my modem's "TurboPage" function (sort of a parabolic motion calculator for satellite modems; turning it off reverts all connections to "straight line" connections), when I figured out that it did more to hinder me than help me.
avatar
SamVimes: Hi,

I'm having trouble installing the update. When starting the downloader I'm notified that an update is available, which I then choose to download. The update progress bar appears and finishes the download. However, then I'm told that an error occurred (see attached screenshot). The error message points me to a log file that doesn't exist (there's no GoG.com folder of any type in my Appdata\Roaming folder).

Is there anything I can try? I deactivated my antivirus during one of my several attempts to get the update installed, but it made no difference. I also tried running the downloader as administrator, but this was also fruitless.

Edit: I'm running version 3.1.0 of the downloader.
avatar
Destro: Can you please try uninstalling the Downloader and then downloading the 3.1.1 version directly from our server? The link is below:

http://static.gog.com/download/d3/beta/Setup_Downloader_3.1.1.exe

Nevertheless it would be great if you could send our Support team the log anyways - we haven't heard about issues like this one.
I came across the same issue. It seems to occur if the %APPDATA%/Roaming/GOG.com directory does not exist during the upgrade. I did not have the directory by default, so the install/upgrade process should take care of creating it first.

Now to a more serious issue I'm having with the downloader - I cannot see any of my games. :)

I can login fine but have never seen the 3.0 stable or 3.1 beta show anything in the list. The "GOG.com downloader mode" is enabled in My Games through the web pages.

*** Added later: Oh wow. I simply had no idea that you have to click the button on the webpage to make a game appear to the list. I thought one would see all the games automatically. Some "how to use" introduction could be useful for us dummies...
Post edited May 01, 2012 by jonsku
The new Version of the Downloader installed just fine for me, but it's worling rather bad.
IT allowed me to download 1 game just as usual but all the other files I tried to download with it download at a speed from 250B's to 2,50KB's tops.

My normal connection speed is 1,5 MB's and when I download the files manually from the page I get that speed.
I wonder what that is all about.
i have speed problems with the latest update of the downloader. Previously i was able to reach 1m and now im stuck to a lousy 320b.
anyone knows what the problem may be?
Post edited May 01, 2012 by Patafisico85
avatar
Patafisico85: i have speed problems with the latest update of the downloader. Previously i was able to reach 1m and now im stuck to a lousy 320b.
anyone knows what the problem may be?
Personally, I find that the download speeds are fine for the first few minutes, and then it's as if something invisible decides to hog my internet. GOG downloader slows down, and so does anything else that uses the internet. Closing the downloader doesn't help, either. To reiterate, the something invisible hogging my internet only ever appears after starting GOG downloader, and it doesn't go away until I restart my computer.
For all of those with speed problems, try adjusting the concurrent connections setting. I'd start with 1.
Post edited May 02, 2012 by Fallen_Zen