It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Details:


www.gog.com uses an invalid security certificate.

The certificate is only valid for the following names:
a248.e.akamai.net , *.akamaihd.net , *.akamaihd-staging.net

(Error code: ssl_error_bad_cert_domain)

This is new to me, was not receiving it yesterday.
Perhaps you used to browse via secure.gog.com?
Could you post a full address please?
I use Firefox and am not seeing this.
avatar
StingingVelvet: I use Firefox and am not seeing this.
Me too, also I have checked it here: http://www.sslshopper.com/ssl-checker.html#hostname=www.gog.com, and certificate is valid.
Have you perhaps changed your date?
I was messing with my PC date decently and it made some certificates invalid as well.
That's actually a fairly common issue, but not with GOG. It's Akamai, the CDN that GOG and many others use. Every once in a while, they glitch like that.
This is obviously a problem with the secondary recoding features that came with the new update for firefox.

You need to check if the surface box model is in line with the certificate algorithm.

And check the flux capacitor while you're at it.
Post edited April 30, 2013 by Titanium
I get that error on https:www.gog.com, which I thought was retired quite some time ago in favour of https://secure.gog.com. https://secure.gog.com works fine for me though.
Post edited April 30, 2013 by Barefoot_Monkey
avatar
Titanium: This is obviously a problem with the secondary recoding features that came with the new update for firefox.

You need to check if the surface box model is in line with the certificate algorithm.

And check the flux capacitor while you're at it.
The flux capacitor...it's always the flux capacitor!

D:


Also, just to not let this be a completely pointless post: using firefox, no problems
Post edited April 30, 2013 by aduken
I dont use FF, but just tried it now, no probs.
Our certificate is on secure.gog.com.
Warning when trying https://www.gog.com is expected behaviour when you don't use secure.gog.com.

I recommend removing 'https://www.gog.com' from your FF history and bookmarks.
Post edited April 30, 2013 by U314b
avatar
Barefoot_Monkey: I get that error on https:www.gog.com, which I thought was retired quite some time ago in favour of https://secure.gog.com. https://secure.gog.com works fine for me though.
This is the situation I am in. However one other piece is that by default if I just type www.gog.com or even just gog.com into the Address bar it will try to redirect to https://www.gog.com . I think this is something in my settings possibly, but it hasn't bothered me enough to find out :)
avatar
U314b: Our certificate is on secure.gog.com.
Warning when trying https://www.gog.com is expected behaviour when you don't use secure.gog.com.

I recommend removing 'https://www.gog.com' from your FF hostory and bookmarks.
Thanks, it apparently was in my history from 2011 :) Don't know why it would use that to decide to default to use https://www.gog.com
Post edited April 30, 2013 by samlii
avatar
Barefoot_Monkey: I get that error on https:www.gog.com, which I thought was retired quite some time ago in favour of https://secure.gog.com. https://secure.gog.com works fine for me though.
avatar
samlii: This is the situation I am in. However one other piece is that by default if I just type www.gog.com or even just gog.com into the Address bar it will try to redirect to https://www.gog.com . I think this is something in my settings possibly, but it hasn't bothered me enough to find out :)
avatar
U314b: Our certificate is on secure.gog.com.
Warning when trying https://www.gog.com is expected behaviour when you don't use secure.gog.com.

I recommend removing 'https://www.gog.com' from your FF hostory and bookmarks.
avatar
samlii: Thanks, it apparently was in my history from 2011 :) Don't know why it would use that to decide to default to use https://www.gog.com
Because if you have a specific domain (www.gog.com, in this case) with https:// in your history, Firefox will default to the secure one rather than the non-encrypted http:// one (usually a sensible idea, in my opinion). Trouble comes when a site decides to move their secure access site to another subdomain and people still have the old (same-as-unsecure) address in their history.

If you only type gog.com, Firefox will decide that www.gog.com is a perfectly good alternate (despite the fact that this is not necessarily always the case), then find the https version in your history, and send you the wrong way again (to www.gog.com, which doesn't respond on https).

Please use https://secure.gog.com if you want a secure session. And, yes, as was said, remove everything starting with https://gog.com and https://www.gog.com from your history.
Post edited April 30, 2013 by Maighstir
avatar
samlii: This is the situation I am in. However one other piece is that by default if I just type www.gog.com or even just gog.com into the Address bar it will try to redirect to https://www.gog.com . I think this is something in my settings possibly, but it hasn't bothered me enough to find out :)

Thanks, it apparently was in my history from 2011 :) Don't know why it would use that to decide to default to use https://www.gog.com
avatar
Maighstir: Because if you have a specific domain (www.gog.com, in this case) with https:// in your history, Firefox will default to the secure one rather than the non-encrypted http:// one (usually a sensible idea, in my opinion). Trouble comes when a site decides to move their secure access site to another subdomain and people still have the old (same-as-unsecure) address in their history.

If you only type gog.com, Firefox will decide that www.gog.com is a perfectly good alternate (despite the fact that this is not necessarily always the case), then find the https version in your history, and send you the wrong way again (to www.gog.com, which doesn't respond on https).

Please use https://secure.gog.com if you want a secure session. And, yes, as was said, remove everything starting with https://gog.com and https://www.gog.com from your history.
I dislike that they did that. Now, I have to go back through my bookmarks and change them so that they actually work, without having to first go to secure.gog.com. It's annoying, really.