It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Does anyone know how to turn off compatibility mode for the Fallout2.exe from within the GOG Mac version? I'm assuming there is some way to do this from within Wine, but I don't know what it is. I don't have easy access to a PC, so I would prefer to do it on my Mac if possible, rather than transferring the exe to a PC, turning off compatibility and transferring it back.


Just to clarify, the Mac version worked fine, but I installed the Fallout 2 Restoration mod, and now I'm getting the compatibility mode error.
Post edited January 24, 2013 by Bokaj
Just to say I've got the same error, I've been googling for hours to no avail
avatar
Bokaj: Does anyone know how to turn off compatibility mode for the Fallout2.exe from within the GOG Mac version? I'm assuming there is some way to do this from within Wine, but I don't know what it is. I don't have easy access to a PC, so I would prefer to do it on my Mac if possible, rather than transferring the exe to a PC, turning off compatibility and transferring it back.

Just to clarify, the Mac version worked fine, but I installed the Fallout 2 Restoration mod, and now I'm getting the compatibility mode error.
If you already installed Restoration Project:
1. Right click (or Cmd Click) on your Fallout 2 icon and select "Show Package Contents"
2. Run Wineskin.app
3. Advanced > Tools > Registry Editor
4. Browse to:
HKEY_CURRENT_USER>Software>Microsoft>Windows NT>CurrentVersion>AppCompatFlags>Layers
and delete entry associated with fallout2.exe

Now Fallout 2 should run without compatibility error.
Hope this helps :)
Post edited January 28, 2013 by _Lectral
avatar
Bokaj: Does anyone know how to turn off compatibility mode for the from within the GOG Mac version? I'm assuming there is some way to do this from within Wine, but I don't know what it is. I don't have easy access to a PC, so I would prefer to do it on my Mac if possible, rather than transferring the exe to a PC, turning off compatibility and transferring it back.

Just to clarify, the Mac version worked fine, but I installed the Fallout 2 Restoration mod, and now I'm getting the compatibility mode error.
avatar
_Lectral: If you already installed Restoration Project:
1. Right click (or Cmd Click) on your Fallout 2 icon and select "Show Package Contents"
2. Run
3. Advanced > Tools > Registry Editor
4. Browse to:
HKEY_CURRENT_USER>Software>Microsoft>Windows NT>CurrentVersion>AppCompatFlags>Layers
and delete entry associated with

Now Fallout 2 should run without compatibility error.
Hope this helps :)
Thanks so much, _Lectral, but now another problem has appeared: I'm now getting the 256 bad color/rainbow lines glitch, and editing as advised somewhere else just made it crash :(
Open file:
Fallout 2.app/Contents/Resources/drive_c/Program Files/GOG.com/Fallout 2/ddraw.ini
And modify this entries to the following values:
Mode=4
GlobalShaderMode=1
avatar
_Lectral: Open file:
Fallout 2.app/Contents/Resources/drive_c/Program Files/GOG.com/Fallout 2/ddraw.ini
And modify this entries to the following values:
Mode=4
GlobalShaderMode=1
When I made these changes I got an error upon loading the game:

The instruction at 0036c9e4 referenced memory at 00000000
The memory could not be read from

EDIT: one item of note, I could not find the GlobalShaderMode entry to change it's value. If I added it, would it make any difference?
Post edited October 07, 2013 by juliusand1

The instruction at 0036c9e4 referenced memory at 00000000
The memory could not be read from
Set Mode=0
And set
GRAPHICS_MODE=2

That did the trick for me, can't change resolution though :(
avatar
_Lectral: If you already installed Restoration Project:
1. Right click (or Cmd Click) on your Fallout 2 icon and select "Show Package Contents"
2. Run Wineskin.app
3. Advanced > Tools > Registry Editor
4. Browse to:
HKEY_CURRENT_USER>Software>Microsoft>Windows NT>CurrentVersion>AppCompatFlags>Layers
and delete entry associated with fallout2.exe
Do you have any suggestions if this didn't resolve the compatibility mode error?
Post edited January 03, 2014 by macographer
avatar
_Lectral: If you already installed Restoration Project:
1. Right click (or Cmd Click) on your Fallout 2 icon and select "Show Package Contents"
2. Run Wineskin.app
3. Advanced > Tools > Registry Editor
4. Browse to:
HKEY_CURRENT_USER>Software>Microsoft>Windows NT>CurrentVersion>AppCompatFlags>Layers
and delete entry associated with fallout2.exe
avatar
macographer: Do you have any suggestions if this didn't resolve the compatibility mode error?
I don't know whether you've been able to solve this, but I had the same issue. Here's how I got F2 running

1. Deleted the entries under:
HKEY_CURRENT_USER>Software>Microsoft>Windows NT>CurrentVersion>AppCompatFlags>Layers
HKEY_LOCAL_MACHINE>Software>Microsoft>Windows NT>AppCompatFlags>Layers
2. It started up, but I received the memory instruction error. Then I edited the
/Applications/Fallout 2.app/Contents/Resources/drive_c/Program Files/GOG.com/Fallout 2/ddraw.ini
, and I set the following values
Mode=4
GPUBlt=2
, and now I'm able to play the game :)

-w-
I'm another mac user for whom this compatibility error keeps popping up.

GOG staff, any suggestions?

Cheers,

-Feliks
avatar
macographer: Do you have any suggestions if this didn't resolve the compatibility mode error?
avatar
w01w13: I don't know whether you've been able to solve this, but I had the same issue. Here's how I got F2 running

1. Deleted the entries under:
HKEY_CURRENT_USER>Software>Microsoft>Windows NT>CurrentVersion>AppCompatFlags>Layers
HKEY_LOCAL_MACHINE>Software>Microsoft>Windows NT>AppCompatFlags>Layers
2. It started up, but I received the memory instruction error. Then I edited the
/Applications/Fallout 2.app/Contents/Resources/drive_c/Program Files/GOG.com/Fallout 2/ddraw.ini
, and I set the following values
Mode=4
GPUBlt=2
, and now I'm able to play the game :)

-w-
You're a god amongst men.

I don't know if it's important, but I used the Windows NT package from Killap's installer, and that's probably a good bit of info for this min-faq, if it's actually necessary.