It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
Gingerious: I know this topic is a little old, but I just downloaded this after the DRM sale and ran into this exact problem. Here's how i fixed it (running windows 7):

1. Right click fallout 2 launch icon and select properties.
2. Click Advanced... button.
3. Select Run As Adminstrator checkbox and click OK.
4. Click OK to close Fallout 2 Properties window.

That seemed to do the trick for me. No mods required, although I'd still recommend them!
Yep, this worked for me too.
avatar
Gingerious: I know this topic is a little old, but I just downloaded this after the DRM sale and ran into this exact problem. Here's how i fixed it (running windows 7):

1. Right click fallout 2 launch icon and select properties.
2. Click Advanced... button.
3. Select Run As Adminstrator checkbox and click OK.
4. Click OK to close Fallout 2 Properties window.

That seemed to do the trick for me. No mods required, although I'd still recommend them!
I installed Fallout 2 for the first time today and also had this problem. Making it run as Administrator as per the above also fixed the problem for me. I think the admins should make a sticky post about this for Fallout 2. Or update the GOG version so it always runs as administrator on default after install, like many other GOG games are configured.
I was having the same color issue with the game and running as admin wasn't working, but i was able to fix it by changing the graphics from 8 bit fullscreen to dx9 fullscreen, just go to ddraw.ini under graphics there's "mode=0"
replace the 0 with 4, this completely fixed it for me.
agh! it drives me crazy when people ask a question on a forum, then the next post is "never mind, i fixed it"
avatar
TiuLeitero: I was having the same color issue with the game and running as admin wasn't working, but i was able to fix it by changing the graphics from 8 bit fullscreen to dx9 fullscreen, just go to ddraw.ini under graphics there's "mode=0"
replace the 0 with 4, this completely fixed it for me.
Thanks. This is all I had to do. Install, and edit one line of the .ini. Didn't even have to run compatibility mode.
*also, my error initally was can't initialize 640x480 or so such. Fallout2.exe cannot be started only happened when running from the direct exe.*
Post edited December 13, 2013 by deathmothon
avatar
Gingerious: I know this topic is a little old, but I just downloaded this after the DRM sale and ran into this exact problem. Here's how i fixed it (running windows 7):

1. Right click fallout 2 launch icon and select properties.
2. Click Advanced... button.
3. Select Run As Adminstrator checkbox and click OK.
4. Click OK to close Fallout 2 Properties window.

That seemed to do the trick for me. No mods required, although I'd still recommend them!
I'd just like to add that I also had the "cannot be started" error and this is the simplest solution. Although on my computer (Win 7) the 'Run as Admin' option was listed under the Compatibility tab.
Fixed it. go to ddraw in the installation map and change the mode=0 to 4.
worked for me.
Starting directly from the executable did the trick for me.