It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have a bizarre problem which I never encountered using the CD-based versions of the games represented under the Earth 2150 Trilogy under Windows 7 (at least the first two games - I've never actually played "Lost Souls" on Windows 7) When I attempt to design a unit in-game, the game immediately crashes. There are no specific circumstances - simply boot up the game, start a battle, and click on the "Construction Center" button. It doesn't matter whether I launch the game using the supplied shortcuts or the games' executables, and changing compatibility options doesn't do anything, either.
Post edited July 15, 2011 by Expack
This question / problem has been solved by korellimage
I was able to solve the problem; apparently, the unit construction screen doesn't like non-4:3 resolutions. Simply switching to a 4:3 resolution was enough to solve the problem.
avatar
Expack: I was able to solve the problem; apparently, the unit construction screen doesn't like non-4:3 resolutions. Simply switching to a 4:3 resolution was enough to solve the problem.
Yeah, quite a few posts in this forum about this issue. It's not just widescreen resolutions that are the problem either, sometimes the resolution is just too high for the game and a number of players have had to use 1024x768 to get it working.
avatar
Expack: I have a bizarre problem which I never encountered using the CD-based versions of the games represented under the Earth 2150 Trilogy under Windows 7 (at least the first two games - I've never actually played "Lost Souls" on Windows 7) When I attempt to design a unit in-game, the game immediately crashes. There are no specific circumstances - simply boot up the game, start a battle, and click on the "Construction Center" button. It doesn't matter whether I launch the game using the supplied shortcuts or the games' executables, and changing compatibility options doesn't do anything, either.
Hi,

I have the same problem, playing on win 7, when i press F1 ( design ) it crashes. Did you solve it !

And it wont play full screen mode.
Ah, and I just wondering why the game crashes every time I wanted to construct. I thought it was because of my laptop specs. It turns out because of the resolution, eh ? well, that is a classic game for you.

Thanks for the info !
avatar
agylardi: Ah, and I just wondering why the game crashes every time I wanted to construct. I thought it was because of my laptop specs. It turns out because of the resolution, eh ? well, that is a classic game for you.

Thanks for the info !
how do you change resolution once you have already installed the game?
avatar
sharkrider: how do you change resolution once you have already installed the game?
You have to go to the folder of the game (inside of the "Escape from the blue planet" folder of your Earth2150 folder e.g.) and start the "Setup" inside of it. That brings you back to the little window where you can change the resolution.
I encountered the same problem when i tried to play "Lost Souls" and "Escape From the Blue Planet." I was setting my resolution at 1920x1080 for both games and when I wanted to go in the construction menu, the game would crash. However, thanks to all you smart people, I followed your advice and changed the resolution down to 1024x768x32. With those settings, I can now use the construction menu without the game crashing. Just wanted to say thanks! :D