It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
i have just recently bought this game. and its still as good as ever. however it does not support widescreen reselution... sort of. the game itself work fine. but! once i go in to the designe center, where you put the various parts you have discoverd together into a unit.. it crashes.

so i started fiddeling with the reselutions in the setup that comes with the games. i discoverd that the design center does work. just not on a reselution above 1280x1024x32.

i would however like to run this in widescreen mode. is this possibel in anyway? dosent have to be max reselution possibel. just wide screen.
This question / problem has been solved by Flemimage
sort of fixed. iw tested several reselutions and come up with this.

List of widescreen resolutions the game successfully ran at: 1280x800, 1440x900, 1152x720, 1680x1050, 1920x1200.
List of widescreen resolutions that were not tested: 2048x1536.
List of widescreen resolutions the game fails to run at: 1280x720,
1280x768, 1200x720, 1366x768, 1920x1080.

so it does work in widescreen mode just not all of em. this crash still only applyes to the construction center bug. the game works fine in all reselutions until that part.
Post edited May 26, 2011 by jurijchrul
Greetings all. To fix the game crash problem, first delete the gog supplied shortcut on your desktop, then go into the Escape from Blue Planet folder and left click Earth2150 application so that it is highlighted. Right click on that, then select send to desktop (create shortcut). Problem solved. I'm running Windows 7 Home Premium with a max res. of 1366x768 on my laptop. Game now playes fine. Hope that helps :-)
Thanks for the tip, my game froze a few times and now its running like a champ. Love this game and im so glad i can play it on my new laptop, thanks again.
avatar
Randall415: Greetings all. To fix the game crash problem, first delete the gog supplied shortcut on your desktop, then go into the Escape from Blue Planet folder and left click Earth2150 application so that it is highlighted. Right click on that, then select send to desktop (create shortcut). Problem solved. I'm running Windows 7 Home Premium with a max res. of 1366x768 on my laptop. Game now playes fine. Hope that helps :-)
avatar
Flem: sort of fixed. iw tested several reselutions and come up with this.

List of widescreen resolutions the game successfully ran at: 1280x800, 1440x900, 1152x720, 1680x1050, 1920x1200.
List of widescreen resolutions the game fails to run at: 1280x720,
1280x768, 1200x720, 1366x768, 1920x1080.

so it does work in widescreen mode just not all of em. this crash still only applyes to the construction center bug. the game works fine in all reselutions until that part.
1728x1080 (pillarboxed 16:10 on 1920x1080 monitor) also works - it seems the game doesn't like 16:9 aspect on the design screen.

The game seems to be Vert- : there's no stretching of the 3D graphics, but you see less of the game than you would if you were running at a 4:3 aspect resolution.

You can counter this by zooming out more - to increase the maximum zoom-out distance press 'Enter' in-game to open the console and type "graph.zoom.max 19" (without the quotes), then press 'Enter' again to apply. I think the default is 16. You can use higher values if you want, however using too high a setting might make the game unstable and/or allow the camera to clip through the ground when tilted.

4:3 1440x1080
16:10 1728x1080
16:10 1728x1080 (graph.zoom.max 19)
Post edited October 15, 2014 by DreadMoth
@DreadMoth
Is the graph.zoom.max 19 setting saved after you quit the game or you have to type it every time you start the game?
Your solution seems like a great workaround for 16:9 resolutions which are problematic with Earth 2150. Could you please provide more details how do you use the custom resolution-1728x1080? The game normally doesn't provide it, you probably created a profile in your graphic card's control panel? Thanks about the new info!