It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Some discussion of advantages and disadavantages of the various DKII versions by Hapuga from Keeperklan forum
http://keeperklan.com/threads/2957-Have-GOG-DKII-which-patches-would-work-best?p=42014&viewfull=1#post42014

1.3 vanilla - great version.
1.3 cracked - great version.
1.51 - the best version of the game.
1.6 - don't use
1.61 - don't use.
1.7 vanilla - what 95% of people use.
1.7 silver edition an enhanced 1.7 version.
1.7 GOG a very good adaptation of 1.7 version.
1.71 - don't use.
1.72 - don't use.
1.73 - an okay version to try.
1.8 - don't use.

tl;dr version:
Every version since 1.6 has broken AI, since 1.7 MP is broken.

This is one case where I dislike the GOG "everything pre-patched" policy :/

Update 2013-11: there is a new patch approach by Wyrmcast over at keeperklan trying to join the best of 1.51 and 1.7.
Post edited November 29, 2013 by shaddim
Wait... so the GOG version has broken AI and broken multiplayer? What the fuck.
Post edited March 09, 2013 by Swallagoon
avatar
Swallagoon: Wait... so the GOG version has broken AI and broken multiplayer? What the fuck.
indeed, that's crap.

I think the best 1.7 branch version is the merged 1.73+GOG(timeslip) exe + map fixes:
1.73GOG patch and map fixes

For a merged 1.3/1.51 with timeslip's fixes, timeslip's support is needed.... and that GOG provide this version overall!
Post edited March 24, 2013 by shaddim
Do those map fixes work with online multiplayer? I managed to get the game working over Tunngle, but it crashes randomly throughout play.
avatar
Swallagoon: Do those map fixes work with online multiplayer? I managed to get the game working over Tunngle, but it crashes randomly throughout play.
I don't know, never tried, sorry. If you test it, could you please report back? Thanks :)
avatar
Swallagoon: Do those map fixes work with online multiplayer? I managed to get the game working over Tunngle, but it crashes randomly throughout play.
There is a new patch approach by Wyrmcast over at keeperklan, compatible with the GOG version (but de-activating/not using the timeslip graphic patch) which aims on fixing the AI by being based on v1.51 while incorporating several of the 1.7 features.

General-Improvement-Mod-A-New-Unofficial-Patch-for-DK2
Post edited November 29, 2013 by shaddim
Is there anyway of 'downgrading' to v1.51 or for anyone to 'imitate' that version at least? Tried playing a game y'day and the ai got shafted... Just a bunch of lvl 1 goblins and 3x3 rooms all in one space (difficulties were Mk, conq and psychtic). Can you play gog 1.7 online? Need a separate client/program to make your own parties still?
avatar
lghkljcvm: Is there anyway of 'downgrading' to v1.51 or for anyone to 'imitate' that version at least? Tried playing a game y'day and the ai got shafted... Just a bunch of lvl 1 goblins and 3x3 rooms all in one space (difficulties were Mk, conq and psychtic). Can you play gog 1.7 online? Need a separate client/program to make your own parties still?
Just follow the instructions in Wyrmcasts's mod folder. Should be self-explanatory.
avatar
Swallagoon: Do those map fixes work with online multiplayer? I managed to get the game working over Tunngle, but it crashes randomly throughout play.
avatar
shaddim: There is a new patch approach by Wyrmcast over at keeperklan, compatible with the GOG version (but de-activating/not using the timeslip graphic patch) which aims on fixing the AI by being based on v1.51 while incorporating several of the 1.7 features.

General-Improvement-Mod-A-New-Unofficial-Patch-for-DK2
If using Wyrmcast's mod, make sure you're using DKII.EXE instead of DKII-DX.EXE, otherwise you'll be running V1.7 with broken multiplayer and AI.
Post edited February 20, 2014 by devilhood
avatar
shaddim: There is a new patch approach by Wyrmcast over at keeperklan, compatible with the GOG version (but de-activating/not using the timeslip graphic patch) which aims on fixing the AI by being based on v1.51 while incorporating several of the 1.7 features.

General-Improvement-Mod-A-New-Unofficial-Patch-for-DK2
avatar
devilhood: If using Wyrmcast's mod, make sure you're using DKII.EXE instead of DKII-DX.EXE, otherwise you'll be running V1.7 with broken multiplayer and AI.
I'm not sure i know what you mean? i just patched it into directory and then i run the normal dk2 exe in my 'GOG' folder. i have better campaign results now - better creatures on last few levels, etc. and i have loads of maps in skirmish/multi; however, it does state that it is 1.7v in bottom left. i tried just using the DKII.EXE (which does actually fit full screen now, but just black and only text of main menu popping up, so only the prior works for me? the AI are labelled differently too in the 1.7v to moron, idiot, and others? there was nothing wrong with the AI of master keeper on original GOG, before patch as i just went in to editor and gave them a gem seem and they were fine; creatures lvl 8 and 5x5 rooms with double fortification, don't know what the problem was? if they only have gold then yes, they bug out, but get rid of all other gold and just give them a gem vine and they'll be fine. how do i get better AI now though? lol
avatar
devilhood: If using Wyrmcast's mod, make sure you're using DKII.EXE instead of DKII-DX.EXE, otherwise you'll be running V1.7 with broken multiplayer and AI.
avatar
lghkljcvm: I'm not sure i know what you mean? i just patched it into directory and then i run the normal dk2 exe in my 'GOG' folder. i have better campaign results now - better creatures on last few levels, etc. and i have loads of maps in skirmish/multi; however, it does state that it is 1.7v in bottom left. i tried just using the DKII.EXE (which does actually fit full screen now, but just black and only text of main menu popping up, so only the prior works for me? the AI are labelled differently too in the 1.7v to moron, idiot, and others? there was nothing wrong with the AI of master keeper on original GOG, before patch as i just went in to editor and gave them a gem seem and they were fine; creatures lvl 8 and 5x5 rooms with double fortification, don't know what the problem was? if they only have gold then yes, they bug out, but get rid of all other gold and just give them a gem vine and they'll be fine. how do i get better AI now though? lol
You can still launch the game using DKII-DX.EXE but you will be missing out on a lot of the benefits. I can give you an example.
Try playing Skirmish mode with any difficulty. The AI will mostly appear idle and wont build more than 3-4 rooms. It's incredibly easy to defeat the enemy.

Follow my instructions here for installing the GIM mod correctly

When using DKII.EXE, make sure you choose the "Conqueror" AI personality for any Skirmish maps.
Post edited February 26, 2014 by devilhood