It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello everyone! I've recently bought Duke Nukem 3D at GOG, and there's a problem with its sound. It's simply out of synch! For example, when I shoot, the sound of shooting is heard a bit later than the shot itself. Does Duke have to sound this way? I mean, its sound is crappy anyway. This game is one of the worst sounding games of all times. Sometimes I begin to think that the sound has been recorded in the noisy street, rather than a studio - it's extremely grainy and muffled. And now with this sound delay it's really hard to play. Is there some way to fix it?
Post edited December 15, 2012 by serguntchik
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have the same issue. It was immediately noticeable upon entering the main menu. The sound effect for selecting each menu item is off; all sounds are delayed by less than a second, but it is entirely noticeable. I'm suprised to see that no body else seems to be experiencing this (but us). I hope there is a fix because, for me, this is unplayable.

Also, I tried messing with the sound settings in "settings", but to no avail.

Can anyone shed some light on this?

Running mod free
Windows 7 64-bit
X-Fi sound card with latest drivers
Post edited December 28, 2012 by nickrp3d
it's a dosbox sound card setup issue.

maybe use SB16 instead of AWE64(or whatever vs. whatever you're using now), could be conflicting IRQs, or a matter of setting reserve IRQs in the BIOS, etc.

i don't use dosbox, so i can't help resolve the issue other than to point you in the right direction

if nobody answers at this site try here at the dosbox forum:

http://vogons.zetafleet.com/index.php?c=7

or you could try one of the ports like eduke32
Post edited December 28, 2012 by Forge
I appreciate the input, Forge. I'll do some more digging and see if I can resolve this.

I did try eDuke32, which solved the sound issue. However, I would prefer to play the game in its vanilla form, so unless you can point me to a source port that preserves the original state of the game, I'll have to stick with the emulation.

Other than this sound issue, the game looks and plays great.

Thanks
you can play it in original vanilla form with eduke32. the main differences are you don't get weird visual bugs when looking all the way up or down like in the original game, and the mouse support is better.

play it in 8 bit mode and choose a screen resolution below 800 x 600

these can be set in the launch window - if you don't get a launch box when starting the program you'll need to edit the eduke32.cfg file in the duke directory. make sure the line reads ForceSetup = 1

but if you can solve the sound problem with this game using dosbox, other people will probably appreciate it
Post edited December 28, 2012 by Forge
I played around with just about every setting in dosBox configuration, but I was unsuccessful at getting the darned audio to sync with the video. Ah well, I gave it my best effort.

I understand that you can tweak all the settings in eDuke32 to match the vanilla gameplay experience, but I'd like the game to be original from the ground up, including menus (I'm picky I know). If eDuke had the nifty little background demo playing at the menu screen I would be content.

Still, thanks for the help Forge.
i've never used this port (xDuke), but you can give it a try and see if it does what you want:

http://vision.gel.ulaval.ca/~klein/duke3d/