It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Goes straight to a black screen every time, stops responding. This is while trying to host TCP/IP on windows 7. Any ideas?

Actually any of the buttons on the multiplayer create game screen do this, "New Game" "Load Game" and the third option...
Post edited October 11, 2010 by dreadgazebo
Has the windows firewall popup come up asking if you want to let bg2main.exe access the network?
avatar
Aliasalpha: Has the windows firewall popup come up asking if you want to let bg2main.exe access the network?
I do not have windows firewall enabled, nor UAC, none of that garbage.
Have you enabled any sort of port forwarding on your router? I don't know the port numbers off the top of my head but they're probably in the manual.

Have you tried hamachi? https://secure.logmein.com/products/hamachi2/
avatar
Aliasalpha: Have you enabled any sort of port forwarding on your router? I don't know the port numbers off the top of my head but they're probably in the manual.

Have you tried hamachi? https://secure.logmein.com/products/hamachi2/
Yeah ports are forwarded, I'm only trying to play on LAN so that shouldn't even be an issue. I see no sense in trying hamachi since when I actually push the start button for the game the program stops responding.
Ahh I missed the freezing part when I read your post.

Are you running wired or wireless?

Does the same error happen if you disconnect from the network and try going into multiplayer?

How long have you waited when its frozen?
avatar
Aliasalpha: Ahh I missed the freezing part when I read your post.

Are you running wired or wireless?

Does the same error happen if you disconnect from the network and try going into multiplayer?

How long have you waited when its frozen?
1. Wired.

2. Freezes regardless of network connection enabled or disabled

3. Too long.



Did I mention I'm an IT guy? Does anyone have any suggestions or solutions with some substance to them?
Since you're a fellow IT guy, I'll assume you've made the sensible choice to not install in program files since win7 is overprotective of it even with UAC disabled. Presumably you've also removed and reinstalled it and since you've not mentioned mods, I take it you're running the vanilla game

Is your system multihomed? 2 NICs might confuse it
Are you dual stacking with ipv6?
Got any weird networking protocols installed?
Done any network tweaks (either manually or with TweakXP, TCPoptimiser)?

There are rare instances that I've seen (mostly with xp) where the windows firewall has flat out lied, saying its not on when it really is, adding an exception for BGmain might still be worth a go, if it works its good and if not its a few bytes of redundant data.

The Baldur.ini file in the install folder has a multiplayer section at the end, it should look similar to this:
Last Protocol Used=2
Player Name=player
Session Password=password
Session Name=session
Manually editing the protocol used entry might be worth a go, 2 is tcp/ip

If you temporarily disable the ip protocol stack, that would help eliminate a connection issue. When you click the multiplayer button, it'd presumably start scanning for available protocols and if there's a problem there, it could get stuck in an endless loop. I'll grant that its unlikely to help but it'd eliminate the protocol as the problem.
Post edited October 15, 2010 by Aliasalpha
uhm. Before all that. Are you running it full screen? The IE games can't start a multiplayer (either host or join) session on modern systems while full screened (for some obscure reason). So start the game windowed and switch to full screen during play, or just play windowed.
avatar
Aliasalpha: Since you're a fellow IT guy, I'll assume you've made the sensible choice to not install in program files since win7 is overprotective of it even with UAC disabled. Presumably you've also removed and reinstalled it and since you've not mentioned mods, I take it you're running the vanilla game

Is your system multihomed? 2 NICs might confuse it
Are you dual stacking with ipv6?
Got any weird networking protocols installed?
Done any network tweaks (either manually or with TweakXP, TCPoptimiser)?

There are rare instances that I've seen (mostly with xp) where the windows firewall has flat out lied, saying its not on when it really is, adding an exception for BGmain might still be worth a go, if it works its good and if not its a few bytes of redundant data.

The Baldur.ini file in the install folder has a multiplayer section at the end, it should look similar to this:
Last Protocol Used=2
Player Name=player
Session Password=password
Session Name=session
Manually editing the protocol used entry might be worth a go, 2 is tcp/ip

If you temporarily disable the ip protocol stack, that would help eliminate a connection issue. When you click the multiplayer button, it'd presumably start scanning for available protocols and if there's a problem there, it could get stuck in an endless loop. I'll grant that its unlikely to help but it'd eliminate the protocol as the problem.
Vanilla, yes. No IP6, No dual NIC's, all common network protocols (no virtual adapters either)

Baldur.ini checks out, sorry for the cocky response earlier just frustrated - really wanted to play multiplayer with my wife. Trying to suck her into my nostalgia :(

LordCinnamon - you win the day good sir! The last time I fired up this game was on my compaq persario circa high school, good thing to know for when GoG launches BG2! Thanks!
How do I make it windowed? The game runs fine for me single player, but when I click on an IP game and try to host a new game the game crashes.After some googling I clicked on properties on the shortcut and on Run it was set to "Normal Window" and I could change it to "Minimized" or "Maximized", it still crashed in all settings. I even tried to run as administrator.
(I am trying this on a laptop with Windows 7)
Post edited October 17, 2010 by Freedom_Fridge
avatar
Freedom_Fridge: How do I make it windowed? The game runs fine for me single player, but when I click on an IP game and try to host a new game the game crashes.After some googling I clicked on properties on the shortcut and on Run it was set to "Normal Window" and I could change it to "Minimized" or "Maximized", it still crashed in all settings. I even tried to run as administrator.
(I am trying this on a laptop with Windows 7)
Press ALT + Enter while in game, you can also add -windowed to the shortcut paramaters.
Oh cool, thanks it worked!!

On my fiance's laptop it showed up widescreen, but mine was squashed to regular resolution.
I read something about a Widescreen mod, but it seems like hers didn't need it for some reason
avatar
LordCinnamon: uhm. Before all that. Are you running it full screen? The IE games can't start a multiplayer (either host or join) session on modern systems while full screened (for some obscure reason). So start the game windowed and switch to full screen during play, or just play windowed.
That is just weird! But REALLY good to know. Might want to have mod sticky that fact for others in future
avatar
dreadgazebo: Baldur.ini checks out, sorry for the cocky response earlier just frustrated - really wanted to play multiplayer with my wife. Trying to suck her into my nostalgia :(

LordCinnamon - you win the day good sir! The last time I fired up this game was on my compaq persario circa high school, good thing to know for when GoG launches BG2! Thanks!
Glad it worked! I was in pretty much the same situation when I ran into this problem. I'm playing a multiplayer game with my girlfriend at the moment (with her as the protagonist) and she loves it! She initially complied to humor me, I think, but these days she's the one who suggests we go an play some more BG most of the time :D

I did install some convenience mods I wouldn't have used when I play alone though. Stuff like infinite stacking. Anyway, I hope your wife will enjoy the game as well :)