It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hi I just signed up here on GOG because i saw that they have Baldurs gate 2, I wanted to know if anyone knew if this would run on a mac or not as it will influence my purchase. Thanks.
You should be able to get it to run on an Intel Mac using either:

Wine - http://www.winehq.org/
Harder to setup, but free.

Or

CrossOver Games - http://www.codeweavers.com/products/cxgames/
Easy to setup, not free.

Personally if I were using a Mac, I would go for CrossOver Games. This will allow you to run many of the games on this site. There is also a demo version that you could try.
avatar
nullzero: CrossOver Games - http://www.codeweavers.com/products/cxgames/
Easy to setup, not free.
I got this and the only issue is size of the full screen. Once installed go to manage bottles, control panel, launch the wine config, select the graphic tab, and uncheck both "allow the window manager to decorate the windows" and "allow the window manager to control the windows". Once this is done the game runs perfect on full screen. Enjoy.
Another option is gemrb:

http://gemrb.sourceforge.net/wiki/doku.php?id=start
avatar
nullzero: CrossOver Games - http://www.codeweavers.com/products/cxgames/
Easy to setup, not free.
avatar
Feyjoo: I got this and the only issue is size of the full screen. Once installed go to manage bottles, control panel, launch the wine config, select the graphic tab, and uncheck both "allow the window manager to decorate the windows" and "allow the window manager to control the windows". Once this is done the game runs perfect on full screen. Enjoy.
I did those changes and when I launch Baldur's Gate 2 and I still get the white screen cant play.
avatar
Feyjoo: I got this and the only issue is size of the full screen. Once installed go to manage bottles, control panel, launch the wine config, select the graphic tab, and uncheck both "allow the window manager to decorate the windows" and "allow the window manager to control the windows". Once this is done the game runs perfect on full screen. Enjoy.
avatar
luis_villasenor: I did those changes and when I launch Baldur's Gate 2 and I still get the white screen cant play.
After uncheking those go to the actual game config icon and open the BG2 config. In there try to find the area where it mentions 3 options of BLT or something like it. I think is the last Tab, have a check mark on those and the game should run perfectly.

Edit: yes is the last selection the 2d 3d options, in there on the 2d options on top check all 3 areas of BLT, also make sure the game is on 2D and not 3D. Happy gaming.
Post edited April 06, 2011 by Feyjoo
avatar
luis_villasenor: I did those changes and when I launch Baldur's Gate 2 and I still get the white screen cant play.
avatar
Feyjoo: After uncheking those go to the actual game config icon and open the BG2 config. In there try to find the area where it mentions 3 options of BLT or something like it. I think is the last Tab, have a check mark on those and the game should run perfectly.

Edit: yes is the last selection the 2d 3d options, in there on the 2d options on top check all 3 areas of BLT, also make sure the game is on 2D and not 3D. Happy gaming.
Thanks it worked ! what worked for me was that i needed to change the resolution.

Anyone had installed patch BGT-WeiDU on a mac?
I just bought this game and I am playing it on a MacBook Pro, OS X 10.6.6. using Crossover Games 10.
Followed the instructions in this thread and got it running smoothly as far as graphics go. My problem is with the mouse though. It's sort of see-through half the time and doesn't register each click I make, making combat very difficult.
The response time for clicking is also not the greatest. Anyone got an idea for what I could do to make the mouse work perfectly? If that is even possible.
if you have bootcamp on your mac you could try installing windows. i do everything on my mac side and play games that only work for windows when i boot up the windows xp side. only problem is if you don't have a windows install disc....you kinda gotta buy one. still, its an option.
avatar
xxlordskullxx: if you have bootcamp on your mac you could try installing windows. i do everything on my mac side and play games that only work for windows when i boot up the windows xp side. only problem is if you don't have a windows install disc....you kinda gotta buy one. still, its an option.
or you can get the wrapper from my site and install the gog.com version into the wrapper and play it as an app on your mac: http://www.paulthetall.com/baldurs-gate-2-mac.html
Post edited February 06, 2013 by drpaulthetall
avatar
xxlordskullxx: if you have bootcamp on your mac you could try installing windows. i do everything on my mac side and play games that only work for windows when i boot up the windows xp side. only problem is if you don't have a windows install disc....you kinda gotta buy one. still, its an option.
avatar
drpaulthetall: or you can get the wrapper from my site and install the gog.com version into the wrapper and play it as an app on your mac: http://www.paulthetall.com/baldurs-gate-2-mac.html
Hello Dr Paul The Tall.

I tried using your wrapper (great site by the way) but couldn't get it to work.

When I try the game, I just get a white screen.

I also tried adjusting the graphics setting to 2d (someone else had suggested it I think) and it when I tested the settings, the game just crashed (it displayed the green, red and blue boxes ok).

any thoughts?
avatar
drpaulthetall: or you can get the wrapper from my site and install the gog.com version into the wrapper and play it as an app on your mac: http://www.paulthetall.com/baldurs-gate-2-mac.html
avatar
htown1980: Hello Dr Paul The Tall.

I tried using your wrapper (great site by the way) but couldn't get it to work.

When I try the game, I just get a white screen.

I also tried adjusting the graphics setting to 2d (someone else had suggested it I think) and it when I tested the settings, the game just crashed (it displayed the green, red and blue boxes ok).

any thoughts?
Don't bother the gog.com forum for this but post the issue on the paulthetall.com forums.
avatar
luis_villasenor: snip...
Anyone had installed patch BGT-WeiDU on a mac?
I can tell you that easy tutu works fine on a mac (well my old mac)... as that is WeiDU, there should be no issue with BGT because you have already got the game engine working.
Post edited July 27, 2013 by ussnorway
avatar
htown1980: Hello Dr Paul The Tall.

I tried using your wrapper (great site by the way) but couldn't get it to work.

When I try the game, I just get a white screen.

I also tried adjusting the graphics setting to 2d (someone else had suggested it I think) and it when I tested the settings, the game just crashed (it displayed the green, red and blue boxes ok).

any thoughts?
avatar
drpaulthetall: Don't bother the gog.com forum for this but post the issue on the paulthetall.com forums.
Thanks but I figured it out (didn't work properly in crossover either - not much seems to sadly).

If anyone else has this problem, I just created a new wineskin myself and then ran the following wine trick:

ddr=gdi