It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
For those who just can't play this game in 800x600 anymore here is your answer.

The Gibberlings Three Widescreen Mod

I would recommend 1280x720 if you have a desktop that is 1920x1080. But the beauty of this widescreen mod is that you can select whatever width and height you want to use.

Many thanks to the bigg for making this mod thus allowing this classic game to continue to live on.
Post edited March 23, 2012 by Trebor
You're aren't using the link tag correctly:
[ url= url goes here ]url or title here[ /url ]

and this mod has already been posted on the sticky thread here:
http://www.gog.com/en/forum/baldurs_gate_series/newbie_guide_modding_bg1_if_you_buy_bg1_bg2_from_gog/page1

Thanks for being helpful, though!
Post edited March 16, 2012 by Rhiyo
Original post fixed :) Links work now.
Does anyone have a copy of the mod - I went to go grab it and it looks like the gibberlings is offline? Many thanks.
avatar
friendofp: Does anyone have a copy of the mod - I went to go grab it and it looks like the gibberlings is offline? Many thanks.
They've gone down before, I'm sure they will be up again shortly. I have it at home. If they aren't up by this weekend, I'll upload it somewhere it can be accessed.
Post edited December 13, 2012 by ncarty97
avatar
friendofp: Does anyone have a copy of the mod - I went to go grab it and it looks like the gibberlings is offline? Many thanks.
It's only temporary, they're going to be back up soon.

But if you are in despair and can't possibly wait you could try their emergency mirror
:)
Hi folks,

Sorry if this has already been solved, cannot seem to find it.

I have installed this mode and used 1280 x 720 (native is 1280x1080)

When I launch the game, the "game" screen remainds the same size but its surrounded by massive areas of black.

The screen is 1280x720 but the actual game screen fills hardly any of it.

Any ideas?

(EDIT)

Realised the main game screen works fine. A mod can deleted this post! (Couldnt see how!)
Post edited April 26, 2013 by Asho
Hi you all,

I'm trying to make the widescreen patch working with my Windows 8.1 laptop. I got, reading previous posts, that this patch changes the in-game resolution and not the one of the introduction and character creation screens.

Now, I have 1920x1080 resolution set up by now on my laptop. I set up the same resolution for the game, but, as I thought, it looks too small even if the image fills the whole screen correctly. Now, I reduced the resolution of the game scaling it 1280x720 as suggested in the first post, but, running the game, it just shrinks the image (probably to the value I set I think) and now it's leaving a lot of black space on the side of the screen. I suppose that this is because I'm still leaving the laptop screen resolution to 1920x1080.

What can I do to avoid this problem? Do I have to set the main resolution of my laptop to 1280x720 (as the game resolution) every time I want to play the game? Is there another solution?

Thank you for your time.
avatar
Atreyu83: Hi you all,

I'm trying to make the widescreen patch working with my Windows 8.1 laptop. I got, reading previous posts, that this patch changes the in-game resolution and not the one of the introduction and character creation screens.

Now, I have 1920x1080 resolution set up by now on my laptop. I set up the same resolution for the game, but, as I thought, it looks too small even if the image fills the whole screen correctly. Now, I reduced the resolution of the game scaling it 1280x720 as suggested in the first post, but, running the game, it just shrinks the image (probably to the value I set I think) and now it's leaving a lot of black space on the side of the screen. I suppose that this is because I'm still leaving the laptop screen resolution to 1920x1080.

What can I do to avoid this problem? Do I have to set the main resolution of my laptop to 1280x720 (as the game resolution) every time I want to play the game? Is there another solution?

Thank you for your time.
Hi, Atreyu83.

You need to go into your video card's control panel and set the scaling options for the 1280x720 resolution. Here are some instructions:

For AMD Radeon and R Series
For Nvidia

Hope this helps. =)

Neverending Story was an awesome movie!

Flynn
Hi Flynn, thank you for your answer!

So, my graphic card is no AMD and no nVidia: it's an Intel Graphic HD 5000. I checked for this scaling option for my GPU and it seems that there are some issues with it.

I understood that this option is called "Panel fit" for Intel graphic cards and mine actually it's set at "Maintain Aspect Ratio", the only option available at 1920x1080. It seems more difficult than expected.

Thank you for your help.

P.S. The Never Ending Story was one of the books I loved during my childhood. ;)
Post edited 5 days ago by Atreyu83
With some older Intel mobile drivers you could set your desktop resolution to anything less than default & then it would give you the scaling options, you could set scaling to panel fit & then change your desktop resolution back to default & the panel fit scaling would remain. (although obviously have no effect at the default resolution)
Scaling is not changing the resolution, it is changing the way a set resolution appears on the screen.
Thank you for your answer. I tried to do as suggested by you and in various post that talk about this issue but, by now, I didn't succeed.

Widescreen patch set at 1280x720, my screen set at 1920x1080 (native resolution), I changed the resolution to a non native one (1024x768), set up the Panel Fit option to "Scale Full Screen", then went back to native resolution but I still see the game image at the center of the screen with black bands on top and bottom. It looks like that this adapt to full screen option is doing something since I see some change of resolution when I quit the game, with my desktop turning from a lower resolution to an higher one, but this has no effect on the game.

Still have no idea on what to do to solve this problem. The game in this way is hardly playable.

(EDIT)
So, I found a workaround to get the full screen working but the game is still unplayable: I got the correct full screen behavior when I deactivated the "Use 3D Acceleration" option in the configuration settings (BGConfig.exe) under the section "2D & 3D Options". Now the game executes in full screen but it's slower and the screen and, most important, the hand cursor are flickering with pieces of my underlying desktop sometimes appearing in the game.

I think it's a problem with the OpenGL Drivers configuration between Baldur's Gate and Intel HD Graphics cards. Maybe the guys at GOG can solve this problem?

(RE-EDIT and SOLUTION)
Finally I found a workaround the allows my at least to play full screen. My Intel HD Graphics 5000 doesn't allow "Scale Full Screen" on Panel Fit settings when set on native resolution (1920x1080). Even if it allows this option when set to lower resolutions and I do it the game runs always 1920x1080 with the small game image in the middle (the OpenGL window) at the resolution set by the Widescreen Mod. As I said before, deactivating the "Use 3D Acceleration" option in the configuration settings (BGConfig.exe) under the section "2D & 3D Options" allows (for some reason I'm not able to understand) my graphic card to perform the stretching properly. I finally solved the flickering problem by installing the "Aqrit's DDrawFix for Infinity Engine games" and setting it to "Use WineD3D's DDraw Library".

So no 3D acceleration but now scaling correctly without flickering.

Thanks everybody for the support.
Post edited 6 hours ago by Atreyu83