It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hi guys, I have a bit of a problem with Baldur's Gate 1 & 2 multiplayer.

So first of all, with the Serial connection, it says "Cannot connect to the game session." And when I try to Create a game, I go to "New Game" and click on it, but nothing happens. The same happens with "Load Game." It also immediately silences any music that is playing at the time (in-game).

And then it's the same with IPX. I can't "New Game" or "Load Game", and the music cuts out.

But with TCP/IP, instead of not doing anything, it freezes for 5 seconds after clicking the "New Game" button and then it goes to a black screen, which then leads to the game crashing and me having to open task manager to close the game itself, which is "Not responding.".

If anybody has any information that may help me with this annoying little problem, I would be grateful. Thanks again!

- cjhrjone54.
Post edited November 29, 2012 by cjhrjone54
No posts in this topic were marked as the solution yet. If you can help, add your reply
1. You want TCP/ IP in Australia but the problem sounds like a Firewall or system block (antivirus).

Things that cause this problem are;
1. You have Win7 and installed the game to program files.
2. You have an anti-virus program with a behaviour shield eg. Avast but you didn't add BG to the ignore list.
3. You don't have admin rights while playing the game (see 1).
4. You don't have full network rights eg. a notepad on wi-fi.
avatar
cjhrjone54: Hi guys, I have a bit of a problem with Baldur's Gate 1 & 2 multiplayer.

So first of all, with the Serial connection, it says "Cannot connect to the game session." And when I try to Create a game, I go to "New Game" and click on it, but nothing happens. The same happens with "Load Game." It also immediately silences any music that is playing at the time (in-game).

And then it's the same with IPX. I can't "New Game" or "Load Game", and the music cuts out.

But with TCP/IP, instead of not doing anything, it freezes for 5 seconds after clicking the "New Game" button and then it goes to a black screen, which then leads to the game crashing and me having to open task manager to close the game itself, which is "Not responding.".

If anybody has any information that may help me with this annoying little problem, I woulc be grateful. Thanks again!

- cjhrjone54.
Me and a few friends tried to play the game in multiplayer with no luck. We eventually figured out how to make it work, it's really weird but after fiddling with random options in the game we could play multiplayer.

What you need to do is to play the game in windowed mode and join one another via direct IP multiplayer, as long as you play the game in windowed mode it should work, it's weird I know, but try it. It will 'freeze' for a while when you join the game via direct IP, but that is normal just be patient and you will be able to join your friend.

Everyone should use windowed mode. When you start playing you can just use ALT+Enter if you want to play in fullscreen once you got your game going.
I'm not sure about the second game, but I had the same problem with the first. In one of the readme files it suggested the following:

Open the Baldur.ini file (located where you installed the game) and add the following at the bottom:

[Multiplayer]
AsyncEnumeration=1


This completely solved the problem for us. I don't know if it will help you, but it's worth a try.
Post edited May 04, 2012 by joshlanmao
Thank you guys! I know it's been a while but completely forgot about this website. But I can now play multiplayer now! Thanks! :D