It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I have the portrait i want to use in the Portraits folder inside the game directory, yet when i'm creating a character and click the Custom button underneat the portrait selection thing, the list is empty, what gives?

And yes, the portrait is saved as a bmp image.

Thanks!
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Shiek2005: [...]
Besides format, it has to be correct size and compression (bmp 24-bit & 8-bit for small one)

If you're certain the files are correct, it might be that the game doesn't read files from root directory due to OS protection (Program Files folder)
In that case, try a) running BG as admin, or b) putting files into Portraits folder in
C:\Users\<your_username>\AppData\Local\VirtualStore\Program Files\GOG.com\<game_folder>
Thanks.

After some more messing around, i found out that you also need 2 seperate portraits, ideally a small and large. Also, the name has to be 8 characters or less.

Thanks anyways :)
Same thing happened to me: I put portraits downloaded from Sorcerer's place, which worked with my old 5 CD copy of the game, so the problem does not come from the files themselves: yet no custom portrait appears. I always run anything as admin and I can't find any "virtualstore" folder anywhere
avatar
Shiek2005: [...]
avatar
Thiev: Besides format, it has to be correct size and compression (bmp 24-bit & 8-bit for small one)

If you're certain the files are correct, it might be that the game doesn't read files from root directory due to OS protection (Program Files folder)
In that case, try a) running BG as admin, or b) putting files into Portraits folder in
C:\Users\<your_username>\AppData\Local\VirtualStore\Program Files\GOG.com\<game_folder>
avatar
Parinix: Same thing happened to me: I put portraits downloaded from Sorcerer's place, which worked with my old 5 CD copy of the game, so the problem does not come from the files themselves: yet no custom portrait appears. I always run anything as admin and I can't find any "virtualstore" folder anywhere
If you have BG installed in 'Program Files', uninstall it and re-install to somewhere like 'C:\Games\'.
avatar
Parinix: snip
It's been a while since I've played BG2, but the rules are slightly different from BG1 IIRC. I think you need three pics, all of the correct size, they need to be in Override, and your game should not be installed in Program Files. I could be wrong about all this.

Try putting the pics in Override, and see if they show up.
avatar
Parinix: snip
avatar
BlueMooner: It's been a while since I've played BG2, but the rules are slightly different from BG1 IIRC. I think you need three pics, all of the correct size, they need to be in Override, and your game should not be installed in Program Files. I could be wrong about all this.

Try putting the pics in Override, and see if they show up.
You are not correct. All portraits go in a 'portaits' folder. The only portraits that would go into the 'override' folder would be stock portraits that you want to change (Imoen, Jaheira, Minsc etc.) And the rules are the same for both games.
avatar
BlueMooner: It's been a while since I've played BG2, but the rules are slightly different from BG1 IIRC. I think you need three pics, all of the correct size, they need to be in Override, and your game should not be installed in Program Files. I could be wrong about all this.

Try putting the pics in Override, and see if they show up.
avatar
Hickory: You are not correct. All portraits go in a 'portaits' folder. The only portraits that would go into the 'override' folder would be stock portraits that you want to change (Imoen, Jaheira, Minsc etc.) And the rules are the same for both games.
Ah well. My memory of BG2 is indeed quite fuzzy.
avatar
Parinix: Same thing happened to me: I put portraits downloaded from Sorcerer's place, which worked with my old 5 CD copy of the game, so the problem does not come from the files themselves: yet no custom portrait appears. I always run anything as admin and I can't find any "virtualstore" folder anywhere
avatar
Hickory: If you have BG installed in 'Program Files', uninstall it and re-install to somewhere like 'C:\Games\'.
It is installed in a folder located in C:\GOG Gmaes\

It still does not work
avatar
Hickory: If you have BG installed in 'Program Files', uninstall it and re-install to somewhere like 'C:\Games\'.
avatar
Parinix: It is installed in a folder located in C:\GOG Gmaes\

It still does not work
Where did you put your portraits? I'm not interested in other answers, or 'where it said', I am asking you where you placed the actual files (xxxxx.bmp).
The portraits were first in this folder:

C:\Documents and Settings\Administrator\My Documents\Baldur's Gate\Portraits

When they did not show up, I moved them here:

C:\GOG Games\Baldur's Gate\Portraits
avatar
Parinix: The portraits were first in this folder:

C:\Documents and Settings\Administrator\My Documents\Baldur's Gate\Portraits

When they did not show up, I moved them here:

C:\GOG Games\Baldur's Gate\Portraits
Then the images have either been corrupted, edited, renamed or otherwise altered. If they were in the correct format (name included), they would show up, providing that is where your game is installed (C:\GOG Games\Baldur's Gate\). Be aware that the default name is '\Baldurs Gate\' and NOT '\Baldur's Gate\'.
Turns out, the Portraits do appear: for some reason, the game put them at the end of a list which contains something like 150 empty boxes: It looks like this:





























































Portrait 1
Portrait 2
Portrait 3
etc....
Post edited April 29, 2013 by Parinix