It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Before you say anything - that resolution is half 1920x1080.

I wanted to get the game running in widescreen, but I wanted to make sure that it wasn't horribly zoomed out making it feel a lot more like an RTS.
My idea was to run it at 960x540, as this would mean each ingame pixel was 4 pixels on my monitor, so there would be no real blurring and the game would feel good since it was close to the original size. (I also have it set up to half the DPI of my mouse when playing, my plan (or so I thought) was perfect..)

However, I have a problem. In windowed, it works absolutely fine, but when I try to run fullscreen, it runs at 640x480 and chops off the bottom and the right corner.

Can anyone test this with their copy and see if it does the same?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Confirmed same issue. 1280x720 works. Not as elegant, but manageable. I think the mod is built over BG2's 800x600 functionality (which itself is a mod over the original IE), which requires a minimum of 600. I'd love to see 960x540, but I don't think anyone's actively working on the mod anymore.
Your monitor likely does not support non-standard resolutions such as that. (I'm not sure of any that do, actually). Rather, you should go into your graphics card control panel and look for the scaling options, and set it to 'Aspect Ratio' and GPU scaling. This way, your monitor stays at its native resolution, and the card upscales the image, usually with clearer results. (Hopefully if you have a decent graphics card). It would also not hurt to try making a custom resolution - 960x540 x32bit @60Hz.

As for blurring, I think you would still get a sharper image the higher resolution you go. I run mine at 1066x600 (16:9) - it uses the 800x600 GUI set (only wider) to have a bit more viewable area, while not making everything too tiny. Even sharper would be 1280x720 or 1366x768, but I'm not a fan of that GUI set and I find the dialog box becomes too long and harder to read.
Thanks for testing this guys, I appreciate it!
avatar
anamorphic: Your monitor likely does not support non-standard resolutions such as that. (I'm not sure of any that do, actually). Rather, you should go into your graphics card control panel and look for the scaling options, and set it to 'Aspect Ratio' and GPU scaling. This way, your monitor stays at its native resolution, and the card upscales the image, usually with clearer results. (Hopefully if you have a decent graphics card). It would also not hurt to try making a custom resolution - 960x540 x32bit @60Hz.
As bizzare as it sounds, my monitor actually does. It has a 1:1 pixel mode which most of the time works perfectly, and the full mode normally just stretches anything I throw at it without issue.

Also - how do you tell what GUI set is being used?
Post edited December 20, 2012 by Jademalo
avatar
Jademalo: Also - how do you tell what GUI set is being used?
BG2 has three - the normal one for 640x480, then over 800x600 which puts a tile around all the 480 sized screens (inventory, etc), then 1024x768 (and higher) which puts another tile around them, which I just think does not look as nice.

Looking at the widescreen mod readme, it does say anything above 482 vertical should work. EDIT: Again try making a custom resolution in your graphics control panel. I just did and 960x540 works fine for me. And it uses the 480 GUI with small black bars / letterbox for the 480 screens.
Post edited December 20, 2012 by anamorphic
avatar
Jademalo: Also - how do you tell what GUI set is being used?
avatar
anamorphic: BG2 has three - the normal one for 640x480, then over 800x600 which puts a tile around all the 480 sized screens (inventory, etc), then 1024x768 (and higher) which puts another tile around them, which I just think does not look as nice.

Looking at the widescreen mod readme, it does say anything above 482 vertical should work. EDIT: Again try making a custom resolution in your graphics control panel. I just did and 960x540 works fine for me. And it uses the 480 GUI with small black bars / letterbox for the 480 screens.
Strange, the button to do so on the nvidia control panel is greyed out...

EDIT: Right, after a load of testing, this is indeed the problem., However, with my standard monitor setup, It won't let me add custom resolutions.

Guess I'm gonna have to settle for 1280x720 or something.

Thanks for the help!
Post edited December 20, 2012 by Jademalo