It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I just downloaded and installed the GOG version of BG2/TOB to a folder outside of program files. I downloaded and ran the fixpack.exe as well as the widescreen .exe, specifying my monitor's native resolution of 1920x1080. However, when I actually start BG2, I get a small "window view" of the game with black all around. This happens at the menu, in cut scenes, and in game. I tried 1280x720 instead, but simply got a letterbox format with large strips of black on the top and bottom.

I have a CD version of just BG2 SOA that I was playing several years ago with the widescreen mod, and it was working fine. What is going on now?
At a guess you didn’t start the game before installing the other mods? Therefore your in built graphics are confused about what settings too run the game at... yes it could be something else but I’d look at this first since that will at least say that the game itself is stable before looking at what mods you have running.
Try going into Nvidia Control Panel & Adjust desktop size & position & setting scaling to full screen. & perform scaling on display.
I've never tried BG2 on 1920x1080, but there is a maximum resolution the engine supports for dialog screens such as stores and the map. If you go beyond that resolution, then the game will look fine in-game, but when going to a store or map, you'll get a very small window in the middle of the screen, surrounded by a pool of black.

At least, that's what happens on my old 1280x1024 LCD; I expect it to be worse on a 1920x1080 monitor. How can you even play the game in that resolution? Most people stick to 1280x720 or 1280x800 on a widescreen, mostly because you're going to see a very big, dark world, with a bright line-of-sight bubble in the middle.

Also, you shouldn't change the in-game resolution in the settings panel after you applied the widescreen mod.
Post edited June 15, 2013 by Katsunami
Hi all,

I'm having the same issue with the widescreen mod. Am I doing something wrong?
I tried setting the X & Y axis to my screen's native 1920x1200 as well as something more sensible like 1028x700 but the results are simply various sizes of the BG2 boxed by black borders.
I had also installed the large font mod, which made things worse because the actually resolution of the game did not change, only the size of the game screen. Most of the texts are way too big for the boxes they're in, esp when trying to buy anything, the prices are not even visible.

In the end, I had to uninstall the wide screen and large font, and go back 800x600. Kind of a shame though.
Did I do something wrong? I vague recalled being asked to choose a DUI but I cannot recall when...I think it at the end of the BGT mod? I chose not to apply any DUI then.

Any help and advice would be greatly appreciated.
Don
avatar
Navanod66: Hi all,

I'm having the same issue with the widescreen mod. Am I doing something wrong?
I tried setting the X & Y axis to my screen's native 1920x1200 as well as something more sensible like 1028x700 but the results are simply various sizes of the BG2 boxed by black borders.
I had also installed the large font mod, which made things worse because the actually resolution of the game did not change, only the size of the game screen. Most of the texts are way too big for the boxes they're in, esp when trying to buy anything, the prices are not even visible.

In the end, I had to uninstall the wide screen and large font, and go back 800x600. Kind of a shame though.
Did I do something wrong? I vague recalled being asked to choose a DUI but I cannot recall when...I think it at the end of the BGT mod? I chose not to apply any DUI then.

Any help and advice would be greatly appreciated.
Don
You do not need the Widescreen mod with BG2. Just run the config program and unlock the (unsupported) modes. Anything higher than 1024x768 is silly, though.
avatar
Navanod66: Hi all,

I'm having the same issue with the widescreen mod. Am I doing something wrong?
I tried setting the X & Y axis to my screen's native 1920x1200 as well as something more sensible like 1028x700 but the results are simply various sizes of the BG2 boxed by black borders.
First up, the widescreen mod won't let you use resolutions your monitor can't display. (ie 1028x700)
The lowest standard 16:10 resolution is WXGA 1280x800.

Second, With the widescreen mod, it doesn't go full screen until you start playing. (did you actually start a game?)

If you don't mind squares being rectangles, you can just pick a 4:3 XGA & stretch it to full screen.

If you monitor & display drivers allow, you can create a custom 16:10 resolution ie: 1152x720
In nvidia control panel go to Change resolution/customise/create custom resolution.
avatar
Hickory: You do not need the Widescreen mod with BG2. Just run the config program and unlock the (unsupported) modes. Anything higher than 1024x768 is silly, though.
Thanks for your reply.
Config program? Where can I find it? Sorry, not very good with this modding thing

Meanwhile, I saw another possible solution:

http://www.gog.com/forum/baldurs_gate_series/widescreen_mod_wrong_resolution

Willl try tonight and update.
avatar
olnorton: First up, the widescreen mod won't let you use resolutions your monitor can't display. (ie 1028x700)
The lowest standard 16:10 resolution is WXGA 1280x800.

Second, With the widescreen mod, it doesn't go full screen until you start playing. (did you actually start a game?)

If you don't mind squares being rectangles, you can just pick a 4:3 XGA & stretch it to full screen.

If you monitor & display drivers allow, you can create a custom 16:10 resolution ie: 1152x720
In nvidia control panel go to Change resolution/customise/create custom resolution.
Yes I did. In fact I got through candlekeep with the game in a smaller box surrounded by darkness. Then my eyes could not take it anymore and I decided to go back to default.
Thanks for your tips, I'll try them out
Post edited June 20, 2013 by Navanod66
avatar
Hickory: You do not need the Widescreen mod with BG2. Just run the config program and unlock the (unsupported) modes. Anything higher than 1024x768 is silly, though.
avatar
Navanod66: Thanks for your reply.
Config program? Where can I find it? Sorry, not very good with this modding thing
It's in your BG2 installation folder. It's called BGConfig.exe .
avatar
Navanod66: Thanks for your reply.
Config program? Where can I find it? Sorry, not very good with this modding thing
avatar
Hickory: It's in your BG2 installation folder. It's called BGConfig.exe .
Sorry, was at work and couldn't look in the BG2 folder earlier, so I asked a noob question :p
Thank you! It's working now. I still went ahead and did the widescreen mode too at 1024x768 and it seemed to improve the resolution?
Also, I put the largefont mods back as well cos the words got kinda tiny.
There's just one problem now, the map and the trading screens shrunk back each time I used them. It's no big deal on the map but on the trading screen, I'm encountering the same problem with the large fonts...for them to be readable easily, some of the text would exceed the size of the box and are no longer visible.
I'm happy with it as it were now, but I don't suppose there's a way to fix the map and trading screen shrinkage issue?

Thanks a heap in advance once again, you guys are very helpful
avatar
Hickory: It's in your BG2 installation folder. It's called BGConfig.exe .
avatar
Navanod66: Sorry, was at work and couldn't look in the BG2 folder earlier, so I asked a noob question :p
Thank you! It's working now. I still went ahead and did the widescreen mode too at 1024x768 and it seemed to improve the resolution?
Also, I put the largefont mods back as well cos the words got kinda tiny.
There's just one problem now, the map and the trading screens shrunk back each time I used them. It's no big deal on the map but on the trading screen, I'm encountering the same problem with the large fonts...for them to be readable easily, some of the text would exceed the size of the box and are no longer visible.
I'm happy with it as it were now, but I don't suppose there's a way to fix the map and trading screen shrinkage issue?

Thanks a heap in advance once again, you guys are very helpful
I don't know why you installed the widescreen mod. As I said, it is not needed with BG2, nor is the large font mod. It could be that enabling the larger resolutions and those two mods are causing your issues. I don't have any issues with just the config option.
avatar
Hickory: I don't know why you installed the widescreen mod. As I said, it is not needed with BG2, nor is the large font mod. It could be that enabling the larger resolutions and those two mods are causing your issues. I don't have any issues with just the config option.
Yup, think i'll just stick to the config like you said. Just did some testing...the widescreen mod did nothing different from the config while the large font wasn't that necessary at 1028x768. Don't know why GOG suggested these 2 mods either?
Thanks. Problem solved!
Post edited June 20, 2013 by Navanod66
avatar
Hickory: . I don't have any issues with just the config option.
Do you have a widescreen monitor?

If so, do you prefer the black lines down the sides or the distorted 4:3 ratio stretched to fit the widescreen?
avatar
Hickory: . I don't have any issues with just the config option.
avatar
olnorton: Do you have a widescreen monitor?

If so, do you prefer the black lines down the sides or the distorted 4:3 ratio stretched to fit the widescreen?
Yes. 16:9 (1920x1080 native). I don't have black lines down the sides, and at 1024x768 the image does not look distorted in-game -- screenshots do.