It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
hi everyone

honestly ive been trying to resolve this for ages now and had no luck, strangely bg1 works perfectly with no issues.... ill list the problem, my specs and what ive done so far.

So im playing on a full windows 8 tablet pc with intel hd 4000 on board gfx

so all i want is to play native resolution nothing special and as i said bg1 boots and runs full screen perfectly at native resolution. i installed the widescreen mld but with the ui size and stuff i did not want to keep modding and was happy with vanilla visuals.

bg2 boots with the small screen centered in the middle and a big black frame, i looked around and did the following:

-changed desktop resolution (1024x768 is the lowest available)
-checked scaling options on desktop, set to "maintain display scaling" and thats the only option
-ran bg2 config and checked game, full screen is enabled
-tried compatibility mode with win xp sp2
-forced it to run 640x480 in compat mode
-checked bg .ini file and settings were correct
-tried changing to different resolutions in the bg config, supported AND unsupported
-did everything running as administrator

not only did these all not work but regardless of what resolution settings i changed either in the game settings OR native, the size of the game screen was always the same as id it always jumped back to 1080p, even when i changed the native resolution and closed the game the changes would still b there, but the game would seem to always try to scale to that same resolution...

Any suggestions would be great, and i dont care if its 640x480 or 600x800

many thanks!!!
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
SyruM: hi everyone

honestly ive been trying to resolve this for ages now and had no luck, strangely bg1 works perfectly with no issues.... ill list the problem, my specs and what ive done so far.

So im playing on a full windows 8 tablet pc with intel hd 4000 on board gfx

so all i want is to play native resolution nothing special and as i said bg1 boots and runs full screen perfectly at native resolution. i installed the widescreen mld but with the ui size and stuff i did not want to keep modding and was happy with vanilla visuals.

bg2 boots with the small screen centered in the middle and a big black frame, i looked around and did the following:

-changed desktop resolution (1024x768 is the lowest available)
-checked scaling options on desktop, set to "maintain display scaling" and thats the only option
-ran bg2 config and checked game, full screen is enabled
-tried compatibility mode with win xp sp2
-forced it to run 640x480 in compat mode
-checked bg .ini file and settings were correct
-tried changing to different resolutions in the bg config, supported AND unsupported
-did everything running as administrator

not only did these all not work but regardless of what resolution settings i changed either in the game settings OR native, the size of the game screen was always the same as id it always jumped back to 1080p, even when i changed the native resolution and closed the game the changes would still b there, but the game would seem to always try to scale to that same resolution...

Any suggestions would be great, and i dont care if its 640x480 or 600x800

many thanks!!!
Try actually starting a game, if you haven't already. The menu doesn't resize when the widescreen mod is installed, and the issue you're having come from the same cause (even though you don't have that mod installed). Note that I mean more than just entering character generation: actually go through that process with a test character (or import your BG1 character) and enter the game proper. See if it's working properly after the opening cutscenes, when you get control of your character.

If that doesn't work, press alt-enter. It should set you to windowed mode. Tell us whether the window is the same size as the game is displaying, larger, or smaller.

Finally, are you playing with the GOG version of the game? If not, is it fully patched?

Beyond that, someone with more knowledge of the game (and windows 8) may be able to help more.
Does pressing Ctrl + Alt + F11 change your panel fit mode?
You say you don't care what resolution it runs in, so long as it's full screen, correct? If that's so, uninstall the widescreen mod. You do not need it with BG2, and it will cause all sorts of problems. Uninstall it completely, then run BGConfig and set one of the resolutions in there.
avatar
Hickory: You say you don't care what resolution it runs in, so long as it's full screen, correct? If that's so, uninstall the widescreen mod. You do not need it with BG2, and it will cause all sorts of problems. Uninstall it completely, then run BGConfig and set one of the resolutions in there.
Having the same problem myself since I upgraded to windows 8.1 (with Intel HD4000) and it happens with all of the original resolutions. Tried using the widescreen mod to fix it but the game is still stuck in a tiny box in the middle of a black screen.

Ctrl + Alt + F11 also doesn't help because there's only one option and its 'Maintain Desktop Scaling'.
avatar
AzureHerbivore: Ctrl + Alt + F11 also doesn't help because there's only one option and its 'Maintain Desktop Scaling'.
If you set your desktop resolution to something less than default, and then go to advanced options,
the top tab should say something like "Intel(R) Graphics and Media control panel", click it
then go to the scaling tab.
Does it now have other options in the drop down box?
avatar
AzureHerbivore: Ctrl + Alt + F11 also doesn't help because there's only one option and its 'Maintain Desktop Scaling'.
avatar
olnorton: If you set your desktop resolution to something less than default, and then go to advanced options,
the top tab should say something like "Intel(R) Graphics and Media control panel", click it
then go to the scaling tab.
Does it now have other options in the drop down box?
It does...but all three do the exact same thing. It looks like I'm going to have to wait for new drivers from Samsung since it won't let me install the new one direct from Intel. Although it might be a bit more complex on my laptop because I've got this AMD Radeon 8500m graphics card as well.

Windows 8.1... First you take away the ability to change the screen brightness for a week and now you mess with Baldur's Gate?
avatar
AzureHerbivore: Although it might be a bit more complex on my laptop because I've got this AMD Radeon 8500m graphics card as well.
I think Win 8.1 has a problem with Catalyst Control Centre
Can you right click on your desktop & bring up CCC?
If you can, go to Switchable Graphics & run BG2 on high performance (forcing it to use your 8500M)
Then go to the scaling options in CCC under My Digital Flat Panels (or something like that)

Edit: Hopefully it will look something like this
http://support.amd.com/en-us/kb-articles/Pages/UnableToSetGPUScaling.aspx
Post edited November 18, 2013 by olnorton
avatar
AzureHerbivore: Although it might be a bit more complex on my laptop because I've got this AMD Radeon 8500m graphics card as well.
avatar
olnorton: I think Win 8.1 has a problem with Catalyst Control Centre
Can you right click on your desktop & bring up CCC?
If you can, go to Switchable Graphics & run BG2 on high performance (forcing it to use your 8500M)
Then go to the scaling options in CCC under My Digital Flat Panels (or something like that)

Edit: Hopefully it with look something like this
http://support.amd.com/en-us/kb-articles/Pages/UnableToSetGPUScaling.aspx
Hmm... No luck - no digital flat panels section. Thanks for the effort, though.
Maybe I'll try the AMD beta drivers. Or wait for Samsung to provide some more updates and finish off some of my other games instead. Everything else - Planescape, Arcanum etc. - is working fine.

Edit: I've managed to get BG2 running (but only in 800x600 so far) by disabling 3D acceleration in the config. Maybe this will work with the OP too?
Post edited November 20, 2013 by AzureHerbivore