It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I'm trying to run the latest GOG-Version of BG1 on Windows 8 64 Bit.

When i start the game it immediatly crashes with a message that reads:
"An Assertion failed [...] Programmers says: No valid video modes supported."

I tried several compatibility-modes and a newer video-card driver. Nothing helps, i can't start the game ;-(

My System:
Windows 8 64 Bit
Intel Core i5 3xxx
6 GB RAM
Nvidia Geforce 620 GT
Attachments:
error.jpeg (18 Kb)
This question / problem has been solved by Hickoryimage
It looks like you have installed the Widescreen Mod with an invalid video resolution. Please uninstall, read the the instructions and re-install.

You could also try running it in Windowed mode if you wish. Open baldur.ini and under [Program Options] find

Full Screen=1

and change it to

Full Screen=0
Hmm, i didn't install the Widescreen Mod. I just installed the GOG-version of BG1 and tried to start it.
I tried the "Full Screen=0" option in the "baldur.ini" but that didn't have any effect. I still got the error-message.

Is there a way to change the resolution of the game via "baldur.ini"?
avatar
sam_vimes: Hmm, i didn't install the Widescreen Mod. I just installed the GOG-version of BG1 and tried to start it.
I tried the "Full Screen=0" option in the "baldur.ini" but that didn't have any effect. I still got the error-message.

Is there a way to change the resolution of the game via "baldur.ini"?
There is no way to change the resolution in BG1 without the Widescreen mod, assuming you don't use TuTu or BGT. You aren't running the game in some sort of XP Virtual Machine, by any chance, are you?

You could also try posting your baldur.ini here to see if anybody can spot anything untoward.
Try going into your BG1 directory & running setup-ddrawfix.exe & select U for uninstall.
avatar
sam_vimes: Hmm, i didn't install the Widescreen Mod. I just installed the GOG-version of BG1 and tried to start it.
I tried the "Full Screen=0" option in the "baldur.ini" but that didn't have any effect. I still got the error-message.

Is there a way to change the resolution of the game via "baldur.ini"?
avatar
Hickory: There is no way to change the resolution in BG1 without the Widescreen mod, assuming you don't use TuTu or BGT. You aren't running the game in some sort of XP Virtual Machine, by any chance, are you?

You could also try posting your baldur.ini here to see if anybody can spot anything untoward.
Nope, no virtual machine. Just a fresh GOG-installation on Windows 8 64Bit.

Now i got the windowed mode working! This is weird, there are two "Program Option" sections in the baldur.ini.
You have to put "Full Screen=0" in the first section. The game starts at least, but in a tiny 640x480 window. But it's playable, yay :)
avatar
olnorton: Try going into your BG1 directory & running setup-ddrawfix.exe & select U for uninstall.
Can't find "setup-ddrawfix.exe" in the BG1-dir or subfolder. It is a "fresh" GOG-Installation now, changed nothing.
In windowed mode i tried several graphics options, but when i select "full screen" and hit "done" game crashes with the mentioned error :-\
Post edited May 28, 2013 by sam_vimes
OK, i got it now (finally)! GOG-Version is fine. My Nvidia driver 320.18 (May 2013) is crashing older games in 640x480 resolution on startup. I marked Hickory's tip as solution because window-mode made it at least playable.

I installed an older WHQL-Driver from mid 2012, everthing works fine now out of the (GOG-Setup) box :)
nVidia driver 320.18 is epic crap. It froze my computer 4 times in an hour: more freezes in an hour than I've seen in the last 15 years. I've returned to driver version 314.22, which is the previous one. There is no need (at least not on my computer) to go all the way back to a mid-2012 driver.

edit: it seems I was wrong. 820.18 is utterly unstable, crashing the computer while merely webbrowsing. While the previous version, 314.22 is more stable, it still seems to crash games. I've had BG1 crash on me several times in the third Cloakwood area.

Finally I've just returned to the driver I've been using the past few months: 310.70. (Luckily I always save the drivers I'm using, before upgrading.) It seems to be OK now; I've just finished Cloackwood 3 without a single crash.
Post edited June 07, 2013 by Katsunami