It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I’m running windows 7 on a widescreen monitor and want to play the game full screen but without distortion (i.e. not having the picture stretched). I was able to easily do this with my old computer by fixing the aspect ratio, which resulted in a picture that was not distorted, and black borders on the sides. However, this isn’t working with my new computer. I can’t seem to get the game to recognize any changes made to the display settings – the game ignores the changes. The game’s full-screen mode simply ignores the display settings for some reason.

Note, I don’t want to use the widescreen mod (I tried it already and ended up reinstalling the game from scratch)

Not sure if there is a solution here, but I’m hoping maybe someone has an idea on how to get the game to recognize changes in display settings.

More details:
My last PC had a separate graphics card (from nVidia), and by adjusting the nVidia settings to keep the aspect ratio fixed, I was able to run the game perfectly without distortion. The game filled most of the screen, with black borders on the side. This is what I am trying to do again now.

Recently I had to get a new PC. It’s a laptop and it’s hooked up to my old monitor, the same one I had success with before. I’m running Windows 7 now (old one was Vista). The new computer uses the “Intel Graphics and Media Control Panel” to adjust settings. Unfortunately, the BG game seems to ignore whatever changes I make. Whatever I do the result is the same: the game fills the screen, stretching and distorting the images. So, for example, if I set the resolution to something with a 4:3 ratio, my desktop has the black borders on the side, and other apps limit themselves to this viewing area. But when I launch BG, it ignores the settings and stretches to fill the screen.

I’ve already tried adjusting the BG program properties in the “Compatibility” section, trying such things as disabling display scaling, disabling desktop composition and visual themes.

I've tried setting the graphics control panel to fix the aspect ratio. Whatever setting I change it to, the game looks exactlythe same.

I’ve verified I have the latest device drivers for both the graphics card and the monitor

I also tried the widescreen mod. It made me very uncomfortable – the mod modified hundreds of files. I launched the game and it did work when in the playing screen, but the menus ended up tiny and virtually unreadable in the upper left of my screen. The whole thing made me nervous so I uninstalled the game and deleted all files, and reinstalled from scratch.

The closest I am able to get to a reasonable picture is to set my display to 800X600 and then play BG in a window by turning off full-screen mode in-game. This is not ideal, since the picture is smaller than it was before, it does not fill the screen vertically, and immersion is lost by the desktop, icons, and toolbars that are still visible around the window.

Is there any simple way to get the BG full-screen mode to adhere to the graphics settings I make in Windows 7?
Post edited November 28, 2012 by paladin1
avatar
paladin1: I’m running windows 7
Apologies if I've misunderstood, but it sounds like you're trying to adjust the video display from your computer's OS control panel. You sound thorough in your approach, but I don't see you mentioning that you tried from the BGconfig tool.

I understand that you used to use the control panel for your video card, and are now using your computer's regular control panel since you have integrated graphics, but why haven't you tried bgconfig? I've had no trouble adjusting display from there. I've also tried the widescreen mod, and while I don't use it myself because it makes the text too small, I don't know why it scares you.
Thanks for responding BlueMooner.

You are correct, I'm trying to adjust the video display from the computer OS not the game, which in the past worked great. I did try using Config.exe (and also Configure from within the game, which is the same), but it doesn't give any video options - mainly it just allows you to set up keyboard shortcuts. In searching the forums, I got the sense that only BG2 had a configure tool with video settings. However, if there is a separate configure tool, maybe I am just not aware of it and should look into it - I didn't see anything called BGcongfig.

As for widescreen mod, I don't like that it went in an changed hundreds of files, and in-game the menus (inventory, spells, journal, etc) all looked very small and had strange artifacts (like borders running down the screen, etc), which suggested something was wrong, and could lead to bigger problems down the road. I'd rather live with the stretched image.

What's frustrating is that this issue was easily fixed with my old PC, but with this one the game is ignoring the video idsplay settings.
A fews things to consider -

It could be your monitor is scaling the 800x600 image to make it stretched. Try fiddling with the buttons on it.

If you do NOT have the GOG release, make sure the game is patched. I think there are different official patches for with and without the TotSC expansion. (The GOG release is fully patched).

BG2 has a file BGconfig.EXE in the game folder, where you can set resolutions. Not sure what BG1 has (too long ago, I use BG Tutu to play BG1).

It sounds like the widescreen mod perhaps did not install correctly. (Or it may have limitations for BG1, see the readme). It is normal for it to modify lots of files, so no reason for concern there. If your complaint is that it makes everything too small, you are setting the res too high. Try going into your OS graphics options and making a custom resolution of 1066x600 (for 16:9 aspect screens) or 960x600 (for 16:10 aspect). If that res works for your OS, then install the widescreen mod for the same.
avatar
paladin1: ...
That's my fault. I'm so used to playing with tutu I forgot to check my BG1 folder; no, BG1 doesn't come with BGconfig.

Looking around, these are the options I see:

If you have BG2:
install easytutu mod for res options, or
install BGT mod for res options

If you don't have BG2:
do they make graphics cards for laptops?
switch to a different computer
use the widescreen mod. Pay attention to installation instructions!

The only other thing I can possibly think of is seeing if there's some tweak or option for your integrated graphics control panel. Sorry, these are the only options I can offer.
Thanks again for responding, both of you. (Very decent of you guys to try to help!)

I tried fiddling with the monitor buttons (good suggestion), but no luck. I am running the latest gog release (I did a fresh dowload to the new laptop and copied over the saved games).

Your probably right that I could fiddle with graphics options to get the widescreen mod to work better, but I want to avoid all the file changes it makes, so for now I am avoiding that mod.

The intel graphics control panel that comes with this laptop (or is it part of Win 7?) certainly allows me to change resolutions and fix aspect ratios, changing the desktop and affecting apps like MS Word, but the game doesn't recognize any changes I make (when in full screen mode). What I was hoping to find was a way to get the game to recognize the graphics setting from the OS, or have the OS force the game to adhere to the changes. This happened with no extra steps with my old computer - it was easy, just adjust the graphics settings and the game would run with black borders on the sides and no distortion. But with this new laptop, or due to Win 7, the game completely ignores the changes (when it is in full-screen mode, where it stretches instead of fitting to the desktop settings.

One question, are you thinking the BG2 BGconfig.exe would work on BG? Or do you mean I just won't have the problem later when I get the gog BG2?

My latest idea is to see if I can beg or borrow an old monitor with a 4:3 ratio.... or just live with it.