It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
... and the support article didn't help at all. Anybody had the same problem and was able to resolve it?

my relevant specs : Intel Q6600, 4GB RAM, GeForce 560GTX (1024 MB), Windows7 (32bit)
This question / problem has been solved by Emperor_Bertimage
avatar
sammyf70: ... and the support article didn't help at all. Anybody had the same problem and was able to resolve it?

my relevant specs : Intel Q6600, 4GB RAM, GeForce 560GTX (1024 MB), Windows7 (32bit)
Same problem here Win7 64bit
intel i7, 8gb ram, ati 5870 (rig is up-to-date)
avatar
sammyf70: ... and the support article didn't help at all. Anybody had the same problem and was able to resolve it?

my relevant specs : Intel Q6600, 4GB RAM, GeForce 560GTX (1024 MB), Windows7 (32bit)
avatar
Emperor_Bert: Same problem here Win7 64bit
intel i7, 8gb ram, ati 5870 (rig is up-to-date)
OFP Startup Parameters

While these were written up for OFP, they should be applicable to CWA
Use -nomap - that should do the trick.
Post edited September 20, 2011 by Anguis
I tried -nomap yesterday (it's mentioned in the support pages), but that didn't help neither.
On this page :
http://community.bistudio.com/wiki/Operation_Flashpoint:_FAQ:_Troubleshooting#I.27m_getting_an_error_message_box_that_says_.22Out_of_reserved_memory.22_and_.22Code_change_required.22
they say to decrease the visibility to 900m. I'll have to try it later when I'm back home.
Post edited September 21, 2011 by sammyf70
I tried both solutions including decreasing the visibility distance. Sadly the error is still there.
Gonna give the "Enhanced Configuration Project mod" a shot. can't find a link though. :(
Post edited September 21, 2011 by Emperor_Bert
avatar
Emperor_Bert: I tried both solutions including decreasing the visibility distance. Sadly the error is still there.
Gonna give the "Enhanced Configuration Project mod" a shot. can't find a link though. :(
It worked for me. I ran the autoconfig in the external preferences programm then set distance at slightly under 900m, terrain details at normal, The other in-game options are all maxxed out, resolution is at 1680x1050x32 which is my monitor's native resolution. (Textures still look like 16bit despite the 32bit setting btw.), and it works. increasing the terrain details to high produces the out of mem error.

I would say BIS just set the maximal settings ~available~ much higher than was possible at the time the game was released without actually testing at all whether the game would run at those settings (my guess is that there was no hardware at the time that could have done it), so those "very high detail terrain " and 5K visibility settings are purely "for show".
Post edited September 21, 2011 by sammyf70
avatar
Emperor_Bert: I tried both solutions including decreasing the visibility distance. Sadly the error is still there.
Gonna give the "Enhanced Configuration Project mod" a shot. can't find a link though. :(
avatar
sammyf70: It worked for me. I ran the autoconfig in the external preferences programm then set distance at slightly under 900m, terrain details at normal, The other in-game options are all maxxed out, resolution is at 1680x1050x32 which is my monitor's native resolution. (Textures still look like 16bit despite the 32bit setting btw.), and it works. increasing the terrain details to high produces the out of mem error.

I would say BIS just set the maximal settings ~available~ much higher than was possible at the time the game was released without actually testing at all whether the game would run at those settings (my guess is that there was no hardware at the time that could have done it), so those "very high detail terrain " and 5K visibility settings are purely "for show".
thx a lot! With the terrain at normal it works!
please realize ECP (Enhanced Configuration Project) is just normal modification
it would not solve the 'out of memory' ... if it helps then it just hinders it

these high settings works but the question what breaks can't be answered w/o crashdumps or process dumps from freezed/crashed state
Post edited September 21, 2011 by Dwarden
Just a wild guess but I think the graphics engine has no means of downscaling distant objects in the memory (like popping), therefore the needed memory increases immensly with every meter of visibility, even outrunning modern scales like 8 GB. An other guess would be OFP being a 32bit application simply not reconning with more than 3 GB. Whatever the cause, the solution is a little painfull but the game should run fine if you limit the visibility in the options menue. Decreasing the object resolution in the launcher may also help. I looked some time for a better solution but didn't find anything else.
It's Operation Fogpoint, you better like it! ;-)
One of Bohemia Interactive dev posted on Steam forum that you should consider lowering the viewing distance if you choose higher terrain detail. Or else just stick with normal. This is known problem, you'll suffer from choppiness at High or Very High no matter how good your PC specs.