It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have this game but can not for the life of me figure out how to get it to play. The instructions here are not step by step enough for someone that doesn't know a think about computers.

I've tried setting the compatibility to all of the older versions. I've tried deleting or renaming the ddraw.dll . None of this stuff works for me. And I have no idea what any of that "commandline" stuff means or where to find it.

I need someone to give me step by step instructions on what to do. I miss playing this game a lot. I feel like Windows 8 is nothing but a huge headache.
Cleanse your pc of windows 8 by using fire.
avatar
ewmarch: Cleanse your pc of windows 8 by using fire.
Fire, and then an acid bath, and then boil the acid. :p
I just wanted to chime in here and say a huge thanks to whoever suggested the Wine DLL fix. Works a charm.

I had to download an earlier release from 2013, as the newer release seemed to be missing ddraw.dll. I'm only using the hi-res patch (forgot about the unofficial patch prior to playing, and don't want to lose my save game), but it works flawlessly in Win8 64-bit.

Thank you sir, you've saved me the hassle of using a VM!

edit: forgot to mention, I'm using the -no3d flag as well.

For anyone trying to find the DLLs, just Google "wined3d.dll site:nongnu dot org" (replace dot with, you know, an actual dot), and go to the top link. Go to the full directory, and go for one of the 2013 releases - I think I went for 1.1.38. Download the installer .exe, and use 7zip to extract it. Go to the extracted $SYSDIR directory, and copy the libwine.dll, wined3d.dll, and ddraw.dll files into your Arcanum folder (might want to rename the existing ddraw.dll file, just in case). Launch the game with the -no3d flag by modifying the shortcut and that should do it.
Post edited July 07, 2014 by adfielding
avatar
adfielding: For anyone trying to find the DLLs, just Google "wined3d.dll site:nongnu dot org" (replace dot with, you know, an actual dot), and go to the top link. Go to the full directory, and go for one of the 2013 releases - I think I went for 1.1.38. Download the installer .exe, and use 7zip to extract it. Go to the extracted $SYSDIR directory, and copy the libwine.dll, wined3d.dll, and ddraw.dll files into your Arcanum folder (might want to rename the existing ddraw.dll file, just in case). Launch the game with the -no3d flag by modifying the shortcut and that should do it.
This is the only thing that solved the issue for me, thank you so much for submitting and finding this odd fix!
So happy to be able to play without VM!
avatar
themendios: Alright, finally found something that works and it's pretty simple

Just add "-window" to the shortcut. Also tell it to do maximized on the shortcut if it's below native.

I did this in addition to the stuff I just posted and it's now perfectly fine.
All I did was add the "-window" to the target name and it seems to have fixed my issues for running in Windows 8. Thanks!
Running Windows 8.1 64 bit, used -no3d -doublebuffer along with 3 3 dll from June 2013. Works amazing! Thanks all.
Post edited 21 minutes ago by BlueMerlin