It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi guys i just installed the game on my new computer, a i7 with windows 7 64 bits the game works perfect even with HD patch. But with this patch or without it, i just cannot see the introductory videos, i just can hear it, but not seen it.

Maybe i lack some video driver?
I doubt that it's because of the video driver.... Try to install all DirectX files (from MS site) and then try.
Yeah I have trouble with my copy as well as a few other GOG.com games and compat. mode doesnt fix it. When i get into the game it goes all flickery, it happens in Empire Earth and Dragonshard as well as Arcanum. Quite annoying because Empire earth in particular is an old favourite of mine. Someone told me that they had that issue with their ATI card so I gave up thinking that was it. Will try this though.
Hello all, I have installed the gog version and it ran fine. After 30+ hrs, I decided to d/l and install the Arcanum_uptolevel127_1074 mod. I followed the instructions (renaming the original .exe etc), but the mod won't run... The original ofc does. The error msg I am getting is "No Disc Inserted"... Pls note I did try uninstalling everything and then reinstalling the gog version and then the patch (twice)...
How do I fix this so it actually runs?
Thanks in advance...

May have found a solution.... found a patch via google on
%20No-CD/Fixed%20EXE]http://www.gamecopyworld.com/games/pc_arcanum.shtml#Arcanum%20v1.0.7.4%20[ENGLISH]%20No-CD/Fixed%20EXE

Excellent! It works!
Anyone knows this patch? Any warnings or issues?

Update: The patch works, more or less, but now I do not get random encounters. Is this a normal side-effect of going over lvl 50???
Post edited December 29, 2011 by Ghaeros
Hello I have recently bought the Arcanum and its simply an amazing game however I have encountered serious issues that I cant seem to get rid off.
Number one among them is inability to enter certain areas such as tarant sewers and more importantly Black mountain mines. Let me tell you what happens.
Problem starts when I click on entrance to the area at that point game lags, almost freezes in fact cursor hardly moves and I can enter main menu only with great difficulty.
Map button turns blue as if I was about to enter world map and music appropriate for the area starts to play but thats it.
So far I have tried following: clean install with only UAP applied, previous with -doublebuffer and -no3D, UAP with hires patch and map fixes, all of this while running the exes as administrator and nothing.
Does anyone know what to do?
avatar
Dalexon: Hello I have recently bought the Arcanum and its simply an amazing game however I have encountered serious issues that I cant seem to get rid off.
Number one among them is inability to enter certain areas such as tarant sewers and more importantly Black mountain mines. Let me tell you what happens.
Problem starts when I click on entrance to the area at that point game lags, almost freezes in fact cursor hardly moves and I can enter main menu only with great difficulty.
Map button turns blue as if I was about to enter world map and music appropriate for the area starts to play but thats it.
So far I have tried following: clean install with only UAP applied, previous with -doublebuffer and -no3D, UAP with hires patch and map fixes, all of this while running the exes as administrator and nothing.
Does anyone know what to do?
Dalexon, does it happen to particular save or to all saved games?

I was wandering Tarant sewers to find and kill Pollock. I saved game while my team was running and then lags began. It's practically impossible to do anything. I've been wainting 20 minutes but golden loading clock seems to be permanent. I must use task manager to exit the game. I've tried reinstalling - problem's not gone.

And Dalexon, my question was because saves from early stages work fine.


Any tips fellows?