It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
As the title states. The mouse is far too slow in the game, plus a little jerky. This is my first time playing the game (after years of wanting) but I just can't enjoy it like this.
I have looked through the options and found no mouse sensitivity, the config file doesn't have it in there either.
As it is the game is simply unplayable, when every movement is just annoying and thanks to the slight jerkiness it can be infuriating just talking to people.
I have done -no3d -doublebuffer, which has helped with minor graphic problems. I have also installed the high res mod, Hi res towns, UAP and the mp3 music mod (which I can't think of it's name). With or without them I still have this issue.
Anyone know how to fix this?
avatar
sera: As the title states. The mouse is far too slow in the game, plus a little jerky. This is my first time playing the game (after years of wanting) but I just can't enjoy it like this.
Anyone know how to fix this?

Updating the mouse drivers solved a similar problem :
http://www.gog.com/en/forum/arcanum_of_steamworks_and_magick_obscura/sluggish_mouse/1
Post edited July 27, 2010 by Kezardin
I use a Logitech G5 with the newest drivers so that's not the problem.
I figured out why its jerky at least. If I move the mouse too slow it just doesn't pick it up at all, so I kept moving it slow to do precise selections but it would only pickup some of my movement making it appear jerky. So basically if the mouse is faster this problem will fix itself
avatar
sera: ...

Are you running Vista / Win 7? If not ignore me . . . =)
You have probably already done this but . . . did you right click the game shortcut, click properties, click the Compatibility tab and check "Run as an administrator" Also, try the Win 98/Win ME compatibility mode. Disabling visual themes and destop composition on the same tab might help as well.
Certain resolutions don't work well on some systems. Go to the Arcanum install directory and find the HighRes.bat file. Right click and "Run as an administrator" an set it to a standard res such as 800 x 600 or 1280 x 800 instead of 1280 x 768 and see if the problem goes away. If so try using other standard resolutions until you find one that works on your screen without the stutter.
If the alternate resolutions don't help, use the HighRes.bat file to uninstall the High res mod and see if the problem is fixed. If the HR mod was not installed as and admin it can cause some odd behavior. You mentioned uninstalling the HR mod so . . . just make sure you run the HighRes.bat file as an admin every time.
If you installed everything as an admin, including the mods, there is no need for a reinstall. If not, reinstalling everything as an admin may help. I would also suggest turning UAC off during the install and installing in a directory outside of Program Files, especially on Win 7. Make sure you backup your saves first and uninstall the game followed by deleting any directories / files remaining under Program Files\GOG.com\Arcanum. I use C:\Games on my Win 7 system.
If all else fails, take a look at the Arcanum support page and open a help ticket with GOG support. . . =)
Edit: If you are running a dual core CPU; did you try setting the affinity to a single core? Are you running an AMD CPU?
Post edited July 28, 2010 by Stuff
I always have UAC turned off, the potential gain just isn't sufficient for how annoying it is.
As for the rest of your suggestions, I had overlooked changing compatibility mode but that didn't help at all. Everything else I have changed exhaustively.
I can use setpoint (logitech driver) to dynamically change mouse sensitivity while entering the game. Only problem is that it sucks at resetting it, so when I exit, the mouse is way too fast. I tend to leave this feature disabled since it is waaay too annoying but as a last resort I can at least make the game playable with it.
Oh and thanks for your reply.
Post edited July 28, 2010 by sera
same here, after installing the hires patch my mouse became quite slow in-game...
Like Fallout and a lot of other old games you need to turn off any mouse acceleration in your Logitech control panel to have normal mouse movement.
avatar
StingingVelvet: Like Fallout and a lot of other old games you need to turn off any mouse acceleration in your Logitech control panel to have normal mouse movement.

Sir, I do believe I love you and would like to have your child. Now just to adjust my mouse as it is a little fast for my taste now ^_^
avatar
StingingVelvet: Like Fallout and a lot of other old games you need to turn off any mouse acceleration in your Logitech control panel to have normal mouse movement.
avatar
sera: Sir, I do believe I love you and would like to have your child. Now just to adjust my mouse as it is a little fast for my taste now ^_^

Cool, glad it worked!
avatar
sera: Sir, I do believe I love you and would like to have your child. Now just to adjust my mouse as it is a little fast for my taste now ^_^
avatar
StingingVelvet: Cool, glad it worked!
I am now having this issue with a Logictech G700 mouse but I don't know how to shut off acceleration. Please help!
avatar
thegreatwar: I am now having this issue with a Logictech G700 mouse but I don't know how to shut off acceleration. Please help!
Install the drivers and setpoint. Go into setpoint and mouse settings. There will be settings for acceleration there, as well as "use windows settings for acceleration" which you should also turn off.
avatar
thegreatwar: I am now having this issue with a Logictech G700 mouse but I don't know how to shut off acceleration. Please help!
avatar
StingingVelvet: Install the drivers and setpoint. Go into setpoint and mouse settings. There will be settings for acceleration there, as well as "use windows settings for acceleration" which you should also turn off.
I set acceleration to 0 as well as turning off the "use windows..." thing. No difference. I read through the forum and some people suggested a couple fixes I might be able to type in the "target" line after getting into Arcanum's shortcut properties. like -no3d and -doublebuffer Those didn't work either. I have been trying to fix this for a couple hours now and I really want to play this game, but I cant even get past the title page because my mouse moves so awkward and slow. I am pretty frustrated. Thank you for trying to help though. Anymore insights?
I have a G700 and have the same issue.

What I have done to fix it is to set Mouse speed in Windows to maximum, then setting the mouse speed to level 3 on the mouse itself with the G buttons (fastest speed)

Once this is done , the mouse works a lot better.

Hope this helps you.