It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi all,

I just installed Arcanum and I'm having a problem with the graphics. Here's what happens: Upon start up, during the logo animations of Sierra and Troika, there is flickering. Then the "Loading" screen appears and everything is fine for the moment. Then the first cinematic plays. First, the cinematic flickers and sometimes single frames appear and overlap the movie as it runs. Also, off to the left side, I can still see part of the "Loading" graphic which hasn't fully disappeared. Then the screen burns away and I see the start menu. Part of the "Loading" graphic is still visible off to the left. My mouse leaves a ghost trail behind it as I move it. When I go into any of the menus, the graphics sometimes flip back to the previous menu and then back to the current one. It makes the game rather unplayable.

Now, before anyone mentions the usual solutions, here is what I have done so far:
1) Installed the game in C:/Games
2) Installed the Unofficial Patch, High-Res Town Patch, High-Res Patch and Music Patch all as an administrator
3) I have modified the shortcut to the game with -no3d -doublebuffer in the Target field and checked the "Run this program as an administrator" box. I have also disabled visual themes and desktop composition.
4) I have tried different resolutions under the High-Res patch, but that has not made a difference so far

I'm hoping someone can suggest an new way of fixing my problem. Any ideas?

Thanks in advance,
Sir Grail
What kind of graphics card do you have? What OS are you using? If you're in Vista or Windows 7, have you tried using compatibility modes when running the game?

I also wonder if updating your graphics drivers and/or directx will help, as it certainly sounds like some sort of grpahics codec issue. I'm surprised at how often new graphics drivers will help fix issues in an old game. Although if you're using the "-no3d" line maybe it's not applicable in your case.

Also, did you try the game without the patches? Specifically the high-res patch, since it changes graphics settings... make sure you get the same issues with the base game.

Anyone else have other ideas?
Thanks for the response, Waltorious.
avatar
Waltorious: What kind of graphics card do you have? What OS are you using? If you're in Vista or Windows 7, have you tried using compatibility modes when running the game?
I have two SAPPHIRE Vapor-X Radeon HD 4870 2GB 256-bit GDDR5 PCI Express 2.0 x16 HDCP Ready CrossFire Supported Video Cards in my computer. I have Windows Vista. I tried various compatibility modes, but none fixed the issue.
avatar
Waltorious: I also wonder if updating your graphics drivers and/or directx will help, as it certainly sounds like some sort of grpahics codec issue. I'm surprised at how often new graphics drivers will help fix issues in an old game. Although if you're using the "-no3d" line maybe it's not applicable in your case.
My drivers got updated a couple months ago. I had not updated the drivers in over a year and when my friend, who built my computer for me, found out about it, he updated them. There were some issues involved with that so I'm not inclined to do it again unless he's around to help me out. I hope that's not the issue. I tried running the base game without the "-no3d -doublebuffer" addition and the problem did not change.
avatar
Waltorious: Also, did you try the game without the patches? Specifically the high-res patch, since it changes graphics settings... make sure you get the same issues with the base game.
I just tried it without the patches and the same issues were there with the base game. I installed the Unofficial Patch, but not the High Res patches, and the issue is the same.

Anyone else have any suggestions? I'd appreciate it.
Well, I'm out of ideas except for updating your graphics drivers... usually that's a rather painless process, but if you were having issues before I can understand if you want to wait before trying it.

And if anyone else has some ideas, please post.
Had the same problem as the original poster. Was going to rage quit and not even bother when I read Waltorious's post about updating graphic drivers. Worked like a charm.

Windows 7 64bit
ATI Radeon HD 4870x2
Updated to the latest Catalyst release 1/26/11
comparability mode Windows XP sp3

All mouse trails and graphics overlaps fixed. Thank you Waltorious!
I had the same problem after installing the high resolution patch. It turned out that I just had the patch set for a resolution my computer didn't support. Check and see if that's the problem.
I know this is a bit of a gravedigging but I just bought the game and would like to help to new-users.

If you are having issues with games (Arcanum and others) in means of screen flickering and overlapping images, disable crossfire / sli option of your graphics card before playing the game. It fixes the issue.

Driver re-installing / updating may not always work with the problem, so this is the known fix for such cases.
avatar
oganalp: I know this is a bit of a gravedigging but I just bought the game and would like to help to new-users. If you are having issues with games (Arcanum and others) in means of screen flickering and overlapping images, disable crossfire / sli option of your graphics card before playing the game. It fixes the issue. Driver re-installing / updating may not always work with the problem, so this is the known fix for such cases.
You did well to post, it is the solution!
I searched a solution for hours trying and reinstalling the game, command lines with -no3d switch and others... you posted the only solution that works and you are the only one who proposed it for Arcanum.
I had same behavior with other games like Planscape Tornment but a fix exists for that game, I guess disabling crossfire is working also, no need a fix.
Thanks a lot :)
Post edited October 12, 2012 by arnor2000
avatar
oganalp: I know this is a bit of a gravedigging but I just bought the game and would like to help to new-users.

If you are having issues with games (Arcanum and others) in means of screen flickering and overlapping images, disable crossfire / sli option of your graphics card before playing the game. It fixes the issue.

Driver re-installing / updating may not always work with the problem, so this is the known fix for such cases.
to anyone who still has the intro/cutscene overlapping/flippering problem [this method assumes you have integrated graphics card & xp/w7/w8]: switch over to your integrated graphics card your VGA control panel. now check yr directx config by start -> run -> dxdiag -> display and see if directdraw/direct3d acceleration is enabled. if so, disable it from there if you can. if not, dl the ms dx control panel and you should be able to do so. http://www.majorgeeks.com/Microsoft_DirectX_Control_Panel_d4017.html
the are 2 checkboxes related to hardware acceleration, one in direct3d, the other in directdraw. uncheck them and try the game.
found this while searching for a solution to fix the cursor-leaving phenomenon in icewind dale. yea, it worked. remember to re-enable them after you exit the game. or else... exactly.
avatar
sirgrail: Hi all,

I just installed Arcanum and I'm having a problem with the graphics. Here's what happens: Upon start up, during the logo animations of Sierra and Troika, there is flickering. Then the "Loading" screen appears and everything is fine for the moment. Then the first cinematic plays. First, the cinematic flickers and sometimes single frames appear and overlap the movie as it runs. Also, off to the left side, I can still see part of the "Loading" graphic which hasn't fully disappeared. Then the screen burns away and I see the start menu. Part of the "Loading" graphic is still visible off to the left. My mouse leaves a ghost trail behind it as I move it. When I go into any of the menus, the graphics sometimes flip back to the previous menu and then back to the current one. It makes the game rather unplayable.

Now, before anyone mentions the usual solutions, here is what I have done so far:
1) Installed the game in C:/Games
2) Installed the Unofficial Patch, High-Res Town Patch, High-Res Patch and Music Patch all as an administrator
3) I have modified the shortcut to the game with -no3d -doublebuffer in the Target field and checked the "Run this program as an administrator" box. I have also disabled visual themes and desktop composition.
4) I have tried different resolutions under the High-Res patch, but that has not made a difference so far

I'm hoping someone can suggest an new way of fixing my problem. Any ideas?

Thanks in advance,
Sir Grail
I am having the same issue... does anyone have any ideas?

(sorry for the semi necro)
Minor correction:
I'm having black squares and loading flicker on all the videos, other than that looking good
Post edited March 06, 2013 by BrotherJayne
Nobody else has had this happen?
avatar
BrotherJayne: Nobody else has had this happen?
I had the graphic issues but the solution I posted fixed the ones for me. I have changed my graphics card after that but I didn't re-install the game. If I ever bump into an issue and to its fix, I will post here.
Just had the same problem as described - disabled Crossfire and the flickering was completely fixed and no ghosting of the cursor.
avatar
klubrotator: to anyone who still has the intro/cutscene overlapping/flippering problem [this method assumes you have integrated graphics card & xp/w7/w8]: switch over to your integrated graphics card your VGA control panel. now check yr directx config by start -> run -> dxdiag -> display and see if directdraw/direct3d acceleration is enabled. if so, disable it from there if you can. if not, dl the ms dx control panel and you should be able to do so. http://www.majorgeeks.com/Microsoft_DirectX_Control_Panel_d4017.html
the are 2 checkboxes related to hardware acceleration, one in direct3d, the other in directdraw. uncheck them and try the game.
found this while searching for a solution to fix the cursor-leaving phenomenon in icewind dale. yea, it worked. remember to re-enable them after you exit the game. or else... exactly.
thank you thank you thank you. Worked perfectly!