It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi everybody,
does anybody know if it is possible to play kingpin in 1280x800?
Thanks
avatar
toto73: Hi everybody,
does anybody know if it is possible to play kingpin in 1280x800?
Thanks

I've tried custom resolutions before, they didn't work. I don't think that it's possible with Q2 engine games, without modifications to the source code. Also there's the Q2 FOV bug, where if your FOV value is above the default (90, I think), then the gun becomes invisible.
Post edited September 14, 2008 by EvaUnit02
Don't think so. It doesn't allow it in the games settings and playing around with the games config files does nothing either. Looks like it's just a case of a game made before non standard wide screen resolutions became the norm.
might want to check out that widescreen gamers place.
Kingpin does not support widescreen or any custom resolutions. If it is not listed as an option ingame, you can't use it.
Some fresh news: widescreen mode IS possible with Kingpin and it works perfectly!!
I wrote a first version of this post yesterday, while I was still attempting to fix some problems I had encountered. Now I have solved them all, so I am editing everything here to give you the final results of my experiments. It works!
This widescreen solution is based on an available hack for Daikatana, which also uses a Quake II-based engine. You can find the complete explanation here: http://rome.ro/smf/index.php?topic=6582.0;wap2 Thanks to Fresch, we now have a widescreen fix for Q2 engine that also applies to Kingpin.
Basically, this hack uses the highest resolution available, 1600*1200, and changes hexadecimal values to match those of a custom widescreen resolution. To do this, you must use an hexadecimal editor and open kingpin.exe file. Some excellent freewares are available on the net to do the trick - search Google.
I have tried a resolution of 1440*900 successfully, on Windows 7 x64 professional. In addition to the explanations on the link provided, here are special steps you MUST do in order not to crash the game or to end with unexpected results:
- copy both kingpin.exe and config.cfg on your desktop (config.cfg is in \*directory*\main\; with Vista and 7, this file is moved to Virtual Store by UAC if the application is not run as administrator - check Compatibility Files while browsing your Kingpin directory to find it). Make a backup of original files!
- apply the Daikatana widescreen hack in kingpin.exe as explained in the link
- open config.cfg and be sure to have the following values set correctly:
"set gl_mode 6" // this is the 1600*1200 in-game setting, which has been changed to custom widescreen resolution
"set fov 90" // I mistakenly asserted that setting fov to 100 would work perfectly; in fact this doesn't apply with Kingpin. Not only guns are not drawn anymore with this setting, but it also streches what is displayed. Usually, a 4:3 fov 90 corresponds to a 16:10 fov 100, but it is not the case here. I have compared many screenshots taken at the same spots ingame, and I can confirm that you must still use fov 90. Image is not stretched, but you lose some vertical portions ("Vert-" scaling: top and bottom of the display are cut off).
"set vid_fullscreen 1" // runs game in fullscreen mode, otherwise game would load in a window even with a correct resolution setting and you would have to setup everything manually each time you run the game again
"set viewsize 100" // a VERY important setting !! This is the "screen size" ingame option, which would be set to 110 if cursor is set to the far right. But by doing so, game struggles to launch fullscreen and crashes back to Windows desktop. So keep this value on 100, the slider will not be on the extreme right but it is normal.
Once you are done with config.cfg, open its properties and set it to "read only" to prevent kingpin.exe erasing your values. Paste both files into the original game folder (on Vista or 7, kingpin.exe in game folder and config.cfg in the Virtual Store, where you initially found it).
If you apply those tips, you should not encounter any problem: Kingpin game runs nicely, guns are drawn, and image is not stretched. Only con is, top and bottom of the display are cut, but it is not much of a problem as HUD elements are not hidden in the process.
I hope this widescreen fix will also work for you GOG.com customers! Please give a try and post some feedback here. Don't forget to backup your original files before any attempts.
Cheers, UnF
Post edited April 26, 2010 by UnF
Here are some screenshots attached to this post to show differences between 1024*768 mode and my tweaked 1440*900 mode. As you see, widescreen images are basically the same without top and bottom parts, and with adjusted HUD elements.
Here is also an animation: 1440*900 screenshot is reduced into a 1024*768 one... No stretching at all. Click on the link to see it: http://pix.wefrag.com/i/d/4/1/c/5/156285075ea4cf8a3a8d6c9cb95d46bc.gif
Attachments:
Post edited April 26, 2010 by UnF
Wow, awesome! Thanks a bunch.
I had some problem with 1920x1080, though. I went to page two of the Daikatana guide and put in the exact value as listed, but it only pops up in a window. 1280x720 works fine, but nothing above that.
It's definitely full/widescreen, but I'd like for it to be my native res. Anyone have any clues?
Oops, it's my fault, I forgot to give a more complete list of widescreen hex values than Daikatana's guide.
Your values should be:
1920 x 1080
80 07 38 04
I hope it works because I won't be able to test it myself! But I'm glad it already works in 1280x720 ;-)
I'll try to find a complete list of values, but before I do so, here is an explanation everybody can use. Hex values can easily be calculated for any resolution (5:4 included, or 15:9, 16:9, 16:10 or higher, you name it) using Windows' calculator in scientific mode (or better, programmer mode on Windows 7).
1) Calculator must be set in decimal mode (dec);
2) Type a value (for example, 1920);
3) Change to hexadecimal mode (hex);
4) The value will change to hex mode (in our example, 780);
5) Using your awesome brain, add a zero in front of this value (780 --> 0780);
6) Split the value in 2 groups of 2 digits and reverse them (07 // 80 --> 80 07);
7) You're done, enter this value into your .exe file with a hex editor.
Hope it helps, everybody should find something suitable... But keep in mind that I am limited in screen size with my computer, so I haven't tested everything! I'm pretty confident that every ratio should work (after all, Kingpin is based on Quake II engine, by Mr. Mastermind John Carmack ;-)) but I have only tested 16:10 ratio (1440*900).
EDIT: Damn, I should read more carefully! I'm so dumb, I wrote all that BS for nothing as I didn't see you were speaking about a page 2... Where a complete list can be found! Well at least my method provides correct values.
But I'm very disappointed 1920x1080 doesn't work... You should try to decrease "Screen Size" option in the menu. When I was doing a lot of tweaking, I had exactly the same problem and the game was also crashing. I think that setting screen size more than 100 opens game in a window, but I'm not sure about that. Then check your config.cfg file after your ingame modifications: what are the values of "set vid_fullscreen" and "set viewsize" ? Sometimes, config.cfg does not save your settings correctly. To this day for example, I'm still not able to keep "Texture Quality" on high, I have to set it manually everytime I play :-( Even with "read only" enabled!
What worked for me was to redo anything from the start: I deleted my tweaked files, replaced them with original ones, and tried again using my method provided in the first post. This game can be weird... At my first attempt, everything was OK except FOV, then I tried to change gl_mode to 6 instead of 9 (I was mistaken because of a "mode 9" in kingpin.exe, but in config.cfg it has to be 6) and since then the game was opening in a window and couldn't display anything more than 1 second; then it was crashing. My only guess is that we shouldn't mess with "Screen size" value and let it by default (slider not pushed to the far right).
EDIT 2: what happens if you press ALT+TAB when your 1920*1080 game is running in a window? Does it go fullscreen or crashes?
Post edited April 26, 2010 by UnF
well, I've done everything according to the instructions to set my res to 1680x1050, but I can't tell if it worked or not. The resolution setting still says 1600x1200 even after I went so far as to change the "1600x1200" text values to "1680x1050" using a hex editor (HxD, to be precise), which automatically changed the hex values for the text, so I should have seen at least that change.
avatar
predcon: well, I've done everything according to the instructions to set my res to 1680x1050, but I can't tell if it worked or not. The resolution setting still says 1600x1200 even after I went so far as to change the "1600x1200" text values to "1680x1050" using a hex editor (HxD, to be precise), which automatically changed the hex values for the text, so I should have seen at least that change.

You have done everything right: In-game settings will still display 1600*1200 - of course these numbers are now wrong because the corresponding hex values have been changed. I know this is not perfect. Ideally we should have the correct values in the menu, but I don't know how to do it. Most important is to have in-game setting set to 1600*1200, so the game will use the modified hex values.
If you want to check if the game is really widescreen after your tweakings, maybe you can notice how weapons are rendered: the very bottom of the weapon should be cut (for example on the "kingpin 3" screenshot I posted above - 7th reply -, we see that the hand of the player is not drawn on the flamethrower in widescreen).
Hope it helps... Kingpin is annoying when going widescreen, I've had new crashes since I've updated some drivers! Other Quake 2 based games are less picky.
Thanks a lot, I'll try it soon.:)
i've wanted to do this with KINGPIN too, but i dont get the daikatana tutorial.
in my hex editor a resolution like1600x1200 is shown in this hex form:
31 36 30 30 78 31 32 30 30
i want to change it in 1600 x 900 ... but it says it says 900 is = 84 03 in hex, but this cant be possible, i need 8 digits for it.
am i to stupid or do i overlook something?
ahh now i understood, its a diffrent place, to search for the 1600 is just so its easier to find.
but i have a problem: when i change the values from B0 04 to 84 03 kingpin doesnt start anymore?!
it says error in exe.
hmm?!
ah by the way its code 51 i get on steam (yes i got the game there)
is it possibile steam "detects" that i have edited the exe and denies the start of it? this would be ... horrable!